
  



Teknik Actionscripting dalam Pembuatan 

Presentasi Multimedia Interaktif 

 

 

 

 

Oleh: Fitro Nur Hakim, S. Sn., M. Sn.  



Teknik Actionscripting dalam Pembuatan Presentasi Multimedia 

Interaktif 

 

Penulis: 

 

 

 

Editor: 

Edy Jogatama Purhita, S.Sn., M. Ds. 

 

Penyunting: 

Danang, S. Kom., M.T. 

 

Desain Sampul dan Tata Letak: 

Fitro Nur Hakim, M. Sn. 

 

 

Penerbit: 

Yayasan Prima Agus Teknik 

Redaksi: 

Jln Majapahit No 605 Semarang 

Tlpn. (024) 6723456 

Fax. 024-6710144 

Email: penerbit_ypat@stekom.ac.id 

 

 

Distributor Tunggal: 

UNIVERSITAS STEKOM 

Jln Majapahit No 605 Semarang 

Tlpn. (024) 6723456 

Fax. 024-6710144 

Email: info@stekom.ac.id 

 

Hak Cipta dilindungi Undang undang  

Fitro Nur Hakim, S. Sn., M. Sn. 

ISBN: 978-623-96089-8-9 

  

Dilarang memperbanyak karya Tulis ini dalam bentuk apapun  



HALAMAN PENGESAHAN 

 

Judul Buku Ajar  : Teknik Actionscripting dalam Pembuatan 

Presentasi Multimedia Interaktif 

Mata Kuliah  : Presentasi Multimedia 

Nama Penulis  : Fitro Nur Hakim, S. Sn., M. Sn. 

NIDN  : 0617097801 

Progdi  : Desain Grafis 

Fakultas  : Fakultas Komputer dan Bisnis (FKB) 

Unit  : Universitas Sains dan Teknologi Komputer 

 

 

 

 Semarang, 8 Februari 2021 

 

 

Menyetujui, 

 

Kaprogdi S1-Desain Grafis Ketua Penerbit YPAT 

 

 

 

Edy Jogatama Purhita, S.Sn., M. Ds. Danang, S. Kom., M.T. 

NIDN. 0603097101 NIDN. 0615098702 

 



PRAKATA 

  

Alhamdulillah pada akhirnya penyusunan buku tentang pembuatan 

Presentasi Multimedia ini telah mencapai garis finish. Selama menulis 

buku ini penulis terinspirasi dengan karya-karya multimedia yang sangat 

kreatif beredar di dunia internet maupun yang penulis jumpai secara 

langsung di berbagai event seminar. Kreativitas ini menurut penulis haru 

dituangkan secara teknis untuk membimbing para pelajar dalam 

menyampaikan ide-ide mereka secara lebih lugas dan visual. Memadukan 

karya kreativ kedalam aksi langsung saat berada dipanggung adalah hal 

yang sangat mengasyikkan, namun hal ini tentu didukung dengan media 

yang mumpuni pula. 

Tidak bermaksud menggurui, buku ini mulai mengajak Anda yang ingin 

tampil presentasi dengan elegan, layaknya profesional. Tentu media haru 

didesain dan ditata dengan persiapan matang. Buku ini memandu dari awal 

bagaimana Anda dapat membuat Presentasi Multimedia yang dapat 

membantu kesuksesan Anda menyampaikan ide atau gagasan dihadapan 

publik. Adapun susunan buku ini meliputi pengantar teoritis tentang 

multimedia dan bagaimana membuat komponen-komponen tersebut masuk 

dan terintegrasi kedalam media Presentasi Anda. Panduan dalam buku ini 

sangatlah mudah dan praktis, sehingga dapat diikuti dari tingkat awam 

sekalipun.  

Popularitas utama dalam menyiapkan media presentasi diraih oleh Flash 

yang mana software-software di internet banyak mengakomodasi teknik 

ini. Seiring perkembangan teknologi pula bahwa Flash ini mulai digantikan 

oleh web based yang lebih multiplatform, namun ada baiknya Anda semua 

berkenalan dengan bagaimana sebuah multimedia disusun.  



Ucapan terima kasih penulis sampaikan kepada segenap pihak yang 

telah berpartisipasi secara fisik dan support atas tersusunnya buku ini. 

Tentu masih banyak fragment yang hilang menjadikan buku ini jauh dari 

sempurna, sehingga masukan dan kritik dari pembaca sangat penulis 

nantikan. 

 

 Fitro Nur Hakim, S. Sn., M. Sn. 
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BAB I  

PENGENALAN MULTIMEDIA 
 

 

Sebagai permulaan untuk mengenal tentang Multimedia, berikut 

adalah kutipan dari beberapa pakar yang telah mendefinisikan 

Multimedia. 

 Menurut Lancien (1998:7), multimedia pada masa kini merujuk 

pada penggabungan dan pengintegrasian media, seperti teks, 

animasi, grafik, suara, video kedalam sistem komputer.  

 Menurut Gayeski, D.M. (1992) “Multimedia ialah satu sistem 

hubungan komunikasi interaktif melalui komputer yang 

mampu mencipta, menyimpan, memindahkan, dan mencapai 

kembali data dan maklumat dalam bentuk teks, grafik, animasi, 

dan sistem audio.”  

 Menurut Phelps (1995) pula, multimedia adalah kombinasi 

teks, video, suara dan animasi dalam sesebuah konten 

komputer yang interaktif. Schurman (1995) mendefinisikan 

multimedia sebagai kombinasi grafik, animasi, teks, video dan 

bunyi dalam satu reka bentuk isi yang mementingkan interaksi 

antara pengguna dan komputer. 

Tujuan Instruksional: 
1. Mampu Menjelaskan Multimedia 
2. Mampu Menjelaskan Frame Script 

3. Mampu Menjelaskan Button Script 
4. Mampu Menjelaskan Movie Script 
5. Mampu Menjelaskan Metode Scripting Flash 
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 Menurut Collin, Simon (1995), “….Multimedia merupakan 

sebuah persembahan, permainan atau aplikasi yang 

menggabungkan beberapa media yang berlainan.  

 Kombinasi dari komputer dan video (Rosch, 1996), Kombinasi 

dari tiga elemen: suara, gambar, dan teks (McComick,1996), 

Kombinasi dari paling sedikit dua media input atau output. 

Media ini dapat berupa audio (suara, musik), animasi, video, 

teks, grafik dan gambar (Turban dan kawan-kawan, 2002). Alat 

yang dapat menciptakan presentasi yang dinamis dan interaktif 

yang mengkombinasikan teks, grafik, animasi, audio dan video 

(Robindan Linda, 2001).  

 Multimedia dalam konteks komputer menurut Hofstetter 2001 

adalah: pemanfaatan komputer untuk membuat dan 

menggabungkan teks, grafik, audio, video, dengan 

menggunakan tool yang memungkinkan pemakai berinteraksi, 

berkreasi, dan berkomunikasi. 

 Menurut Haffos (Feldman 1994) multimedia adalah sebagai 

suatu sistem komputer yang terdiri dari tool dan konten yang 

memberikan kemudahan agar gambar, video, fotografi, grafik 

dan animasi, dipadukan dengan suara, teks data yang 

dikendalikan dengan program komputer.  

 Multimedia adalah media yang menggabungkan dua unsur atau 

lebih media yang terdiri dari teks, grafis, gambar, foto,audio, 

video dan animasi secara terintegrasi. 

 Multimedia interaktif adalah suatu multimedia yang dilengkapi 

dengan alat pengontrol yang dapat dioperasikan oleh 
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pengguna, sehingga pengguna dapat memilih apa yang 

dikehendaki untuk proses selanjutnya. Contoh multimedia 

interaktif adalah: multimedia pembelajaran interaktif, aplikasi 

game, dll. 

 

Kelebihan Komunikasi via Multimedia 

1. Interaksi.  

� Terjadi timbal balik antar penyedia layanan dangan 

pengguna. 

2. Animasi.  

� Target audiens dapat melihat secara nyata dan jelas 

bagaimana sesuatu proses itu terjadi. 

3. Audio.  

� Memberikan kesan lebih menarik shg khalayak 

memperhatikan informasi dg antusias dan menarik 

aktifitas. 

4. Visual.  
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� Berupa video klip dan ilustrasi memberikan gambaran 

yang sebenarnya terhadap sesuatu situasi.  

� Aspek realistis visual memberikan efek psikologis 

terhadap khalayak yaitu timbulnya rasa kepercayaan. 

5. Bebas dan Repetitif 

� Dapat skip atau melompat ke bagian-bagian informasi 

mana yang diperlukan. 

� Membuka kesempatan penyedia layanan mengulang 

bagian-bagian pesan yang diperlukan. 

6. Pengekalan ingatan. Memperbesar prosentase ingatan 

berdasarkan : 

� 20%- apa yang didengar.   

� 40%- apa yang didengar dan dilihat.   

� 75%- apa yang didengar, lihat dan buat. 

Pembuatan multimedia interaktif lebih banyak berfokus pada 

pengelolaan media agar dapat saling berkolaborasi dan mengundang 

interaktifitas pengguna, dengan demikian perlu dipelajari cara 

menggabung media-media agar saling memiliki peran dalam aplikasi. 

Pada latihan dalam buku ini akan dipelajari actionscript dalam 

program Flash untuk menggabungkan media-media. Perlu diketahui 

bahwa banyak sekali program yang bisa dijadikan alat untuk 

mendesain multimedia, namun dalam buku ini dibahas menggunakan 

Flash yang dikarenakan juga Flash dapat digunakan untuk mendesain 

Animasi. Penggabungan Animasi Flash dengan actionscript akan 

mempersingkat dan mempermudah mengembangkan sebuah aplikasi 

multimedia interaktif. 

a. Frame Script 
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Actionscript dalam macromedia flash dapat dibagi menjadi tiga 

kategori dasar: Pertama dalam program Flash dikenal dengan Frame 

Script, Frame Script yaitu actionscript yang diletakkan dalam 

keyframe.  

  

 

Frame Script ditunjukkan dengan icon huruf a pada keyframe 

Cara untuk membuat frame script adalah dengan memasukkan 

actionscript kedalam frame. Secara teknik adalah dengan melakukan 

klik kanan pada frame yang dikehendaki, kemudian klik menu action 

dan ketik perintah yang diinginkan. 

b. Button Script  

Button Script yaitu actionscript yang diletakkan dalam symbol 

button. Cara menambahkannya adalah dengan membuka jendela 

Action, atau klik kanan pada symbol yang akan diberi actionscript. 
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Klik kanan pada tombol pilih Action 

 

Lihat peletakan actionscript pada symbol tombol 

Cara untuk membuat button script adalah seleksi sebuah symbol 

button, kemudian klik kanan. Pada menu yang muncul  pilih Action, 

kemudian ketikkan actionscript yang diinginkan. Jika opsi assit yang 

dipilih maka, langkah yang dilakukan adalah dengan melakukan 

serangkaian klik pada list actionscript yang sudah tersedia. 

c. Movie Script  

Movie script yaitu actionscript yang diletakkan dalam symbol 

movie clip. 
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Lihat peletakan actionscript pada symbol movie clip 

Jika menginginkan sebuah antarmuka multimedia interaktiv 

akan dibutuhkan bentuk pemberian actionscript yang lain yaitu 

Dynamic Event Handler. Script model ini akan lebih mengakomodir 

skenario sajian multimedia. 

d. Metode Scripting Flash 

Script assist adalah teknik penerapan actionscript menggunakan 

bantuan Assist yang ada pada Flash, sehingga desainer tidak perlu 

mengetikkan kode, melainkan hanya memilih list actionscript yang 

sudah disiapkan oleh program. 
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Langkah yang dilakukan adalah dengan mengaktifkan tombol 

Script Assist, kemudian pada symbol yang terpilih > Klik ikon + dan 

pilih perintah yang akan diterapkan. 

Script Assist diperuntukkan desainer yang ingin memulai 

membangun aplikasi multimedia interaktif menggunakan Flash, dan 

untuk lebih mengenal kode actionscript sebelum nantinya beralih 

kemode expert. 

 

Pertanyaan Dan Diskusi: 

1. Apakah yang disebut dengan Multimedia?  

2. Apakah yang disebut dengan Frame Script? 

3. Apakah yang disebut dengan Button Script? 

4. Apakah yang disebut dengan Movie Script? 

5. Bagaimana konsep singkat scripting dalam Flash? 

BAB II 

MEMBUAT TOMBOL NAVIGASI 
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Pada latihan kali ini akan dipelajari cara membuat tombol 

navigasi yang akan memandu pengguna untuk mengeksplorasi sajian 

multimedia yang dibuat. Sebagai contoh tombol navigasi yang dibuat 

mengikutsertakan kemampuan animatif. Tombol yang animatif lebih 

menarik dan tampak dinamis sehingga menjaga minat audiens dalam 

mengakses multimedia. 

Juga hal yang perlu diperhatikan dalam latihan kali ini adalah 

penggunaan metode scripting yang masih menggunakan cara symbol 

script assist, atau dengan memasukkan langsung actionscript kedalam 

symbol dan frame yang ada dalam desain multimedia. 

Multimedia interaktif menggunakan Flash lebih mudah 

dikerjakan jika telah menguasai materi Animasi Flash, maka pada 

latihan ini akan dipelajari kembali cara membuat animasi motion 

tween yang kemdian akan dikombinasikan dengan actionscript. 

a. Mendesain Navigasi 

1. Klik File > new, untuk membuat file baru 

2. Klik menu Insert > New Symbol pada kotak dialog Pilih 

behavior : Movie Clip, Name : mc_dropdownmenu 

Tujuan Instruksional: 
1. Mampu Menjelaskan Tombol Navigasi Sederhana 

2. Mampu Membuat Mendesain Navigasi 
3. Mampu Menjelaskan Assist ActionScript 

4. Mampu Menjelaskan Expert ActionScript 



10 

Fitro Nur Hakim 

 

3. Buat Rectangle ditengah-tengah registration point 

Anda dapat mendesainnya sebagai menu seperti contoh 

berikut : 

 

4. Klik menu insert > Layer, untuk membuat layer 2 

5. Copy rectangle pada layer 1 frame 1 

6. Klik Layer 2 frame 2 dan Klik Menu Edit > Paste in Place 

Anda dapat mendesainya sebagai menu seperti contoh 

berikut : 

 

7. Seleksi semua obyek pada layer 2 

8. Klik Menu Insert > Convert to Symbol… -  

Jadikanlah Button seperti berikut : 

 

9. Klik Frame 15 Layer 1 dan Klik > Insert > Frame 

10. Klik Frame 15 Layer 2 dan Klik > Insert > Keyframe 
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11. Geser “bt_lihatfilem” kebawah sehingga tersusun dengan obyek 

layer 1 sebagai  berikut : 

 

12. Karena tujuan dari latihan kali ini adalah untuk mengasah 

kemampuan actionscript dasar maka akan lebih baik lagi jika 

materi animasi flash juga diterapkan kedalam desain. Skenario 

tombol navigasi yang akan dibuat pada latihan kali ini adalah 

memiliki kemampuan animasi dropdown. Untuk membuat 

gerakan drop down dibuat menggunakan teknik animasi 

motion tweening. 

13. Klik Frame 1 Layer 2 dan Klik > Insert > Create Motion Tween 

14. Rename Layer 1 menjadi Menu dan Layer 2 Menjadi Lihat Film 

 

15. Buatlah 2 menu lagi sehingga menjadi tiga drop-down menu 

sebagai berikut: 
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b. Assist ActionScript 

1. Klik Insert > Layer, untuk membuat layer baru dan beri nama 

action 

2. Klik layer action frame 1 

3. Klik menu Window > Action Klik tombol + dan pilih stop 

 

4. Klik Frame 15 pada layer action, klik menu Insert > Keyframe 

dan berikanlah pula actionscript stop. 

5. Klik Frame 1 Layer menu, pastikan semua obyek pada layer 

menu terseleksi 

6. Klik menu Insert > Convert to Symbol.. 
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7. Klik tb_menu, untuk menyeleksinya 

8. Klik menu Window > Action  

Pilih goto, dan pastikan Frame adalah 2 

 

 

9. Klik tb_tutup untuk menyeleksinya 

10. Klik menu Window > Action Pilih Go to and Stop 

 

11. Klik icon Scene 1 dan untuk keluar dari editing symbol 

mc_dropdown 

12. Klik Window > Library, untuk memperlihatkan jendela Library 
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13. Klik dan seret mc_dropdown dari Library ke Scene1 

 

14. Lakukan Test Movie 

c. Expert ActionScript 

Penggunaan metode Assist Actionscripting akan menemui 

kendala saat desain multimedia mulai berbentuk komplek, sehingga 

perlu dipelajari metode expert Actionscripting, yaitu mengetikkan 

kode kedalam jendela Action. Pada latihan kali ini akan dipelajari 

perbedaan secara praktis peneran Assist dibanding menggunakan 

Expert. Pada mode expert, menjadikan sistem multimedia lebih 

dinamis. 

Skenario latihan dibawah ini adalah membuat tombol dragable, 

dimulai dengan menerapkan script Assist kemudian Mode Expert. 

Ikutilah latihan dibawah ini untuk membuat tombol navigasi menjadi 

bisa di geser atau drag and drop.   

1. Script untuk symbol tb_drag 
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Ganti even sbb :  

 

Properti yang harus diketik Target : this (tanpa petik) Expression 

: Cek 

      

2. Script yang kedua tb_drag 
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3. Lakukan Test Movie dengan cara menekan tombol Keyboart 

Ctrl + Enter. 

Jadi sebuah sajian multimedia dapat dengan mudah diakses 

hanya menggunakan Timeline Control. Terlebih jika actionscripting 

yang dilakukan masih menggunakan bantuan Script Assist, yang hanya 

memerlukan set input sesuai arahan program Flash. 

Setelah mempelajari teknik actionscripting dinamis, akan diubah 

desain set multimedia tombol drag drop down tersebut menggunakan 

teknik expert. Berikut adalah penulisan Actionscript2 dinamis untuk 

desain tombol drag drop diatas : 

//Membuat Dropdown 
_root.onEnterFrame=function(){ 
menu_mc.menu_btn.onPress=function(){ 
 menu_mc.startDrag(); 
} 
menu_mc.menu_btn.onRelease=function(){ 
 menu_mc.stopDrag(); 
 menu_mc.gotoAndPlay(2); 
} 
menu_mc.tutup_btn.onRelease=function(){ 
 menu_mc.gotoAndPlay(26); 
} 
} 

Alternatif ActionScript untuk menjadikan tombol navigasi lebih 

usability. Pada latihan kali ini akan dipelajari penggunaan mode expert 

untuk membuat tombol navigasi lebih dinamis. Ikutilah latihan 

dibawah ini  dengan menggantikan actionscript pada latihan 

sebelumnya dengan actionscript2 dibawah ini.  

//Membuat tombol toogle drag n drop 
toogle=1; 
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_root.onEnterFrame=function(){ 
menu_mc.menu_btn.onPress=function(){ 
 menu_mc.startDrag() 
} 
menu_mc.menu_btn.onRelease=function(){ 
 menu_mc.stopDrag(); 
 if(toogle>1){ 
  menu_mc.gotoAndPlay(2); 
 } else { 
  menu_mc.gotoAndStop(1); 
  toogle=2; 
 } 
} 
menu_mc.menu2_btn.onRelease=function(){ 
 menu_mc.gotoAndPlay(26); 
 toogle=1; 
} 
} 

Untuk memahami actionscript diatas pelajari bab Mengenal 

Actionscript Dinamis pada bab berikutnya. Disamping itu terdapat 

pula pelajaran Actionscript2 dan actionscript 3, tentu akan dibahasa 

pada latihan bab berikutnya. Untuk menerapkan actionscript 3 pada 

desain dragable akan dibahas pada bab Load Movie sub bab 

Actionsript 3 Load Movie swf. 

Sebagai catatan bahwa pelajaran maupun latihan penerapan 

actionscript dalam buku ini difokuskan pada pengembangan produk 

mutlimedia interaktif, maka pelajaran actionscript disajikan secara 

implementatif. 

 

Pertanyaan Dan Diskusi: 

1. Bagaimana cara singkat mendesain sistem navigasi?  

2. Apakah yang disebut dengan tombol navaigasi? 
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3. Bagaimana cara Assist dalam actionscript? 

4. Ada berapa cara memberikan Script dalam Flash? 

5. Apakah perbedaan utama Expert dan Assist? 
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BAB III 

MENGENAL ACTIONSCRIPT DINAMIS 
 

Sebelum menerapkan actionacript yang kompleks maka lebih 

baik jika mengenal dulu variable. Variable adalah kontainer yang 

berfungsi untuk menyimpan informasi. Script berikut menunjukkan 

cara deklarasi variable dalam Action Script : 

Var myVariable:Number = 10; 

Variable ini menyimpan nilai angka (numeric). Penggunaan: 

Number pada kode menetapkan tipe nilai yang dimiliki variable, 

biasanya disebut data typing. Anda dapat mendeklarasikan variable 

dalam frame pada timeline, atau langsung pada obyek. 

Misalnya: Var firstName:String; 

Ketika anda mendeklarasi variable, anda menentukan tipe data 

pada variable. Pada contoh diatas anda menentukan tipe pada variable 

firstName. Jenis tipe data dapat anda lihat pada Help. Jika digunakan 

macromedia Flash Actionscript2 penulisan kode variable lebih 

sederhana sebagai berikut : 

Tujuan Instruksional: 
1. Mampu Mejelaskan Event Handler Dinamis 
2. Mampu Mejelaskan Comparison operator 
3. Mampu Mejelaskan Nested Movie 

4. Mampu Mejelaskan Eksternal File txt 
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putar = 10; 

a. Event Handler Dinamis 

Agar lebih bisa mengontrol set multimedia, perlu diterapkan 

actionscript yang dinamis yang dapat menyatukan semua komponen 

multimedia yang dikelola pada Scene. Pada latihan kali ini akan 

diperkenalkan dulu dengan model penulisan actionscript dinamis, 

untuk lebih lengkapnya dapat dipelajari pada bab berikutnya. 

 Buatlah desain antarmuka seperti contoh dibawah ini : 

 

Beri nama symbol pada property instance 
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 Masukkan actionscript sebagai berikut pada layer 1 frame 1: 

 

 Penjelasan actionscript : 

Jalan = 6;  

Adalah perintah untuk membuat variabel dengan nama Jalan dan 

kemudian memberinya nilai 6. 

Bintang adalah nama instance movieclip pada scene 

 

 Syntax penulisan yang menggunakan gaya dinamis akan 

dibahas dalam proses latihan secara bertahap.  

 Bintang yang merupakan movieclip memiliki event 

onEnterFrame, yaitu selama instance berada dalam scene maka 

perintah akan dieksekusi terus menerus. Dalam konteks ini 

bintang memiliki properti posisi _x yaitu posisi terhadap sumbu 

X 
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 Pada gambar perhatikan posisi nol sumbu X ada pada pojok kiri 

atas. 

b. Comparison operator 

Suatu variabel dapat dimodifikasi dengan menggunakan 

operator. Variabel dapat diganti nilainya dengan informasi terbaru 

dari kondisi movie clip, mengganti suatu nilai dilakukan dengan cara 

true atau false, menambah, mengurangi dan mengalikan atau 

membagi. 

Terdapat tiga macam operator yaitu : 

1. Assigment Operator  = operator ini berfungsi untuk 

menetapkan suatu nilai untuk suatu variabel 

2. Arithmetic operator operator ini terdiri dari simbol yang biasa 

digunakan dalam matematika (lihat tabel) 

Simbol Keterangan 

+ Tambah  

_ Kurang 

* Kali 

/ Bagi 

++ Menambah nilai dengan 1 
x++ sama dengan x=x+1 

-- Mengurangi nilai dengan 1 

+= Menambah suatu nilai pada variabel 
x+=5 sama dengan x=x+5 
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-= Mengurangi suatu nilai pada variabel 

*= Mengalikan suatu nilai pada variabel 

/= Membagi suatu nilai pada variabel 

Operator ini membandingkan dua expression diantara simbol 

operator dan mengeluarkan nilai true atau false. 

Simbol Keterangan 

== Sama dengan 

< Kurang Dari 

> Lebih Dari 

<= Kurang atau sama dengan 

>= Lebih atau sama dengan 

!= Tidak sama dengan 

2. Property Symbol pada Actionscript2 

Movie clip memiliki banyak sekali property yang dapat dikontrol. 

Property Nilai Keterangan 

_alpha 0-100 Transparansi 

_x Pixel Koordinat sumbu x 

_y Pixel Koordinat sumbu y 

_rotation Derajat Putaran 

_xscale 100 Dimensi/skala mendatar 

_yscale 100 Dimensi/skala tegak 

 

c. Logika If dan Or 

Untuk Latihan Operator kali ini buatlah sebuah obyek symbol 

bola seperti desain pada gambar dibawah ini : 

 

Desain terdiri dari dua layer, layer pertama merupakan tempat 

meletakkan actionscript, dan layer kedua adalah letak symbol / obyek. 

Buat / ketikkan actionscript sebagai berikut : 



24 

Fitro Nur Hakim 

n=15; 
bola_mc.onEnterFrame=function() { 
 bola_mc._x=bola_mc._x+n 
 if (bola_mc._x>400) { 
  n=0 
 } 
} 

Penjelasan Script diatas adalah : Membuat variable dengan nama 

n dan memberinya nilai sebesar 15. Kemudian symbol instance diberi 

nama bola_mc – sedangkan actionscript untuk bola_mc adalah 

menggunakan model dinamis. Ketika bola_mc berada pada scene akan 

diset posisi _x nya bertambah terus-menerus sebanyak n. 

Jika bola mencapai posisi x lebih dari 400 pixel, maka variable n 

akan diberi nilai 0. Jadi desain set akan memperlihatkan bola berhenti 

bergerak ketika mencapai tepian scene. 

 

Lihat gambar area Scene diatas, ukurannya akan memiliki 

panjang 550 x 400 pixel, atau bisa dilihat pada properties dibagian 

bawah area scene. 
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.  

Or digunakan untuk mengevaluasi kondisi 1 dan kondisi 2, dan 

jika ada kebenaran terhadap satu ekspresi, atau keseluruhan ekspresi. 

Untuk lebih memahami secara praktis Logika Or, buatlah latihan 

actionscript dibawah ini : 

n=15; 
bola_mc.onEnterFrame=function() { 
 bola_mc._x=bola_mc._x+n 
 if ((bola_mc._x>400) or (bola_mc._x<0)) { 
  n=-(n) 
 } 
} 

Penjelasan actionscript diatas adalah : Jika bola-mc mencapai x 

lebih dari 400 pixel atau kurang dari 0 pixel maka variable n akan 

dikali dengan negatif n. 

d. Logika Else dan Trace 

Masih menggunakan file latihan pada pengenalan actionscript 

dinamis yaitu menggunakan desain scene sebagai berikut : 
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Masukkan actionscript berikut pada Layer1 Frame 1 

putar = 0; 
kondisi = 1; 
bintang.onEnterFrame=function(){ 
 bintang._rotation= bintang._rotation + 
putar; 
} 
 
ganti.onRelease=function() { 
 trace ("putar"+putar); 
 trace ("kondisi"+kondisi); 
 if (kondisi) { 
        putar=7; 
  kondisi=0; 
    } else { 
        putar=0; 
  kondisi=1; 
 } 
} 
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Penjelasan actionscript diatas adalah : Jika tombol ganti ditekan 

maka akan memeriksa apakah variabel kondisi terdefinisi pada scene 

jika ya, maka akan mengubah nilai putar yang tadinya 0 menjadi 7 

sehigga bintang akan berputar. Jika kondisinya lain maka akan 

mengubah nilai putar menjadi 0 dan kondisi menjadi 1. 

Trace berfungsi untuk debuging, melihat nilai yang dihasilkan 

suatu fungsi. Pada actionscript diatas trace(“putar”) hanya akan 

menghasilkan tulisan putar, sedangkan trace(putar) akan 

menghasilkan nilai dari variabel putar yaitu 0. 

e. Nested Movie 

Buatlah desain scene sebagai berikut : 

 

Struktur desain sebagai berikut : 

Symbol Movieclip “Mobil” 

↳ Symbol Movieclip “Symbol 1” 

↳ Symbol Movieclip “Symbol 1” 

↳ Symbol Movieclip “Symbol 2” 
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Berinama Instance pada Symbol sebagai berikut : 

 Movieclip Mobil = mobilku 

 Movieclip Symbol 1 = bandepan 

 Movieclip Symbol 2 = banbelakang 

Masukkan actionscript pada layer 1 Frame 1 

mobilku.onEnterFrame=function(){ 
 mobilku._x -= 4; 
 } 
mobilku.bandepan.onEnterFrame=function(){ 
 mobilku.bandepan._rotation -= 10; 
 } 
mobilku.banbelakang.onEnterFrame=function(){ 
 mobilku.banbbelakang._rotation -= 10; 
 } 

Penjelasan actionscript diatas adalah : Sederhana saja bahwa 

untuk memerintakan banbelakang agar melakukan putaran maka 

harus disebutkan induk movieclipnya. Instance Banbelakang berada 

didalam instance Mobilku. 

f. Membuat Scroll Text 

Anda dapat membuat animasi menggunakan teks yang diambil 

dari file txt (eksternal) dalam catatan file ini harus berada pada satu 

root atau satu folder. 

Script untuk load file txt sering digunakan untuk membuat 

template sehingga orang awam yang tidak menguasai flash dapat 

mengedit redaksi web flash-nya hanya dengan mengubah teks yang 

berada dalam file txt. 

 Script yang digunakan adalah loadMovieNum 

 Pada file plain text cukup tambahkan namaVariable=isi teks 

sesuka anda 
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 Sedangkan untuk sub teks yang ingin dimuat ditulis sbb : 

o Pada flash   /:namaVariable 

o Pada plain teks &pesan=teks sub yang anda 

inginkan 

 Teks sub ini dapat berlaku pula untuk menuliskan alamat url 

misal  

o Pada flash   getURL(/:url7); 

o Pada plain teks &url=kontak.html 

Desain antarmuka Scrolling Text: 

1. Klik menu File > New 

2. Klik tool Text dan pilih Dynamic Text pada Property, dan set 

properti teks sbb : Multiline, Show Border, Var : tulisan 

  

3. Buat lagi Dynamic Text pada Scene dengan property sbb : 

 

4. Sehingga pada Scene akan tertata layout sbb : 

 

5. Buat Static Text seperti pada Layout dibawah ini 
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6. Klik Line tool dan buat bentuk segitiga, dan Klik menu Insert > 

Convert to Symbol… beri Nama : tb_keatas 

 

7. Buat lagi segitiga seperti langkah 6 dengan berlawanan arah. 

Beri nama : tb_kebawah 

 

8. Klik menu Insert > Layer, untuk membuat Layer2 dan klik 

ganda layer 2 tersebut beri nama “action” 

9. Klik frame1 layer2, klik window > action, beri action + > Action 

> Browser/Network > loadMovie pada URL ketik = berita.txt 

  

10. Buka program Notepad atau Pengolah kata seperti Ms.Word 

11. Ketik beberapa paragraf pada notepad dan simpan dengan 

nama = berita.txt 

12. Pada awal teks berita.txt berilah teks: tulisan= 
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g. Eksternal File txt 

1. Klik symbol tb_keatas dan beri actionscript + > Action > 

Variable > Set Variable 

2. Klik kanan baris kedua pada jendela teks actionscript pilih 

Copy,  

kemudian klik kanan lagi dan pilih Paste, ubah variable seperti 

gambar dibawah 

 

3. Klik symbol tb_kebawah dan beri actionscript seperti pada 

tombol tb_keatas dengan mengubah tanda – menjadi + 

 

4. Klik menu File > Save simpan dengan nama teks.fla difolder 

yang sama dengan Anda menyimpan file berita.txt 

5. Klik menu Control > Test Movie. Test dengan menekan tombol 

keatas dan kebawah untuk melihat teks anda pada kotak dan 
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Anda dapat melihat pula posisi yang menginformasikan posisi 

scroll teks-nya 

 

Pada latihan tersebut sudah dipelajari metode penulisan 

Actionscript2 dinamis, dan membuat file eksternal yang dapat 

terkoneksi dengan tampilan multimedia. Walaupun desain antarmuka 

nantinya dapat menggunakan component yang sudah built-in dalam 

program Flash, namun latihan kali ini diharapkan mampu 

memberikan pemanasan dan pengertian yang lebih mendalam tentang 

potensi Flash untuk mengelola aset multimedia. 

Berikut adalah penulisan scrolling text apabila menggunakan 

teknik atau metode Actionscript2 dinamis : 

//Membuat variable 
loadVariablesNum("berita.txt", 0); 
//Tombol navigasi 
tiga1_btn.onRelease = function() { 
 _root.tulisan.scroll = tulisan.scroll+1; 
}; 
tiga2_btn.onRelease = function() { 
 _root.tulisan.scroll = tulisan.scroll-1; 
}; 
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Lebih lanjut akan dipelajari teknik pembuatan multimedia 

interaktif menggunakan actionscript3. Dalam actionscript 3 metode 

pembuatan ekternal file text menjadi lebih singkat, yaitu sebagai 

berikut : 

//Membuat kotak teks 
var external_txt:TextField = new TextField(); 
var externalReq:URLRequest = new 
URLRequest("berita.txt"); 
var externalLoad:URLLoader = new URLLoader(); 
 
externalLoad.load(externalReq); 
 
externalLoad.addEventListener(Event.COMPLETE, 
textReady); 
 
//Kotak yang Menampung Teks  
external_txt.x = 175; 
external_txt.y = 100; 
external_txt.border = true; 
external_txt.width = 200; 
external_txt.height = 200; 
external_txt.wordWrap = true; 
 
addChild(external_txt); 
 
function textReady(event:Event):void 
{ 
 external_txt.text = event.target.data; 
} 

h. External File AS3 

Penerapan Teknik Eksternal File Teks dalam Actionscript3, tidak 

diperlukan lagi menggambar kotainer simulatif untuk memuat teks, 

namun kontainer tersebut sepenuhnya dibuat dalam ActionScript3. 

Sedangkan interaktifitas scrolling secara otomatis diwakili oleh 
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tombol scrolling mouse. Jika masih menginginkan tombol untuk 

mengontrol scroll, berikut adalah penerapan Actionscript3 untuk 

scrolling text. 

Desain layout adalah Scene1 yang hanya terdiri dari dua symbol 

button dengan nama instance masing-masing seperti pada gambar 

dibawah ini. 

 

Persiapkan file beritaku.txt yang dibuat menggunakan Notepad, 

isikan teks dengan berita yang ingin dimuat. 
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i. Peletakan ActionScript 

Sebaiknya peletakan actionscript dipisah secara khusus, 

misalnya pada layer Action, yaitu layer yang hanya berisikan 

actionscript yang mengontrol keseluruhan media. 

 

var external_txt:TextField = new TextField(); 
var externalReq:URLRequest = new 
URLRequest("berita.txt"); 
var externalLoad:RLLoader = new URLLoader(); 
 
externalLoad.load(externalReq); 
 
externalLoad.addEventListener(Event.COMPLETE, 
textReady); 
 
var external_txt:TextField = new TextField(); 
var externalLoad:URLLoader = new 
URLLoader(new URLRequest("berita.txt")); 
 
externalLoad.addEventListener(Event.COMPLETE, 
textReady); 
function textReady(e:Event):void { 
 external_txt.text = e.target.data;//Isi teks 
dalam teksfield = data dari externalLoad 
} 
addChild(external_txt); 
//Tombol Scroll  
up_btn.addEventListener(MouseEvent.CLICK, 
scrollUp); 
function scrollUp(e:MouseEvent):void { 
 external_txt.scrollV --; 
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} 
down_btn.addEventListener(MouseEvent.CLICK, 
scrollDown); 
function scrollDown(e:MouseEvent):void { 
 external_txt.scrollV ++; 
} 
//Dimensi Kotak yang Menampung Teks   
external_txt.x = 175; 
external_txt.y = 100; 
external_txt.border = true; 
external_txt.width = 200; 
external_txt.height = 200; 
external_txt.wordWrap = true; 

File Flash berupa .fla dan file teks berupa .txt disimpan dalam 

satu folder yang sama. Pemahaman Actionscript akan dibahas pada 

Bab 4, terutama mempelajari logika perintah dari Actionscript2 

menuju penerapan Actionscript3 yang lebih kompatibel dengan 

perangakat atau gadget modern. Perlu diingat bahwa ActionScript3 

merupakan versi pembaharuan dari flash, yang harus diikuti dengan 

flash player dengan versi yang didukung, pada contoh dibawah adalah 

hasil latihan yang diputar menggunakan flash player versi 17. 
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Pertanyaan Dan Diskusi: 

1. Apakah yang dimaksud dengan Event Handler 

Dinamis? 

2. Apakah Fungsi Trace dalam penulisan script? 

3. Apakah yang dimaksud dengan Nested Movie? 

4. Bagaimana cara agar file eksternal dapat terbaca 

pada hasil movie? 

5. Apakah fungsi If dan Or dalam menjalankan 

komponen multimedia?  
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BAB IV 

PERBEDAAN ACTIONSCRIPT2 DAN 

ACTIONSCRIPT3 

 

Pada software Macromedia Flash MX terdapat cara penulisan 

actionscript Dynamic Event Handler. Penulisan actionscript cara ini 

dirilis dengan mengemas actionscript kedalam satu halaman sehingga 

lebih terorganisir. 

Seperti telah dipelajari sebelumnya cara penulisan actionscript 

dalam Flash yang lama dikenal sebagai : 

1. Frame Script (actionscript dalam keyframe)  

2. Button Script (actionscript dalam tombol) 

3. Movie Script (Script dalam MovieClip) 

Pada intinya cara penulisan yang baru ini memasukkan semua 

actionscript yang terpencar menjadi satu dalam keyframe movie clip 

utama (_root), sehingga Anda tidak perlu repot-repot lagi untuk 

mengedit actionscript suatu symbol jika, desain multimedia kita 

terdiri dari banyak elemen simbol yang kompleks. 

Penulisan actionscript2 akan membimbing pemahaman logika 

manusia kedalam sistem multimedia, sedangkan actionscript 3 lebih 

Tujuan Instruksional: 
1. Mampu Menjelaskan Event Handler ActionScript 
2. Mampu Menjelaskan Kontrol Movie Clip Dinamis 
3. Mampu Menjelaskan Event Movie Clip 
4. Mampu Menjelaskan Variable 

5. Mampu Menjelaskan Tombol Saklar 
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mengutamakan kekinian kompatibilitas pada platform yang modern, 

disamping pemikiran peningkatan keamanan. 

a. Event Handler Actionscript2 

Tata bahasa dari penulisan Dynamic Event Handler adalah 

sebagai berikut : 

nama_instance.nama_event=function() { 
perintah 
} 

Nama instance adalah nama instance dari symbol yang telah 

berada pada scene. Nama event adalah nama event instance dengan 

penambahan penulisan yang lebih spesifik. Script ini diletakkan pada 

frame dengan sarat semua symbol yang dimaksud dalam actionscript-

nya sudah berada pada scene dan memiliki instance name. Dengan 

cara penulisan ini maka sistem dapat menganimasi obyek pada scene 

dari actionscript yang terletak di frame. Penamaan instance yang baik 

telah diatur dalam Flash, tetapi tidak harus mematuhinya selama tidak 

berbenturan dengan origin syntax actionscript dalam Flash. Aturan ini 

hanyalah untuk mempermudah opsi event atau handler (perintah) 

untuk muncul saat mengetik actionscript dalam panel Action. Aturan 

penulisan tersebut biasa ada pada nama instance yaitu : 

namainstance_btn untuk simbol tombol dan namainstance_mc untuk 

simbol movieclip. 

b. Event Handler ActionScript 3 

Dalam Actionscript 3 dikenal pula methode .addEventListener 

pada sebuah objek. Kadang ada banyak fungsi yang menyertai 

methode ini. Methode .addEventListener adalah sebuah methode untuk 

mengontrol interaksi sebuah objek dengan objek lain atau dengan 
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sutau keadaan. Even handling, pada actionscript 3 adalah segala 

bentuk interaksi terdapat dalam suatu lingkungan Flash. Semua 

interaksi ini bisa terjadi baik dalam bentuk mouse klik, penekanan 

tombol pada keyboard, loading data, ataupun masuk pada frame 

tertentu. Actionscript 3 membuat sebuah object dapat berinteraksi 

dengan sebuah event menggunakan sebuah Event Listener. Hal ini 

dapat dilakukan menggunakan methode .addEventListener pada 

sebuah objek yang akan berinteraksi. Secara umum bentuk dari 

eventListener dapat digambarkan sebagai berikut : 

object.addEventListener(Event, 
eventListenerFunction); 
function eventListenerFunction 
(e:Event):void{ 
do someThing; 
} 

Objek merupakan sebuah obyek yang akan menerima interaksi, 

misalnya sebuah MovieClip, button, atau loader. Event merupakan hal 

yang dapat memicu sebuah objek untuk menjalankan fungsi 

eventListener.  Contoh : 

tombolku.addEventListener(MouseEvent.CLICK, 
jalan); 
function jalan(eventnya:MouseEvent):void { 
     bintang.x = bintang.x + 5; 
} 

Fungsi diatas adalah sebuah fungsi untuk menggeser suatu objek 

movieclip bernama instance “bintang” ke kanan sebanyak 5px saat klik 

tombol bernama instance “tombolku”. Instance bintang menerima 

event dari MouseEvent.CLICK, maka jika tombolku diklik fungsi jalan 
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akan dieksekusi. Pada fungsi jalan, nilai x dari bintang akan ditambah 

5 yang berarti bintang akan bergeser 5 px ke kanan.  

Perhatikan pada bagian parameter fungsi di atas : 

jalan(eventnya:MouseEvent). eventnya merupakan sebuah argumen 

yang merepresentasikan fungsi jalan. Pada sebuah EventListener, 

argumen ini wajib disertakan. Sebagai identifier dan bebas digunakan 

kata atau huruf apa saja yang tidak merupakan syntax dalam 

actionscript3.  

c. Kontrol Movie Clip Dinamis 

Pada latihan berikut dibawah ini akan dipelajari cara membuat 

Tombok yang mengontrol MovieClip, dan sebagai pelajaran akan 

digunakan Actionscript2 dan metode listener actionscript 3. 

Sebelumnya buatlah desan sebagai berikut : 

 

1. Klik menu File > New untuk membuat file baru 

2. Klik Oval tool dan gambarlah dua buah lingkaran tanpa outline 

sbb: 
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3. Gunakan teknik segmenting untuk mengedit lingkaran biru 

dengan memindahkan lingkaran hijau sehingga menjadi sperti 

contoh berikut : 

   

4. Seleksi gambar cakram tersebut dan klik menu Insert > Convert 

to Symbol 

Beri nama Cakram, behave : movie clip 

 

5. Pada panel property beri nama instance : cakram_mc 

6. Klik rectangle tool dan buat gambar tombol 

7. Seleksi gambar tombol dan klik menu Insert > Convert to 

Symbol 

beri nama tombol, behavior : Button 

   

8. Pada panel property beri nama instance tombol : tombol1_btn 



44 

Fitro Nur Hakim 

9. Organisirlah obyek yang anda buat kedalam layer yang diberi 

nama tombol, isi untuk meletakkan movieclip dan script (untuk 

menulis actionscript dengan cara Dinamis nantinya). 

 

Menulis actionscript dinamis untuk Menganimasi Movie Clip 

1. Klik Keyframe 1 layer script dan Klik menu Window > Action 

2. Ketik actionscript berikut dalam mode Expert 

 

cakram_mc.onEnterFrame=function(){ 
 cakram_mc._x=cakram_mc._x+5; 
} 

Penjelasan actionscript diatas adalah : saat cakram berada pada 

frame maka properti x nya akan ditambah 5, dan karena 

onEnterFrame akan dieksekusi terus selama movieclip berada pada 

Scene, maka akan menghasilkan cakram yang bergerak kekanan. 

Jika perintah tersebut ditulis dengan menggunakan actionscript 

3 akan berbentuk sebagai berikut : 

cakram_mc.addEventListener(Event.ENTER_FRAME, 
berjalan); 
 
function berjalan(evt:Event) { 



  45 

Fitro Nur Hakim 

     cakram_mc.x += 5; 
} 

Untuk mengontrol cakram dengan tombol maka, actionscript 3 

yang diterapkan adalah sebagai berikut : 

tombol1_btn.addEventListener(MouseEvent.CLICK
, mulai); 
 
function mulai(evtm:MouseEvent) { 
 cakram_mc.x = 200; 
} 

Penjelasan actionscript diatas adalah : Sekali lagi ditekankan 

bahwa actionscript diatas menggunakan actionscript 3. Maka bisa 

dilihat bahwa properti _x berubah menjadi x. Jika tombol1_btn 

mendengar event CLICK maka akan mengesekusi fungsi mulai. Fungsi 

mulai akan membuat posisi cakram kembali pada 200 px. 
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d. Tentang This dan Event Movie Clip 

Penggunaan this  

1. this mengacu pada nama instance, karena this berada dalam 

nama instance cakram_mc maka kalimat this._x adalah milik 

cakram_mc 

2. property _x dilengkapi dengan this karena peletakan 

actionscript diluar movie clip cakram_mc yaitu didalam movie 

flash scene1 

3. jika property _x ditulis tanpa kepemilikian this maka _x 

dianggap milik movie flash scene1 yang artinya semua obyek 

dalam scene akan bergerak kekanan 

berikut adalah penulisan actionscript 
yang salah 
cakram_mc.onEnterFrame=function(){ 
 _x=_x+5; 
} 

Event untuk Movie Clip dalam actionscript2 adalah 

onEnterFrame sedangkan untuk actionscript 3 adalah ENTER_FRAME, 

yaitu selama movie clip berada di scene (perintah akan dieksekusi). 

e. Variable Dinamis 

Variabel digunakan sebagai tempat untuk menampung nilai, jika 

menggunakan Script Assist akan tertulis sebagai berikut :  

Nama event{ 
 Nama variabel = nilai; 
} 

Misalkan : 



  47 

Fitro Nur Hakim 

on (Release) { 
 n=1 
} 

Penjelasan actionscript diatas adalah, pada saat tombol mouse 

dilepas maka nilai 1 akan ditampung dalam variabel n. Jadi ini adalah 

tahap inisialisasi untuk memberitahu komputer bahwa nilai awal n 

adalah 1. Nama variable bebas misalnya angka, nilai, dll  selama nama 

yang anda pakai tidak termasuk dalam kode actionscript yang telah 

dipakai oleh Flash. 

Sebagai latihan  

1. Pakailah lagi tombol dengan nama instance tombol2_btn dan 

skenarionya jika tombol2 ini ditekan maka movie clip cakram 

akan berhenti bergerak. 

2.  Pakailah lagi tombol dengan nama instance tombol3_btn dan 

skenarionya jika tombol3 ini ditekan maka movie clip cakram 

akan bergerak kembali. 

3. Buatlah agar cakram bergerak sambil berputar dengan 

property _rotation 
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Penerapan actionscript untuk desain multimedia interaktif 

diatas adalah sebagai berikut : 

n=5 
cakram_mc.onEnterFrame=function(){ 
 this._x=this._x+n; 
 this._rotation=this._rotation+n; 
} 
tombol1_btn.onRelease=function(){ 
 cakram_mc._x=cakram_mc._x=200 
} 
tombol2_btn.onRelease=function(){ 
 n=0 
} 
tombol3_btn.onRelease=function(){ 
 n=5 
} 

Sebagai latihan kerjakan desain multimedia interaktif diatas 

menggunakan actionscript 3. Untuk actionscript 3 maka penerapan 

penulisan syntax tersebut adalah sebagai berikut : 
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var n:Number = 5; 
cakram_mc.addEventListener(Event.ENTER_FRAME, 
berjalan); 
tombol1_btn.addEventListener(MouseEvent.CLICK
, mulai); 
tombol2_btn.addEventListener(MouseEvent.CLICK
, henti); 
tombol3_btn.addEventListener(MouseEvent.CLICK
, jalanlagi); 
function berjalan(evt:Event) { 
     cakram_mc.x += n; 
} 
function mulai(evtm:MouseEvent) { 
     cakram_mc.x = 200; 
} 
function henti(evth:MouseEvent) { 
     n=0; 
} 
function jalanlagi(evtjllg:MouseEvent) { 
     n=5; 
} 

f. Membuat Tombol Saklar 

Pada Latihan kali ini akan dipelajari cara membuat tombol 

skalar, yaitu satu tombol yang memiliki dua buah fungsi secara 

bergantian, misalnya untuk menghidupkan lampu kemudian juga 

untuk mematikan lampu. Sebelum memulai latihan maka buatlah 

desain set sederhana sebagai berikut : 
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Kemudian ActionScript2 untuk desain tersebut adalah : 

//Membuat variable 
putar = 0; 
kondisi = 1; 
//Membuat obyek berputar 
cakram1_mc.onEnterFrame=function(){ 
 cakram1_mc._rotation=cakram1_mc._rotation + 
putar; 
} 
 
//Tombol togle putar 
tombol1_btn.onRelease=function() { 
 if (kondisi) { 
        putar=7; 
  kondisi=0; 
    } else { 
        putar=0; 
  kondisi=1; 
 } 
} 
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 Penulisan actionscript 3 dinamis terhadap skenario desain 

multimedia diatas adalah sebagai berikut ; 

var putar:Number = 0; 
var kondisi:Number = 1; 
cakram_mc.addEventListener(Event.ENTER_FRAME, 
berputar); 
tombol1_btn.addEventListener(MouseEvent.CLICK
, saklar); 
function berputar(evt:Event) { 
     cakram_mc.rotation += putar; 
} 
function saklar(evt:MouseEvent) { 
 if (kondisi) { 
  putar=7; 
  kondisi=0; 
 } else { 
  putar=0; 
  kondisi=1; 
 } 
} 

Selain fungsi, sebuah tombol juga akan lebih menarik jika diberi 

tambahan berupa animasi. Keberhasilan komunikasi menggunakan 

multimedia interaktif didukung tampilan dan fungsi, sebab tanpa 

tampilan yang menarik – user bisa saja meninggalkan sebuah 

informasi penting yang hendak disampaikan. Sedangkan untuk fungsi 

dari sebuah tombol navigasi, selain mengundah rasa ingin tahu maka 

sebaiknya tombol dibuat simpel dan informatif. Misalnya, agar simpel 

tombol dibuat dropdown sehingga memberbesar pula bidang baca 

yang dihadapi user. Tombol informatif memberikan keterangan yang 

jelas, misalnya gambar pintu pada tombol sebagai representasi untuk 

membuka atau memulai masuk halaman. 
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Pertanyaan Dan Diskusi: 

1. Apakah yang disebut dengan Event Handler 

ActionScript? 

2. Apakah yang disebut dengan Kontrol Movie Clip 

Dinamis? 

3. Apakah yang disebut dengan Event Movie Clip? 

4. Apakah yang disebut dengan Variable? 

5. Bagaimana Cara membuat Tombol Saklar? 
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BAB V 

MEDIA IMAGE EKSTERNAL 

 

Memuat gambar eksternal yang dikelola dengan file identifikasi 

database akan lebih memiliki kemampuan berekspansi jika nantinya 

aplikasi multimedia memiliki lebih banyak data. 

Sebagai latihan membuat antarmuka gambar eksternal ini, 

buatlah desain set sebagai berikut: 

 

Tujuan Instruksional: 
1. Mampu Menjelaskan Eksternal Image 
2. Mampu Menjelaskan Identitas Data 
3. Mampu Menjelaskan cara Load Gambar 
4. Mampu Menjelaskan Metode XML 

5. Mampu Menjelaskan Metode XML external 
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Siapkan file-file gambar berformat .jpg pada satu folder  

 

a. Membuat Text Identitas Data 

Teks berupa file .txt dapat dijadikan identittas suatu database 

gambar dalam satu folder, yang kemudian data teks ini dipanggil 

kedalam flash untuk mengidentifikasi data eksternal. Pada latihan kali 

ini akan dipelajari cara membuat database datagambar.txt. 

Langkahnya sederhana saja, buat file menggunakan program teks 

standar seperti notepad, wordpad atau semacamnya, kemudian isi file 

tersebut dengan informasi teks sebagai berikut : 

gbr1=depan.jpg&judul1=Tampak Depan 
&gbr2=box.jpg&judul2=Box Kelengkapan 
&gbr3=nyala.jpg&judul3=Kondisi Menyala 
&total=3 

b. Load Gambar Menggunakan ActionScript2 

Setelah file-file gambar dan database identifier siap maka, pada 

Layer 1 Frame 1 ketikkan Actionscript2 sebagai berikut : 

loadVariablesNum("datagambar.txt",0); 
n=1; 
_root.onEnterFrame=function(){ 
 if(total!=undefined){ 
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  //undefined mengindikasikan bahwa 
variabel tersebut belum terdefinisi 
  //!= atau <> adalah inequality operator 
  loadMovieNum(gbr1,1); 
  display_txt=judul1; 
  delete this.onEnterFrame; 
  trace (total); 
 } 
} 
prev_btn.onRelease=function(){ 
 if(n>1)n--; 
 loadMovieNum(eval("gbr"+String(n)),1); 
 // eval Accesses variables, properties, 
objects, or movie clips by name. 
 display_txt=eval("judul"+String(n)); 
} 
next_btn.onRelease=function(){ 
 if(n<total)n++; 
 loadMovieNum(eval("gbr"+String(n)),1); 
 display_txt=eval("judul"+String(n)); 
} 
 
 

c. Load Gambar Menggunakan ActionScript3 

Pola actionscript 3 yang sudah berubah memberikan pilihan jika 

desain mutlimedia ingin dibangun berdasarkan metode ini. 

Actionscript 3 memberikan opsi untuk memuat data dengan xml 

daripada menggunakan txt. Kombinasi load gambar dengan 

penggunaan xml akan memerlukan banyak tahapan pemahaman 

actionscript 3, karena implementasinya juga semakin kompleks. 

Sebagai alternatif berikut adalah penggunaan actionscript 3 untuk 

membuat galeri gambar sederhana, yaitu hanya meliputi tombol 

navigasi next dan previous sebagaimana skenario yang sudah 

ditunjukkan pada latihan sebelumnya. 
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Desain Layout load gambar eksternal Actionscript3. Hanya 

terdiri dari dua buah tombol dengan nama Instance nextBtn dan 

prevBtn 

 

Selain layout, siapkan pula gambar berformat jpg dalam satu root 

atau folder  

 

//membuat variabel yang diperlukan 
var imgs:Number =6;//jumlah gambar 
var imgNum:Number = 1;//gambar ke… 
var imgLoader:Loader = new Loader(); 
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var imgRequest:URLRequest = new URLRequest 
(imgNum + '.jpg'); //imgNum adalah nama file 
jpg nya 
imgLoader.load(imgRequest); 
addChild(imgLoader); 
 
//Mengambil data dimensi obyek 
imgLoader.contentLoaderInfo.addEventListener(
Event.INIT, getDimF); 
 
function getDimF(e:Event):void { 
 //trace(imgLoader.width); //Dimensi 
imgLoader 
 
 //Memposisikan gambar ditengah stage 
 //Lebar Stage dikurang lebar obyek kemudian 
dibagi 2 
 var imgX:Number = (stage.stageWidth-
imgLoader.width)/2; 
 var imgY:Number = (stage.stageHeight-
imgLoader.height)/2; 
 //trace(imgX); // Mengatahui posisi X 
variabel imgX 
 
 imgLoader.x =imgX; 
 imgLoader.y=imgY; 
} 
nextBtn.addEventListener(MouseEvent.CLICK, 
nextF); 
prevBtn.addEventListener(MouseEvent.CLICK, 
prevF); 
 
function nextF(e:MouseEvent):void { 
 if (imgNum<imgs) { 
  imgNum++; 
   } else { 
  imgNum=1; 
 } 
  reloadF(); 
} 
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function prevF(e:MouseEvent):void { 
 if (imgNum>1) { 
  imgNum--; 
 } else { 
  imgNum = imgs; 
 } 
  reloadF(); 
} 
//Fungsi untuk menghapus child imgLoader yang 
berada pada stage 
function reloadF():void { 
 removeChild(imgLoader); 
 imgRequest = new URLRequest (imgNum 
+'.jpg'); 
 imgLoader.load(imgRequest); 
 addChild(imgLoader); 
} 

d. XML Load External Files Actionscript 3 

Pada latihan kali ini akan dipelajari cara membuat identitas data 

eksternal menggunakan xml, sedangkan pada latihan Actionscript2, 

identitas data menggunakan file txt. XML memberikan kemudahan 

untuk mengatur tag dan memanfaatkannya kedalam flash. 

Berikut ini adalah bentuk dari file xml yang dijadikan bahan 

latihan 

 

Pada contoh gambar xml diatas diperlihatkan struktur attribute 

yaitu source dan thum sedangkan datanya adalah Description of 

image1. XML pada contoh memiliki 4 node dan disimpan dalam folder 

bernama “data”. 
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Lengkapi pula file-file gambar sebagaimana tertulis pada contoh 

xml diatas, yaitu gambar image1.jpg (resolusi besar) dalam folder 

bernama images – gambar Image1.jpg (resolusi kecil) dalam folder 

bernama thumbnails. 

Sedangkan actionscript 3 untuk memuat file gambar 

menggunakan xml adalah sebagai berikut. 

var imageLoader:Loader; 
var xml:XML; 
var xmlList:XMLList; 
var xmlLoader:URLLoader = new URLLoader(); 
xmlLoader.load(new 
URLRequest("data/images.xml")); 
 
xmlLoader.addEventListener(Event.COMPLETE, 
xmlLoaded); 
 
function xmlLoaded(event:Event):void 
{ 
 xml = XML(event.target.data); 
 xmlList = xml.children(); 
 for(var i:int = 0; i < xmlList.length(); 
i++) 
 { 
  imageLoader = new Loader(); 
  imageLoader.load(new 
URLRequest(xmlList[i].attribute("thumb"))); 
  imageLoader.x = 25; 
  imageLoader.y = i * 150 + 25; 
  addChild(imageLoader); 
   
 } 
         
  
} 

Penjelasan actionscript 3 diatas adalah : 
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Ketika xmlLoader selesai memuat xml maka akan menjalankan 

fungsi xmlLoaded. 

 xml = XML(event.target.data); 

Perintah tersebut adalah xml sebagai holder data 

 xmlList = xml.children(); 

Perintah tersebut adalah untuk membuat array dari variabel xml 

 for(var i:int = 0; i < xmlList.length(); 
i++) 

Perintah tersebut adalah untuk membuat looping  saat variabel i 

lebih kecil daripada jumlah node yaitu 4, maka nilai variabel i akan 

bertambah 1 dan seterusnya. 

imageLoader.load(new 
URLRequest(xmlList[i].attribute("thumb"))); 

Perintah tersebut akan memuat node ke i pada atribut thumb 

yang mana akan memberikan hasil - thumbnail/image1.jpg -   

imageLoader.y = i * 150 + 25; 

Perintah tersebut akan membuat jarak Y yang besarnya i 

dikalikan 150 + 125 pixel. Misalnya akan dimuat i atau node ke 2 maka 

akan memberikan hasil : 

2 x 150 + 125 = 425 pixel 

addChild(imageLoader); 
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Perintah untuk menampilkan nilai imageLoader pada stage.

 

Sedangkan untuk mengakses gambar resolusi bersanya akan 

dibuat masing-masing thumbnail sebagai tombol navigasi. Lebih 

lengkap actionscript 3 yang diterapkan adalah sebagai berikut : 

Perhatikan teks yang ditebalkan sebagai modifikasi actionscript 3 dari 

latihan sebelumnya. 

var imageLoader:Loader; 
var xml:XML; 
var xmlList:XMLList; 
var xmlLoader:URLLoader = new URLLoader(); 
xmlLoader.load(new 
URLRequest("data/images.xml")); 
 
xmlLoader.addEventListener(Event.COMPLETE, 
xmlLoaded); 
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function xmlLoaded(event:Event):void 
{ 
 xml = XML(event.target.data); 
 xmlList = xml.children(); 
 for(var i:int = 0; i < xmlList.length(); 
i++) 
 { 
  imageLoader = new Loader(); 
  imageLoader.load(new 
URLRequest(xmlList[i].attribute("thumb"))); 
  imageLoader.x = 25; 
  imageLoader.y = i * 150 + 25; 
  imageLoader.name = 

xmlList[i].attribute("source"); 

  addChild(imageLoader); 
 
 imageLoader.addEventListener(MouseEvent.CLIC
K, showPicture); 
 } 
         
  
} 
 
function showPicture(event:MouseEvent):void 

{ 

 imageLoader = new Loader(); 

 imageLoader.load(new 

URLRequest(event.target.name)); 

 imageLoader.x = 200; 

 imageLoader.y = 25; 

 addChild(imageLoader); 

} 

Penjelasan actionscript 3 diatas adalah : 

  imageLoader.name = 

xmlList[i].attribute("source"); 

Perintah tersebut  adalah menambahkan .name yang merupakan 

property dari instance name obyek, sedangkan atribut yang diacu 
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adalah source. Misalnya dari i atau node ke 2 maka akan menghasilkan 

images/image3.jpg. 

 imageLoader.load(new 
URLRequest(event.target.name)); 

Fungsi showPicture akan menghasilkan gambar pada folder 

images/ dimuat pada stage, penulisan URLRequest mencantumkan 

.name. Hasilnya modifikasi load gambar menggunakan XML dengan 

actionscript 3 dapat diilustrasikan pada gambar dibawah ini. 

 

Untuk menambahkan teks deskripsi gambar maka digunakan 

actionscript3 modifikasi sebagai berikut : 

Letakkan variabel imageText pada bagaian atas actionscript 3  

var imageText:TextField = new TextField(); 
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kemudian tambahkan / modifikasi fungsi showPicture pada 

latihan sebelumnya untuk memuat teks, atau dapat dilihat 

actionscript3 berikut : 

function showPicture(event:MouseEvent):void 
{ 
 imageLoader = new Loader(); 
 imageLoader.load(new 
URLRequest(event.target.name)); 
 imageLoader.x = 200; 
 imageLoader.y = 25; 
 addChild(imageLoader); 
 imageText.x = imageLoader.x; 
 imageText.y = 351; 
 for(var j:int = 0; j < xmlList.length(); 
j++) 
 { 
  if(xmlList[j].attribute("source") == 
event.target.name) 
  { 
   imageText.text = xmlList[j]; 
  } 
 } 
} 
imageText.autoSize = TextFieldAutoSize.LEFT; 
addChild(imageText); 

Penjelasan actionscript 3 diatas adalah : 

Membuat looping variabel j jika nilainya dibawah jumlah node 

(4) maka : 

Jika xmlList j menghasilkan nilai yang sama dengan nama 

instance imageLoader maka : akan imageText akan menampilkan 

xmlList dari loop ke j. Hasilnya akan diperoleh teks pada stage sesuai 

data xml. 

imageText.autoSize = TextFieldAutoSize.LEFT; 
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Perintah tersebut akan membuat teksfield menjadi otomatis 

mengikuti panjang teks dan tampil rata kiri. 

e. Load Gambar XML Actionscript3 

Desain Layout 

 

Pada bagian tengah adalah Dynamic Text bernama Instance : 

judulipun Tombol masing-masing bernama nextBtn dan 

prevBtn. 

Persiapan file dataku.xml adalah sebagai berikut : 
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Sedangakan gambar-gambar yang diperlukan disimpan satu 

folder dengan dataku.xml dan file .fla nya. Ingat file-file gambar yang 

akan diload (dimuat) haruslah lebih kecil dibandingkan dimensi stage 

yang dibuat. 

  

Actionscript3 untuk menjalankan rangkaian desain layout, 

gambar dan koneksi XML nya adalah sebagai berikut :  

var xmlLoader: URLLoader = new URLLoader(); 
xmlLoader.load(new URLRequest("dataku.xml")); 
xmlLoader.addEventListener(Event.COMPLETE, 
XMLLoaded); 
var XMLData: XML = new XML(); 
var stat: Number = 0; 
var jumlahGambar: Number; 
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var fileGambarN: String; 
var imgLoader: Loader; 
var juduleN: String; 
function XMLLoaded(e: Event): void { 
 XMLData = new XML(e.target.data); 
 jumlahGambar = XMLData.gambar.length(); 
 reloadF(); 
} 
 
nextBtn.addEventListener(MouseEvent.CLICK, 
nextF); 
function nextF(e: MouseEvent): void { 
 if (stat < (jumlahGambar - 1)) { 
  stat++; 
 } else { 
  stat = 0; 
 } 
 removeChild(imgLoader); 
 reloadF(); 
} 
function reloadF(): void { 
 juduleN = XMLData.gambar[stat].judul.text(); 
 judulipun.text = juduleN; 
 fileGambarN = 
XMLData.gambar[stat].filenya.text(); 
 imgLoader = new Loader(); 
 var imgRequest: URLRequest = new 
URLRequest(fileGambarN); 
 imgLoader.load(imgRequest); 
 addChild(imgLoader); 
} 
 
prevBtn.addEventListener(MouseEvent.CLICK, 
prevF); 
function prevF(e: MouseEvent): void { 
 if (stat > 0) { 
  stat--; 
 } else { 
  stat = (jumlahGambar-1); 
 } 
 removeChild(imgLoader); 
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 reloadF(); 
} 
 

Penjelasan Actionscript3 diatas adalah : 

xmlLoader.addEventListener(Event.COMPLETE, 
XMLLoaded); 

Setelah XMLLoader selesai memuat data XML akan menjalankan 

fungsi XMLLoaded 

XMLData = new XML(e.target.data); 

Mengisi variabel XMLData dengan data XML dalam file 

dataku.xml 

 

jumlahGambar = XMLData.gambar.length(); 

Mengambil jumlah data tag gambar dalam dataku.xml 

reloadF(); 

Menjalankan fungsi reloadF(); 

removeChild(imgLoader); 

Menghapus aset yang dimuat kedalam Stage, kalau tidak dihapus 

dahulu maka aset akan dimuat secara bertumpuk. 

juduleN = XMLData.gambar[stat].judul.text(); 

Mengambil data judul ke N dari dataku.xml -> hasil N ke 2 : 

Ngebut Benjut 

Jumlah data 3 dimulai dari hitungan 0,1,2 
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fileGambarN = 
XMLData.gambar[stat].filenya.text(); 

Mengambil data filenya ke N dari dataku.xml -> hasil N ke 2 

:motor.jpg 

addChild(imgLoader); 

Menampilkan aset ke Stage 

 

Metode XML diatas bersifat opsional karena strategi penulisan 

syntax dalam Actionscript3 bisa berbeda, menurut pemahaman atau 

gaya penulisan masing-masing desainer. 

 

Pertanyaan Dan Diskusi: 

1. Apakah yang disebut dengan Eksternal Image? 

2. Apakah yang disebut dengan Identitas Data? 

3. Apakah yang disebut dengan cara Load Gambar? 

4. Apakah yang disebut dengan metode XML? 

5. Apakah yang disebut dengan Metode XML external? 
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BAB VI 

MEMBUAT INTERFACE LOAD MOVIE 
 

 

Perhatikan pada latihan kali ini akan dipelajari cara memuat file 

.swf eksternal kedalam stage utama, teknik yang digunakan pada 

tutorial ini adalah script assist. Jadi untuk mengasah kemampuan 

multimedia develop menggunakan Flash, perlu memodifikasi desain 

menggunakan Actionscript2  dinamis atau bahkan menggunakan 

actionscript 3.  

Pada intinya adalah file-file .swf dapat saling berkolaborasi 

dalam sistem multimedia sehingga memudahkan mengembangkan 

konten dengan berbagai tipe media.  

a. Menyiapkan File Aset 

1. Klik menu File > New 

2. Klik tombol Size pada property panel . Ubah 

ukurannya menjadi 300 width dan 70 height 

Tujuan Instruksional: 
1. Menjelaskan Tentang Load Movie 
2. Menjelaskan Tentang Aset File 
3. Menjelaskan Tentang Stage Load Movie 

4. Menjelaskan Tentang Unload Movie 
5. Menjelaskan Tentang Dragable Movie 
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3. Buat animasi Motion Tween logo perusahaan Anda 

a. Klik Text tool, ketik Teks misal “Budiman Corp” 

 

b. Klik teks budiman corp dan klik menu Insert > Convert 

to Symbol 

Behavior : Graphic, Name : gr_budiman 

c. Klik frame 15, klik menu insert > Keyframe 

d. Klik Free Transform tool dan tarik teks sehingga 

mengecil 

 

e. Klik frame 30, klik menu insert > Keyframe 

f. Klik Free Transform tool dan tarik teks sehingga 

kembali keukuran semula 

g. Klik keyframe 1 dan ubah Tween : Motion (pada 

property panel) 

h. Ulangi langkah g untuk keyframe 15 

i. Klik menu File > Save, simpan dengan nama Logo.fla 

j. Klik menu Control > Test Movie 

4. Klik menu File > New, untuk membuat file baru 
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5. Klik menu File > Import, import lah file video misalnya file 

video berformat .avi pada sample folder Windows Operating 

System. 

6. Klik Tombol Size pada Property Panel dan ubah ukuran 

document sesuai dengan dimensi video yaitu :  

 

7. Klik menu File > Save dan simpan dengan nama videoku.fla 

8. Klik menu Control > Test Movie 

Sekarang pada desain set telah memiliki dua buah file .swf yang 

satu bernama logo.swf dan yang lain bernama videoku.swf. Sebagai 

alternatif dapat digunakan file .swf apa saja yang ada pada satu folder, 

hal yang perlu diperhatikan adalah dimensi dari file-file .swf tersebut 

dapat dimuat pada stage utama. 

b. Membuat Desain Stage Load Movie 

Stage utama ini nantinya akan menjadi induk tempat peletakan 

file-file .swf yang dipanggil atau dimuat. 

1. Klik menu File > New, untuk membuat file baru 

2. Klik Rectangle Tool, buat tiga buah kotak untuk tombol 

3. Klik Text tool, beri nama kotak-kotak tersebut 
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4. Seleksi kotak logo dan klik menu Insert > Convert to Symbol 

Behavior : Button, Name : bt_logo dan untuk dua yang lain 

bt_video dan bt_stop 

 

5. Klik menu Insert > New Symbol 

 

6. Kembali ke mode Editing Scene1 

7. Klik dan seret mc_kosong dari Library ke Scene 
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8. Pastikan mc_kosong pada scene terseleksi dan pada panel 

Property beri nama instance : layar 

 

c. ActionScript Assist Load Movie 

Sekali lagi perhatikan, bahwa teknik yang diterapkan adalah 

menggunakan Script Assist (tersedia dalam menu Flash ActionScript). 

1. Seleksi tombol Logo dan Beri script sbb : + Action > 

Browser/Network > loadMovie 

URL : logo.swf 

 

2. Seleksi tombol videoku dan beri action script (metode script 

assist) + Action > Browser/Network > loadMovie URL : 

videoku.swf 

3. Seleksi tombol Stop dan beri script (metode script assist) + 

Action > Browser/Network > unloadMovie 
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4. Klik menu File > Save, beri nama menu.fla 

5. Klik menu Control > Test Movie 

d. Load Movie swf Actionscript2 

Berikut ini adalah alternatif pengaturan layout peletakan muatan 

media kedalam stage utama, jika menginginkan media dimuat pada 

lokasi tertentu secara bebas, tidak tergantung titik registration point 

yang selalu menggunakan acuan kanan atas stage. 

1. Menggunakan Level  

Level : adalah susunan lapisan yang ada di scene. Nol (0) adalah 

lapisan paling bawah jika anda mengisikan nol pada script maka 

seluruh komponen tombol akan hilang tergantikan oleh movie yang 

diload. 

Setiap movie yang diload dalam scene selalu menggunakan titik 

kiri atas sebagai pusat load. 

 

 

 

2. Menggunakan Target 

Target : adalah sasaran dimana anda akan menempatkan movie 

yang akan diload kedalam scene. Karena posisi level selalu pada kiri 

atas maka anda dapat mengisikan target dengan mc_kosong, dengan 

mengtikkan nama instance-nya. 

Sehingga Script berubah menjadi : 
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Script Tombol Logo : 

 

Script Tombol Videoku : 

 

Script Tombol Stop : 

 

e. Load Movie swf Actionscript3 

Pada latihan berikutnya akan dipelajari cara menerapkan 

actionscript 3 pada desain layout tersebut. Pertama-tama yang harus 

diingat adalah metode actionscript 3 memiliki perbedaan yang cukup 

besar bagi pengguna yang sudah terbiasa bekerja dengan lingkungan 

actionscript2.  

Sebagai latihan load Movie menggunakan actionscript 3 ikuti dan 

perhatikan latihan berikut : 

 Buatlah sebuah layout desain berupa tombol pada movie utama 

dan sebuah atau beberapa file .swf yang akan diload kedalam movie 

utama. 
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Perhatikan syarat load movie pada actionscript 3 yaitu : file .swf 

yang bisa dimuat adalah yang merupakan flash player versi 10 keatas, 

jika syarat tini tidak terpenuhi maka file .swf tidak bisa dimuat. Pada 

program Flash CS3 belum bisa menggunakan metode load movie 

actionscript 3 karena, flash playernya terbatas hanya sampai pada 

versi 9. Pada gambar dibawah ini diperlihatkan penggunaan Flash CC 

yang sudah mengakomodir Flash Player versi 17. 
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Selalu desain sebuah layout yang memiliki tempat penulisan 

actionscript pada layer tersendiri. 
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Pada Actionscript 3 ketikkan perintah berikut ini : 

biru_btn.addEventListener(MouseEvent.CLICK, 
muat); 
function muat(evt:MouseEvent):void { 
 var loader:Loader = new Loader(); 
 loader.load(new URLRequest("logoku.swf")); 
 addChild(loader); 
 loader.y=60; 
 loader.x=65; 
} 

Penjelasan actionscript diatas adalah :  

biru_btn.addEventListener(MouseEvent.CLICK, 
muat); 

Membuat tombol biru yang mendengarkan event CLICK, 

kemudian mengeksekusi fungsi muat.  

var loader:Loader = new Loader(); 
 loader.load(new URLRequest("logoku.swf")); 

Membuat variabel loader yang bertipe Loader, kemudian loader 

ini memuat URLRequest file logoku.swf. 

 addChild(loader); 
 loader.y=60; 
 loader.x=65; 

Menampilkan loader pada stage dengan lokasi y 60 dan x 65 pixel 

dari pojok kiri atas stage. 
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f. Unloadmovie Actionscript3 

Jika menginginkan sebuah tombol yang berfungsi untuk “meng-

unload” swf maka penulisan variabel loader harus diletakkan pada 

frame, sehingga actioncript 3 secara lengkap adalah sebagai berikut : 

var loader: Loader = new Loader(); 
loader.load(new URLRequest("batMobile.swf")); 
biru.addEventListener(MouseEvent.CLICK, 
muat); 
function muat(evt: MouseEvent): void { 
 
 addChild(loader); 
 loader.y = 0; 
 loader.x = 5; 
} 
biru2.addEventListener(MouseEvent.CLICK, 
bongkar); 
function bongkar(evt: MouseEvent): void { 
 removeChild(loader); 
 } 

g. Dragable Loaded Movie Actionscript3 

Pada latihan kali ini akan diperkenalkan konsep dragable 

menggunakan actionscript 3. Praktek latihan yang diperlukan adalah 

sebuah gambar bernama gambar1.jpg. Kemudian ketikkan 

actionscript 3 berikut pada frame 1 layer 1. 

//menginisialisasi loader 
//loader digunakan untuk menampung gambar 
var loader:Loader = new Loader(); 
 
//url request digunakan untuk mengubah alamat 
yang bertipe string menjadi URL 
var request:URLRequest = new 
URLRequest("gambar1.jpg"); 
 
//melakukan load 



  81 

Fitro Nur Hakim 

loader.load(request); 
 
//membuat movieclip kosong 
 
var movie = new MovieClip(); 
//menambahkan event onPress 
movie.addEventListener(MouseEvent.MOUSE_DOWN, 
onMoviePress); 
//menambahkan event onRelease 
movie.addEventListener(MouseEvent.MOUSE_UP, 
onMovieRelease); 
//memasukkan loader kedalam movie 
movie.addChild(loader); 
//memasukkan movie kedalam stage/root 
addChild(movie); 
 
//fungsi ketika diklik 
function onMoviePress(e:MouseEvent) { 
 //melakukan start drag 
 e.currentTarget.startDrag(); 
} 
//fungsi ketika dilepas 
function onMovieRelease(e:MouseEvent) { 
 e.currentTarget.stopDrag(); 
} 

h. Tombol Dragable ActionScript3 

Penerapan actionscript3 untuk desain tombol navigasi drag and 

drop sebagaimana pada latihan Bab 2 adalah sebagai berikut : 

var statusnya:Number = 0; 
menu_mc.addEventListener(MouseEvent.MOUSE_DOW
N, onMoviePress); 
menu_mc.addEventListener(MouseEvent.MOUSE_UP, 
onMovieRelease); 
function onMoviePress(e:MouseEvent) { 
 if (statusnya==0) { 
  e.currentTarget.startDrag(); 
  menu_mc.gotoAndPlay(2); 
  statusnya =1; 
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 } else { 
  e.currentTarget.startDrag(); 
  menu_mc.gotoAndStop(1); 
  statusnya =0; 
 } 
} 
function onMovieRelease(e:MouseEvent) { 
 e.currentTarget.stopDrag(); 
} 
 

Alternatif skenario script = Tombol tidak bisa drag sebelum 

menutup 

var statusnya:Number = 0; 
menu_mc.addEventListener(MouseEvent.MOUSE_DOW
N, onMoviePress); 
menu_mc.addEventListener(MouseEvent.MOUSE_UP, 
onMovieRelease); 
function onMoviePress(e:MouseEvent) { 
 if (statusnya==0) { 
  e.currentTarget.startDrag(); 
  menu_mc.gotoAndStop(1); 
  statusnya =1; 
 } else { 
  menu_mc.gotoAndPlay(2); 
  statusnya =0; 
 } 
} 
function onMovieRelease(e:MouseEvent) { 
 e.currentTarget.stopDrag(); 
} 

ActionScript 3 drag and drop diatas memerlukan bantuan frame 

script berupa stop(); pada animasi tombol di posisi tombol naik, 

dan tombol turun. 
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Pada posisi tombol naik adalah pada frame 1 sedangkan posisi 

tombol turun adalah frame 25. Peletakan actionsript 3 dapat terlihat 

jelas pada frame yang tertera huruf “a” yang menandakan didalamnya 

terdapat actionscript. 

 

Pertanyaan Dan Diskusi: 

1. Apakah yang disebut dengan Load Movie? 

2. Apakah yang disebut dengan Aset File? 

3. Apakah yang disebut dengan Stage Load Movie? 

4. Apakah yang disebut dengan Unload Movie? 

5. Apakah yang disebut dengan Dragable Movie? 
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BAB VII 

MEMBUAT INTERFACE ATTACH MOVIE 
 

 

Script attach movie hampir sama fungsinya dengan script load 

movie, perbedaan yang paling mendasar adalah file-file yang 

digunakan tidak terpisah seperti script load movie. Dengan teknik 

attach movie, kita tidak memerlukan file eksternal melainkan 

beberapa movie clip yang tersimpan dalam library atau masih dalam 

satu file yang sama.  

a. Menyiapkan Movie Clip 

1. Klik Menu Insert > New Symbol... 

 

2. Klik Menu File > Import, pilih file berikut 

 

3. Perkecil ukuran film kira-kira setengahnya 

Tujuan Instruksional: 
1. Menjelaskan Tentang Attach Movie 
2. Menjelaskan Tentang Desain Stage 
3. Menjelaskan Tentang Assist Attach 
4. Menjelaskan Tentang Koordinat Movie 

5. Menjelaskan Tentang Linkage 
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4. Buat lagi Movie Clip seperti langkah 1, isi scene-nya 

dengan animasi logo Anda. Atau ikuti langkah 4 sampai 

14 berikut : Klik Menu Insert > New Symbol... 

5. Pilih Behavior : Movie Clip, Isikan Name : logo 

6. Klik Text Tool, pilih Static Text  dan Tulis Nama Logo 

Anda. Pastikan Logo Anda ditengah-tengah Registration 

Point yang berbentuk tanda Plus! 

 

7. Klik Teks Anda dan Klik menu Insert > Convert to 

Symbol.. 

8. Name : Logoteks, Behavior : Graphic 

9. Klik Frame 5 kemudian Klik Menu Insert > Insert 

Keyframe 

10. Jadikanlah frame 15, 25 dan 30 menjadi Keyframe 
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11. Klik Keyframe 15, kmd klik Free Transform Tool dan 

perkecil / tarik logoteks anda menjadi garis spt gbr 

berikut : 

 

12. Klik Keyframe 5 kmd klik Tween pada properties dan 

pilih Motion 

 

13. Klik Keyframe 15 kmd klik Tween pada properties dan 

pilih Motion  

14. Tekan Enter untuk melihat hasil animasi logo Anda. 

15. Klik Scene 1 untuk kembali ke mode editing Scene 

 

b. Membuat Desain Stage Attach Movie 

1. Klik Menu Window > Library, untuk melihat apakah Anda telah 

menyiapkan Movie Clip dengan benar. 

2. Buatlah 2 buah Symbol Button pada scene 1  
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c. ActionScript Assist Attach Movie 

1. Klik symbol film pada Library dan Pilih Lingkage, dan klik 

Centang Export for ActionScript 

2. Ulangi langkah 1 untuk symbol logo 
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3. Klik Tombol Biru dan klik Menu Window Action, pilih attach 

Movie 
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4. Pada kotak isian script masukkan sbb : 

 

Pada Id dan New Name diberi tanda petik karena menyatakan 

Nama, dan untuk Init Object berikan koordinat x dan y. Sedangkan 

depth menyatakan kedalaman seperti halnya level. 

5. Lakukan Test Movie 

d. Pemanfaatan Koordinat Attach Movie 
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1. Untuk lebih jelas tentang koordinat scene maka lakukan 

langkah berikut.  

Klik menu View > Rulers sehingga terlihat ukuran pixel scene 

tempat anda membuat interface. 

2. Jika X:290 maka jarak tersebut diambil dari 0 kearah kanan 

sepanjang 290 pixel 

jika Y:370 maka jarak tersebut diambil dari 0 kearah bawah 

sepanjang 370 pixel 

3. Ubahlah koordinat x: menjadi 350 dan Y: menjadi 150 

4. Lakukan test movie 

5. Berikanlah Script Attach movie untuk tombol hijau. Dapat pula 

seperti contoh berikut : 

on (release) { 
    this.attachMovie("logo", "baru1", 1, 
{_x:350, _y:150}); 
} 

e. ActionScript Assist Empty MovieClip 

Untuk menghapus movie clip yang telah di-attach dalam scene 

digunakan script Create Empty Movie Clip 

1. Buat symbol tombol baru 

2. Klik tombol dan buka action 

3. Script ini terletak tepat dibawah attach movie (pada gambar 

4.c. langkah ketiga)  

 

4. Pada kotak isian script ketik sbb : 
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5. Script akan terlihat seperti dibawah ini : 

on (release) { 
    this.createEmptyMovieClip("kosong", 1); 
} 

6. Lakukan test Movie 

 

Sebagai catatan penting actionscript attach movie dalam kontek 

latihan ini adalah untuk memberikan alternatif jika sebuah desain 

multimedia interaktif memiliki konten video yang diletakkan dalam 

library .fla. Perkembangan selanjutnya berorientasi pada keringkasan 

sebuah program maka, penggunaan load movie menjadi pilihan utama. 

Hal tersebut didukung dengan metode actionscript terbaru yaitu 
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actionscript 3, sehingga penggunaan attach movie merupakan metode 

opsional. Pada prakteknya lingkage tetap digunakan pada actionscript 

3 namun tetap menggunakan syntax load, bukan attach. Meskipun file 

yang dipanggil berada pada libray, penulisan actionscript 3 tetap 

menggunakan metode load movie. 

f. Penerapan Linkage pada ActionScript3 

Pada latihan kali ini akan dipelajari cara menerapkan lingkage 

pada actionscript 3 dan memanggil movieclip pada library kedalam 

stage. 

Buat lah sebuah layout yang memiliki satu symbol movie clip 

dalam library seperti contoh berikut ini : 
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Pada symbol yang ada berikan linkage dengan nama “Bintang” 

caranya : Pada panel Lybrary Klik Kanan Symbol Bintang > Pilih 

Properties > Export for Action Script 

 

Actionscript 3 untuk memanggil movieclip dalam library 

tersebut adalah  

var bintangku:Bintang = new Bintang(); 
addChild(bintangku); 
bintangku.x=200; 
bintangku.y=100; 

Variabel bintangku adalah kelas bintang yang telah dibuat 

pada langkah Lingkage sebelumnya. 

Untuk menghapus movieclip yang dipanggil dengan cara 

load adalah menggunakan perintah removeChild(); - 

sehingga penerapan actionscript 3 pada tombol untuk 

menghapus atau menghilangkan moviclip panggilan adalah 

sebagai berikut : 

biru_btn.addEventListener(MouseEvent.CLICK, 
hapus); 
function hapus (evt:MouseEvent){ 
 removeChild(bintangku); 
 } 

 

Pertanyaan Dan Diskusi: 
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1. Apakah yang disebut dengan Attach Movie? 

2. Apakah yang disebut dengan Desain Stage? 

3. Apakah yang disebut dengan Assist Attach? 

4. Apakah yang disebut dengan Koordinat Movie? 

5. Apakah yang disebut dengan Linkage? 
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BAB VIII 

MEMBUAT NAVIGASI TIMELINE 
 

 

Tujuan dari latihan kali ini adalah untuk mengingat kembali 

pelajaran actionscript yang telah diterapkan pada latihan-latihan 

sebelumnya. Pada awal latihan akan diberikan pelajaran cara 

membuat sistem menggunakan metode actionscrpt assist. Setelah 

memahami konsep dari latihan ini maka akan dikembangkan kemodel 

actionsctipt 3. 

a. Membuat Movie Clip Isi Gambar 

1. Klik File > New untuk membuat file baru 

2. Klik Menu Insert > New Symbol, untuk membuat symbol baru 

dan pilih  

Behavior  : Movie Clip - Name : Gambar 

3. Klik menu File > Import, untuk memasukkan file gambar 

pilihlah gambar yang sudah ada di sample picture 

MyDocument. Pilih salah satu misalnya water lilies.jpg 

Tujuan Instruksional: 
1. Menjelaskan Tentang Timeline 
2. Menjelaskan Tentang Navigasi 
3. Menjelaskan Tentang Movieclip Gambar  
4. Menjelaskan Tentang Layout Fadein 

5. Menjelaskan Tentang Action Navigasi 
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4. Klik gambar pada frame dan klik menu Modify > Transform > 

Scale and Rotate… 

masukkan ukuran scale 50% 

 

5. Klik frame 2 dan klik menu Insert > Blank Keyframe 

6. Ulangi langkah 3 hingga 5 untuk frame 2 dengan gambar 

sunset.jpg 

7. Klik frame 3 dan klik menu Insert > Blank Keyframe 

8. Ulangi langkah 3 hingga 5 untuk frame 3 dengan gambar 

winter.jpg 

9. Klik menu Insert > Layer, untuk membuat layer baru, dan beri 

nama layer ini “script” 

10. Pada keyframe 1 layer script berikanlah script stop(); 

 

 

b. Membuat Layout Fade In 

11. Kembali pada Scene1 atau Klik menu Edit > Edit Document 

12. Klik Renctangle tool dan buat kotak untuk dijadikan tombol 
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13. Seleksi kotak dan tekan menu Insert > Convert to Symbol… 

Behavior : Button – Name : Hijau 

14. Buatlah 2 kopi simbol tombol Hijau sehingga pada Scene 1 

terdapat 3 tombol 

15. Klik menu Insert > Layer, untuk membuat layer baru dan beri 

nama “gambar” 

16. Klik menu Window Library untuk membuka panel Library 

17. Klik dan seret kira-kira ketengah Scene 1 simbol Gambar yang 

telah anda buat pada langkah awal 

18. Klik frame 10 pada layer Gambar, dan klik menu Insert > 

Keyframe 

19. Klik keyframe 1 layer Gambar, klik simbol pada scene1 dan 

ubah Property (panel dibawah scene) menjadi Color : 

Alpha 0% 

20. Klik keyframe 1 layer Gambar, ubah Property menjadi Tween

 : Motion 

21. Klik menu Insert > Layer, untuk membuat layer baru dan beri 

nama script 

22. Klik frame 10 dan klik menu Insert >Keyframe 

23. Klik frame 10 layer 1 yang berisi tombol-tombol (boleh diganti 

nama leyernya menjadi “tombol”) dan klik menu Insert > frame 

c. Actionscript Assist Navigasi Timeline 
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24. Klik simbol pada layer “gambar” dan pada panel Propery  

berikan nama Instance  : isinya_mc 

  

25. Pada tombol 1 Berikanlah script berikut : 

on (release){ 
 isinya_mc.gotoAndStop(1); 
 gotoAndPlay(1); 
} 

26. Pada tombol 2 dan tiga anda tinggal mengganti baris kedua 

menjadi 

on (release){ 
 isinya_mc.gotoAndStop(frame gambar yang 
dituju); 
 gotoAndPlay(1); 
} 

 

d. Actionscript 3 Navigasi Timeline 

Membuat layout atau mengelola multimedia pada timeline 

adalah cara termudah untuk membangun sistem multimedia 
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interatktif, atau dapat dikatakan bahawa timeline adalah dasar 

rancangan multimedia dalam Flash. Perhatikan bahwa jika telah 

memutuskan untuk menggunakan actionsript maka metode timeline 

ini memerlukan teknik framescript untuk perpaduan jalannya sistem. 

 

Movieclip hanya terdiri dari 4 keyframe, berisi gambar-gambar .jpg 

Kebutuhan membuat Multimedia Interaktif menggunakan 

Timeline sangatlah sederhana, pertama buat Movieclip dengan konten 

yang diletakkan pada masing-masing keyframe. Pada stage utama 

buatlah layer yang membedakan konten, action, tombol dan movieclip. 

Layer movieclip diisi dengan movieclip seperti desain pada contoh 

(batmobile) diatas, beri nama instance movieclip tersebut : 

isinya_mc. Layer tombol diisi sebuah tombol sederhana saja 

bernama tombol1_btn. Layer action berisi actionscript 3. 
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Scene 1 terdiri dari tiga layer sederhana 

Secara sederhana jika layout latihan diatas dikerjakan 

menggunakan actionscript 3 maka akan tertulis sebagai berikut : 

function mainkan2 (evt:MouseEvent){ 
 isinya_mc.gotoAndStop(2); 
 this.gotoAndPlay(1); 
 } 
tombol1_btn.addEventListener(MouseEvent.CLICK
, mainkan2); 

Mengelola konten multimedia interaktif dalam timeline sangat 

mudah dan dapat dikatakan operasi actionscript timeline mirip 
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dengan logika sederhana manusia, untuk itu pelajarilah modifikasi 

navigasi konten menjadi tombol next dan previous berikut ini : untuk 

itu pelajarilah modifikasi navigasi konten menjadi tombol next dan 

previous berikut ini : 

 

 

Modifikasi desain antarmuka dengan hanya menambahkan tombol 

//Membuat tombol Next 
function mainkan(evt:MouseEvent) { 
 var statusnya:Number = 
isinya_mc.currentFrame; 
 statusnya ++; 
 isinya_mc.gotoAndStop(statusnya); 
 this.gotoAndPlay(isinya_mc.currentFrame); 
 if (statusnya > isinya_mc.totalFrames) { 
  isinya_mc.gotoAndStop(1); 
 } 
 trace(statusnya); 
} 
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tombol1_btn.addEventListener(MouseEvent.CLICK
, mainkan); 
//Membuat tombol Previous 
function mundurkan(evt:MouseEvent) { 
 var statusnya:Number = 
isinya_mc.currentFrame; 
 statusnya --; 
 isinya_mc.gotoAndStop(statusnya); 
 this.gotoAndPlay(isinya_mc.currentFrame); 
 if (statusnya <1 ) { 
 
 isinya_mc.gotoAndStop(isinya_mc.totalFrames)
; 
 } 
 trace(statusnya); 
} 
tombol2_btn.addEventListener(MouseEvent.CLICK
, mundurkan); 

Sebagai catatan penting yang merupakan perintah pokok dari 

modifikasi script diatas adalah .currentFrame – yaitu angka yang 

menunjukkan nomor frame playhead. Sedangkan .totalFrames 

adalah angka yang menunjukkan jumlah frames suatu movie clip. 

 

Pertanyaan Dan Diskusi: 

1. Apakah yang disebut dengan Timeline? 

2. Apakah yang disebut dengan Navigasi? 

3. Apakah yang disebut dengan Movieclip Gambar? 

4. Apakah yang disebut dengan Layout Fadein? 

5. Apakah yang disebut dengan Action Navigasi? 
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BAB IX 

KONTROL MEDIA SUARA 
 

 

Untuk memberikan elemen suara pada media interaktif 

menggunakan Flash sangatlah mudah, tinggal mengimpor suara 

kedalam Library kemudian menyeretnya masuk kedalam scene atau 

stage agar menjadi suara latar. 

Tetapi jika ingin memakai tombol untuk mengontrol suara, maka 

latihan dibawah ini dapat digunakan, yaitu membuat tombol on/off 

suara. 

a. Membuat Suara Latar 

1. Klik File > New untuk membuat file baru 

2. Klik Menu File > Import untuk memasukkan file suara misalnya 

suara format .wav pada contoh berikut berada dalam folder 

audio. File suara dapat anda buka disample suara 

c:/windows/help/tours/windowsMediaPlayer/audio/wav 

(pilih salah satu filenya) 

Tujuan Instruksional: 
1. Menjelaskan Tentang Media Suara 
2. Menjelaskan Tentang Suara Latar 
3. Menjelaskan Tentang Tombol Suara 

4. Menjelaskan Tentang Tombol on/off 
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3. Klik menu Windows > Library 

4. Klik dan seret file wav yang telah Anda import kedalam library 

 

Secara otomatis file suara akan diimpor kedalam Library, 

walaupun menggunakan prosedur impor normal, hal ini menandakan 

bahwa seharusnya tentukan dulu lokasi spesifik tempat suara akan 

dimainkan / diputar. 

5. Klik layer1 frame1 anda akan melihat informasi suara sudah 

masuk sebagai suara latar 
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Flash juga memiliki fitur untuk mengedit suara, pilih frame suara 

yang telah di bentangkan pada timeline, kemudian lihat properties 

yang tersedia untuk mengedit suara.  

a. Effect : adalah menu yang tersedia untuk memilih efek stereo 

suara, misalnya suara yang diinginkan hanya terdengar dari 

chanel kiri atau kanan, atau suara yang diinginkan terdengar 

fade dari chanel kiri ke kanan atau sebaliknya, dan dapat juga 

diatur fade out. Fade out yaitu, suara yang terdengar berkesan 

hilang secara perlahan.  

b. Sync : adalah menu yang tersedia untuk menentukan tipe suara 

saat di download dari internet.  

c. Streaming Sound. Suara akan tetap terdengar walaupun hanya 

sebagian yang baru didownload. Suara streaming akan 

terdengar sepanjang waktu yang telah selesai didownload.  

d. Event Sound. Suara akan terdengar dalam kondisi movie 

apapun. Suara event sound harus didownload hingga selesai 

dahulu sebelum diplay.  

e. Loops : adalah menu untuk menentukan berapa kali suara akan 

dimainkan secara berulang-ulang.  
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f. Edit : adalah menu untuk memodifikasi suara secara  manual 

berdasarkan sifat stereo file suara tersebut, yaitu left atau right 

channel.  

6. Klik menu File > Save untuk menyimpan file anda dengan nama 

musik.fla 

7. Klik menu Control > Test Movie 

b. Membuat Tombol on/off Suara 

1. Klik menu File > New untuk membuat file baru 

2. Klik Rectangle tool dan gambarlah kotak untuk membuat 

tombol 

 

3. Seleksi kotak dan klik Menu Insert > Convert to Symbol 

 

4. Klik symbol button ini dan beri nama instance tombol_btn 

5. Klik layer1 dan Klik Menu Modify dan ubah namanya menjadi 

tombol. Layer ini dimaksudkan untuk wadah tombol. 

6. Klik menu Insert > Layer dan beri nama script 

c. Tombol on/off Menggunakan Actionscript2 

Klik frame1 layer script dan ketik script berikut 

loadMovieNum("musik.swf", 2); 
tombol_btn.onRelease=function() { 
 if(_level2){ 
  unloadMovieNum(2); 
 }else{ 
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  loadMovieNum("musik.swf", 2); 
 } 
} 

Penjelasan script adalah sbb : 

loadMovieNum("musik.swf", 2); 

Pada saat Play Head (  ) berjalan atau movie dimainkan maka 

musik.swf akan diload dan diputar pada level 2  

 
tombol_btn.onRelease=function() { 
 if(_level2){ 
  unloadMovieNum(2); 

Pada saat tombol mouse dilepas jika di level 2 terdapat obyek 

maka akan di unload level 2 tersebut. 

 
}else{ 
  loadMovieNum("musik.swf", 2); 
 } 

Jika tidak ada, maka akan diload musik.swf pada level 2 dan 

begitu seterusnya. Sehingga tombol berfungsi sebagai on off suara. 

d. Tombol on/off Menggunakan Actionscript3 

Kontrol suara menggunakan Actionscript 3 lebih mudah karena 

suara dapat dipanggil langsung dari Library ke Stage, dengan terlebih 

dahulu memberi nama Linkage. Pemberian nama Linkage pada 

actionscript 3 dikenal dengan Class, lihat pada gambar dibawah ini : 
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Setelah pemberian nama Class, maka suara dapat dipanggil 

dengan actionscript .play sedangkan untuk menghentikan suara 

dapat diberikan perintah SoundMixer.stopAll();  

var suaraLatar:SoftIns = new SoftIns(); 
var statusnya:Number = 0; 
trace(statusnya); 
tombol.addEventListener(MouseEvent.CLICK, 
putar); 
function putar(ev:MouseEvent):void { 
 if (statusnya==0) { 
  SoundMixer.stopAll(); 
  suaraLatar.play(); 
  statusnya =1; 
  trace(statusnya); 
 } else { 
  SoundMixer.stopAll(); 
  statusnya=0; 
 } 
} 

Penjelasan penerapan actionscript3 pada tombol diatas adalah : 

Jika variabel statusnya sama dengan nol, maka hentikan suara 

yang ada sebelum memutar suaraLatar. Perintah 

SoundMixer.stopAll(); diterapkan untuk memastikan tidak ada 

suara yang diputar sebelumnya, sehingga terhindar dari terjadinya 

suara yang bertumpuk. 
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Pertanyaan Dan Diskusi: 

1. Apakah yang disebut dengan Media Suara? 

2. Apakah yang disebut dengan Suara Latar? 

3. Apakah yang disebut dengan Tombol Suara? 

4. Apakah yang disebut dengan Tombol on/off? 

5. Bagaimana cara membuat kontrol suara 

menggunakan actionscript? 
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BAB X 

MEMBUAT KUIS 
 

 

Ide dari pemanfaatan multimedia adalah memberikan 

pengalaman kepada audiens yang berbeda dalam mengakses soal, 

misalnya untuk menampilkan opsi jawaban dapat langsung 

ditampilkan visual nya, sekaligus visual menjadi input jawaban dari 

konteks pertanyaan soal. 

a. Kuis Pilihan Ganda Script Assist 

Pada latihan kali ini akan dipelajari cara membuat kuis dengan 

memanfaatkan media gambar sebagai opsi jawabannya, dan latihan 

awal pembuatan kuis ini akan diselesaikan menggunakan 

Actionscript2.  

Buat Empat buah layer sebagai berikut : 

 

Tujuan Instruksional: 
1. Menjelaskan Tentang Kuis 
2. Menjelaskan Tentang Desain Layout 
3. Menjelaskan Tentang Kuis Jawaban 

4. Menjelaskan Tentang XML Kuis  
5. Menjelaskan Tentang Kuis Multiple Choise 
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Desain Frame 1, terlihat inputText dengan nama Var:nama 

 

Actionscript2 untuk frame 1 adalah : 

stop(); 
nilai = 0; 

Action tombol mulai adalah : 

on (release) { 
 gotoAndStop(2); 
 peserta = nama; 
} 

 

Desain layout pada frame 2 adalah sebagai berikut : 
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Terdapat DynamicText dengan nama Var:peserta 

Opsi gambar sebagai tombol dengan nama Instance a ; b dan c. 

Tombol ulang dan lanjut dapat diberi nama Instance ulang_btn 

dan lanjut_btn 

Actionscript tombol a 

on (release) { 
 b._visible = false; 
 c._visible = false; 
} 

Actionscript tombol b 

on (release) { 
 a._visible = false; 
 c._visible = false; 
} 

Actionscript tombol c, sebagai jawaban yang benar : 

on (release) { 
 nextFrame(); 
 nilai = nilai+10; 
} 

Actionscript tombol ulang : 

on (release) { 
 a._visible = true; 
 b._visible = true; 
 c._visible = true; 
} 

Actionscript tombol lanjut 

on(release){ 
 gotoAndStop(4) 
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} 

Desain layout Frame 3 

 

Terdapat DynamicText dengan nama Var:peserta 

Actionscript tombol ulang  

on (release) { 
 prevFrame(); 
 nilai = nilai-10; 
} 

Actionscript tombol lanjut 

on(release){ 
 gotoAndStop(4) 
} 

Tombol c tidak ada actionscriptnya. 

Sedangkan Layout Frame 4 adalah sebagai berikut : 
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Terdapat DynamicText dengan nama Var:peserta dan 

DynamicText dengan nama Var:nilai. 

Karena sistem scripting pada latihan diatas menggunakan assist 

dan framescript, maka jika ingin dibuat versi actionscript 3 –nya  pasti 

lebih mudah. 

b. Kuis Jawaban singkat Actionscript 3 

Pada latihan kali ini akan dipelajari cara membuat kuis jawaban 

singkat menggunakan actionscript 3 dan Array. 

1.Desain Layout Frame 1 

Cara membuat kuis menggunakan actionscript 3 ini lebih mirip 

dengan soal konvensional, yaitu pertanyaan teks dan menuliskan 

jawaban singkat berupa teks juga. Actionscript pada latihan ini dapat 

menjadi acuan kreasi pembuatan kuis yang lebih menarik. 
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Pada desain layout diatas terdiri dari (baris kedua) DynamicText 

bernama instance tanya_txt dan (baris ketiga) InputText bernama 

Instance jawab_txt. Actionscript 3 untuk Frame 1 adalah sebagai 

berikut : 

stop(); 
 
var noSoal: Number = 0; 
var tanya: Array = new Array(); 
var kunciJawab: Array = new Array("Jerapah", 
"Macan", "Ayam", "Ular"); 
var jawab: Array = new Array(); 
 
tanya[0] = "Hewan berleher panjang"; 
tanya[1] = "Persamaan kata Harimau"; 
tanya[2] = "Binatang Paling banyak dimakan 
Manusia"; 
tanya[3] = "Tidak punya kaki"; 
 
tanya_txt.text = tanya[noSoal]; 
 
submit_btn.addEventListener(MouseEvent.CLICK, 
quiz); 
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function quiz(e: MouseEvent): void { 
 jawab.push(jawab_txt.text); 
 jawab_txt.text = ""; 
 noSoal++; 
 if (noSoal < tanya.length) { 
  tanya_txt.text = tanya[noSoal]; 
 } else { 
  nextFrame(); 
 } 
} 

2. Desain Layout Frame 2 

Desain layout kuis pada latihan kali ini bergantung pada 

kemampuan actionscript yang berbeda dengan latihan sebelumnya. 

Latihan sebelumnya lebih mementingkan aspek user experience. Pada 

latihan kali ini desain hanya memiliki dua Frame, pada Frame ke 2 

desain layout adalah sebagai berikut : 
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Pada desain layout diatas terdiri dari DynamicText bernama 

Instance jawab0_txt sampai dengan jawab3_txt dan pada 

sebelah kanan terdiri dari DynamicText bernama Instance 

kunciJawab0_txt sampai dengan kunciJawab3_txt. Terakhir 

terdapat DynamicText bernama Instance nilai_txt. 

Actionscript 3 untuk Frame 2 adalah : 

var nilai: Number = 0; 
 
for (var i: Number = 0; i < tanya.length; 
i++) { 
 this["jawab" + i + "_txt"].text = jawab[i]; 
 this["kunciJawab" + i + "_txt"].text = 
kunciJawab[i]; 
 if (jawab[i].toUpperCase() == 
kunciJawab[i].toUpperCase()) { 
  nilai++; 
 } 
 if (i == tanya.length - 1) { 
  nilai_txt.text = nilai.toString(); 
 } 
} 

Skenario latihan kuis diatas dijalankan pada Flash CC dapat 

berjalan dengan baik namun, terdapat bug penerapan actionscript 

latihan diatas pada software Flash CS 3 yaitu tidak dapat 

mengeksekusi data pertama dari Array. 

c. Kuis Jawaban Singkat XML Actionscript3 

Penggunaan XML akan membuat desain multimedia lebih 

fleksibel dalam hal penanganan data, sebab untuk mengubah konten 

hanya memerlukan sebuah teks editor sederhana, tanpa harus 

membuka source file flash-nya. Data soal yang perlu disiapkan adalah 

sebagai berikut : 
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Desain layout sederhana saja seperti pada latihan membuat kuis 

jawaban singkat sebelumnya. 

 

Sedangkan desain layout untuk frame 2 adalah sebagai berikut : 
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Actionscript3 untuk frame 1 adalah sebagai berikut : 

stop(); 
var xmlLoader: URLLoader = new URLLoader(); 
xmlLoader.load(new URLRequest("datane.xml")); 
xmlLoader.addEventListener(Event.COMPLETE, 
XMLLoaded); 
var XMLData: XML = new XML(); 
var noSoal: Number = 0; 
var jumlahSoal: Number; 
var tanya: String; 
var arrayKunci: Array = new Array(); 
function XMLLoaded(e: Event): void { 
 XMLData = new XML(e.target.data); 
 jumlahSoal = XMLData.soal.length(); 
 for (var i: Number = 0; i < jumlahSoal; i++) 
{ 
  //mengirim data xml ke array 
  arrayKunci[i] = 
XMLData.soal[i].jawab.text(); 
  trace("arrayKunci: "+arrayKunci); 
 } 
 tanyakan(); 
} 
 
function tanyakan(): void { 
 tanya_txt.text = 
XMLData.soal[noSoal].tanya.text(); 
} 
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var jawab: Array = new Array(); 
submit_btn.addEventListener(MouseEvent.CLICK, 
quiz); 
 
function quiz(e: MouseEvent): void { 
 jawab.push(jawab_txt.text); 
 //menjadikan data yg dipush sebagai string 
 //atau bisa ditulis --> jawab_txt.text =""; 
 jawab_txt.text =  new String(); 
 trace(jawab); 
 noSoal++; 
 if (noSoal < jumlahSoal) { 
  tanya_txt.text = 
XMLData.soal[noSoal].tanya.text(); 
 } else { 
  nextFrame(); 
 } 
} 

Actionscript3 untuk frame 2 adalah sebagai berikut : 

var nilai: Number = 0; 
for (var i: Number = 0; i < jumlahSoal; i++) 
{ 
 this["jawab" + i + "_txt"].text = jawab[i]; 
 this["kunciJawab" + i + "_txt"].text = 
arrayKunci[i]; 
 trace("nilai " + nilai); 
 if (jawab[i].toUpperCase() == 
arrayKunci[i].toUpperCase()) { 
  nilai++; 
 } 
 if (i < jumlahSoal) { 
  nilai_txt.text = nilai.toString(); 
 } 
} 

Penjelasan actionscript ada didalamnya berupa comment-

comment singkat yang diperlukan atau merupakan syntax yang baru 
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dipelajari dalam latihan kali ini. Yaitu mengirim data XML yang 

dipanggil kepada sebuah array, sehingga konten array ini dapat 

dimanfaatkan untuk soal-soal kuis.  

d. Kuis Multiplechoice ActionScript3 

 

Desain layout dilengkapi dengan movieclip instance name : 

mc_benar yang terdiri dari 2 frame : frame pertama berisi gambar 

benar dan frame 2 berisi gambar salah. Sedangkan tombol instance 

name : jawab ada di stage namun tersembunyi oleh actionscript. 

Adapula dynamic text instance name : pilih. 

ActionScript pada Frame1 

stop(); 
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pilih.text=". . ."; 
mc_benar.visible=false; 
var benar:Boolean=false; 
jawab.visible=false; 
var skor:Number=0; 
var nextsoal:Boolean=false; 
 
a1.addEventListener("click",ba1); 
function ba1(e:MouseEvent):void { 
 pilih.text="Jerapah"; 
 benar=true; 
 jawab.visible=true; 
} 
b1.addEventListener("click",bb1); 
function bb1(e:MouseEvent):void { 
 pilih.text="Elang"; 
 benar=false; 
 jawab.visible=true; 
} 
c1.addEventListener("click",bc1); 
function bc1(e:MouseEvent):void { 
 pilih.text="Harimau"; 
 benar=false; 
 jawab.visible=true; 
} 
 
jawab.addEventListener("click",jawab1); 
function jawab1(e:MouseEvent):void { 
 if (benar) { 
  nextsoal=true; 
  mc_benar.visible=true; 
  mc_benar.gotoAndStop(1); 
  skor+=10; 
 } 
 if (benar==false) { 
  nextsoal=true; 
  mc_benar.visible=true; 
  mc_benar.gotoAndStop(2); 
 } 
} 
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var loading:Number=0; 
 
addEventListener(Event.ENTER_FRAME,nsoal1); 
function nsoal1(e:Event):void { 
 if (nextsoal) { 
  loading++; 
  if (loading>=20) { 
   nextFrame(); 
  
 removeEventListener(Event.ENTER_FRAME,nsoal1
); 
  } 
 } 
} 

Desain layout pada frame 2 dalam latihan ini hanya berupa 

inisiasi untuk dilanjutkan sendiri dengan membuat soal kedua, ketiga 

dan seterusnya. 

 

Actionscript pada frame 2 adalah : 

skor_txt.text=skor.toString(); 
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Pertanyaan Dan Diskusi: 

1. Apakah yang disebut dengan Kuis? 

2. Apakah yang disebut dengan Desain Layout? 

3. Apakah yang disebut dengan Kuis Jawaban? 

4. Apakah yang disebut dengan XML Kuis? 

5. Apakah yang disebut dengan Kuis Multiple Choise? 
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BAB XI 

MENAMBAHKAN COMPONENT 
 

 

Component merupakan template yang disediakan Flash untuk 

memuat konten atau media kedalam desain. 

a. Menambahkan Component Scrollbar 

Scrollbar digunakan untuk menyingkat isi teks anda dalam 

textbox sehingga dapat digulung untuk membacanya. 

1. Klik Text Tool untuk membuat area teks 

2. Pilih opsi Dynamic Text pada Properties. Buatlah kira-kira 

kotak teks berukuran 100x100 pixel, ukuran huruf 12 pt dan 

linetype pilih multiline, beri nama instance tulisan. 

    

 

Tujuan Instruksional: 
1. Menjelaskan Tentang Component 
2. Menjelaskan Tentang Scrollbar 
3. Menjelaskan Tentang Scrollpane 

4. Menjelaskan Tentang Video 
5. Menjelaskan Tentang Control Video 
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3. Klik menu > Window > Component dan pastikan opsi tersebut 

dicentang 

4. Pada panel Component klik dan seret Scrollbar ke Stage 

 

5. Pada Stage pastikan komponen scrollbar menempel pada text 

box yang telah anda buat, sehingga dengan otomatis komponen 

tersebut akan menyesuaikan ukurannya dengan teks box yang 

telah ada. 

 

6. Klik ganda text box-nya untuk membuat teks, anda dapat 

mengisinya dengan menkopi teks atau tulisan yang berada 

pada program pengolah kata, usahakan teks-nya terdiri dari 

beberapa paragraf sehingga melebihi text box yang berukuran 

100 pixel. 
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7. Tekan menu Control > Test Movie, hasilnya anda memiliki teks 

yang dapat digulung. 

b. Menggunakan Component Scrollpane 

Scroll pane sangat berguna untuk menampilkan gambar atau isi 

yang sangat lebar dimensinya. 

1. Klik Menu Insert > New Symbol, pilih Behavior  = Movie Clip 

dan beri nama gambar 

2. Pada mode editing symbol MC Klik menu Insert dan pilih 

gambar berformat .jpg misalnya pilih winter.jpg yang ada di 

sample pictures 

3. Kembali pada mo editing Scene1 dan hapus movie clip gambar 

pada Scene, karena akan dimasukkan kedalam Scrollpane 

4. Klik menu Window > Library dan pastikan opsi Library 

dicentang 

5. Klik kanan symbol gambar dan pilih Linkage, beri nama 

winter_id 
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6. Buka panel Component, klik dan seret Scrollpane dari panel ke 

stage, atur ukuran komponent sesuai konsep anda. 

 

7. Pada panel properties scroll pane component ketik nama 

linkage pada opsi scroll content 

 

8. Tekan menu Control > Test Movie 
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c. Membuat Control Video 

Video yang anda tampilkan pada interface interaktif dapat 

dikontrol dengan tombol play dan pause seperti layaknya movie clip, 

karena video yang telah diipor kedalam movie flash memiliki behavior 

movie clip. 

1. Klik File > import, untuk memasukkan file film atau video, 

misalnya format .avi. 

2. Klik ganda layer1 dan ganti nama menjadi video 

3. Klik menu Insert > Layer,  untuk membuat layer baru  dan ganti 

namanya menjadi tombol. 

4. Klik Line Tool dan buat gambar tombol play dan pause 

5. Convert masing-masing gambar menjadi symbol tombol play 

dan tombol pause. 
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6. Klik tombol play dan beri nama instance play_btn 

7. Klik tombol pause dan beri nama instance pause_btn 

8. Klik menu Insert > Layer, untuk membuat layer dengan nama 

framescript 

9. Ketik script dalam mode expert 

stop(); 
play_btn.onRelease = function () { 
 play(); 
} 
pause_btn.onRelease = function () { 
 stop(); 
} 

Penjelasan Script 

stop(); 
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adalah perintah untuk menghentikan event pada movie utama 

sehingga play head tidak berjalan saat movie dimainkan pertama 

kalinya. 

 

play_btn.onRelease = function () { 
 play(); 
} 

Adalah untuk menjalankan play head ke frame selanjutnya dan 

seterusnya. 

 

pause_btn.onRelease = function () { 
 stop(); 
} 

Adalah untuk menghentikan play head pada frame saat event 

tombol mouse (Release) di capai. 

 

Pertanyaan Dan Diskusi: 

1. Apakah yang disebut dengan Component? 

2. Apakah yang disebut dengan Component Scrollpane? 

3. Apakah yang disebut dengan Component Scrollbar? 

4. Apakah yang disebut dengan Component Video? 

5. Apakah yang disebut dengan Control Video? 
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BAB XII 

MEMBUAT DOCUMENT CLASS 
 

 

Ketika dibutuhkan lebih banyak ruang saat membuat coding 

pada timeline, maka saat itulah diperlukan teknik document class. Clas 

artinya tidak diperlukan lagi menulis code dalam timeline, code atau 

script akan berada diluar secara terpisah. 

Berikut ini adalah contoh sederhana penggunakan teknik 

document class : 

 

Baris pertama mendefinisikan paket, yang mana merupakan 

struktur mandatori yang memerintahkan kompiler tentang class yang 

dibuat. Hal tersebut dapat dipahami sebagai deskripsi jalur ke file 

Tujuan Instruksional: 
1. Menjelaskan Tentang Document Class 
2. Menjelaskan Tentang Sprite Document Class 
3. Menjelaskan Tentang MovieClip Document Class 

4. Menjelaskan Tentang file action script 
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actionscript. Pada praktikum awal, semua file sebaiknya berada pada 

satu folder 

Statement adalah hal penting selanjutnya yang digunakan dalam 

paket, semua flash class harus diimport kedalam class yang dibuat. 

Dalam praktikum awal, diperlihatkan bahwa diperintahkan untuk 

mengimpor seluruh Paket MovieClip dari Flash, karena nantinya akan 

menggunakan instance movieclip dalam latihan pembuatan class yang 

akan dilakukan kali ini. Ketika sebuah class ditambahkan, maka class 

baru akan memiliki kemampuan parent class. 

Pada cuplikan contoh sederhana class diatas, kuncinya adalah 

Main yaitu nama file yang disebut Main.as. Maka class Main adalah 

child dari class MovieClip. Yang akan membuat instance dalam Main 

class bisa melakukan apa saja seperti movie clip. Untuk membuat class 

MovieClip tersedia dalam class baru yaitu Main, diperlukan untuk 

menulis kode yang mengimpor MovieClip kedalam file yang akan 

dikerjakan. Class main harus ditambahkan kedalam class yang dibuat 

dan akan berada didalam keseluruhan class.  

Dalam Main Class terdapat konstruktor function, yang 

merupakan fungsi utama dari class. Function ini harus merupakan 

publik. Walaupun class seringkali memiliki banyak function, tiap class 

harus memiliki satu function yang namanya sama dengan nama file 

class. Class ini merupakan konstruktor function, dan merupakan 

keharusan, yang mana secara otomatis tercipta ketika membuat file 

actionscript baru. Konstruktor function tercipta secara otomatis setiap 

kali instrance class dibuat. 
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Konstruktor class harus publik yang artinya adalah access 

modifier. Dengan menjadikan class publik, maka class ini dapat 

diakses dari file lain. Terdapat beberapa access modifier: 

 Private – Metode dan properties yang dilabeli private 

hanya akan terserdia dalam file class. 

 Protected – Metode dan properties yang dilabeli 

protected akan tersedia hanya untuk file class dan child 

nya. 

 Internal – Metode dan properties yang dilabeli Internal 

hanya akan tersedia dalam file class dan seluruh file yang 

berada dalam satu paket. 

a. Sprite Document Class 

Class Sprite adalah tampilan sebuah building block sederhana, 

yang dapat menampilkan graphic dan bisa juga berisi children. Obyek 

Sprite hampir sama dengan obyek movie clip, namun tidak memiliki 

timeline. Sprite merupakan class yang cocok untuk membuat obyek 

yang memang tidak memerluka timeline. Sebagai contoh sprite 

digunakn untuk membuat komponen user interface yang pada 

umumnya tidak menggunakan timeline. Class Sprite adalah hal baru 

dalam actionscript3, merupakan alternatif dari fungsi class movie clip.  

Pada latihan dibawah ini akan diberikan contoh pembuatan 

obyek sederhana menggunakan sprite document class. 

1. Pertama buat dahulu flash dengan actionscript3 seperti gambar 

dibawah ini 
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2. Kemudian buatlah file baru yang tipenya adalah file actionscript 

Now create an ActionScript file and call it Main. 
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3. Pada halaman file actionscript, ketik contoh latihan yang tertera 

seperti dibawah ini, pada contoh yang ada menggunakan Sprite class 

namun hal ini tidak beda jauh dengan MovieClip) 

 

4. Perintah diatas akan mengeksekusi pembuatan lingkaran dan 

memerintahkan trace “circle added to the display list”. 

5. Sekarang class terbuat, tinggal memerintahkan flash akan 

diletakkan dimana. Pada Panel Properties akan tampak : 
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6. Pada properties seksi class ketikkan nama class (kelas) dan 

lokasinya. 

 

 

 

7. Pada contoh diatas maka ketik Main pada Class, karena di file as3 

memang sudah dipanggil demikian. 



  139 

Fitro Nur Hakim 

8. Sekarang ketika file ini di-run, akan terlihat lingkaran pada swf, dan 

pada seksi output akan tertulis Circle added to the display list!. 

9. Hasil final akan terlihat sebagaimana pada gambar dibawah ini : 

 

Pada latihan berikutnya akan dibuat document Class 

menggunakan MovieClip dari latihan sebelumnya yaitu LoadMovie. 

b. MovieClip Document Class 

Tidak seperti obyek Sprite, Obyek MovieClip memiliki timeline. 

Document Class akan memisahkan antara code dengan file .fla 

sehingga desain multimedia akan lebih rapi. Pada latihan kali ini akan 

membuat Load Movie SWF pada BAB VI menjadi format Document 

Class. Sebagai awalan untuk mengingatkan latihan ini adalah 

menggunkan desain sebagai berikut: 
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Buatlah File Document Class dari Program Adobe Flash atau 

Notepad sebagai berikut: 

 

package { 
 //import statement memastikan script atau 
code bekerja 
 import flash.display.MovieClip; 
 import flash.events.MouseEvent; 
 import flash.display.Loader; 
 import flash.net.URLRequest; 
 
 public class ScriptKu extends MovieClip { 
  //Memastikan script akan berlaku 
sepanjang movieclip 
 
  public function ScriptKu() { 
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   // constructor code 
  
 biru_btn.addEventListener(MouseEvent.CLICK, 
muat); 
   var loader: Loader = new Loader(); 
   function muat(evt: MouseEvent): 
void { 
    loader.load(new 
URLRequest("logoku.swf")); 
    addChild(loader); 
    loader.y = 60; 
    loader.x = 65; 
   } 
  } 
 } 
} 

Simpan file document class tersebut dengan nama ScriptKu.as 

jika menggunakan program Notepad. Jika membuat document class 

menggunakan Adobe Flash maka Import Statement akan ditambahkan 

secara otomatis oleh Flash-nya, sehingga meminimalisir terjadinya 

error. 

Sedangkan pada file flash atau .fla pastikan koneksi dengan 

document class yang telah dibuat : 

 

Perhatikan pada file flash .fla yang sedang dibuat, pasti akan 

menunjukkan saling keterkaitan dengan file document class yang 

sedang diketik pula. 
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Dalam keterkaian tersebut dapat mempermudah untuk 

pengujian media dan scriptnya. Dalam mode document class dapat 

langsung dilakukan test movie, sedangakan pada file fla dapat 

dilakukan test movie dengan memastikan document class ScriptKu.as 

di-Save (disimpan). 

 

Pertanyaan Dan Diskusi: 

1. Apakah yang disebut dengan Document Class? 

2. Apakah format script diluar dokumen flash?  

3. Apakah yang disebut dengan Sprite? 

4. Apakah yang disebut dengan MovieClip? 

5. Apakah perbedaan Class Sprite dengan Class Movie 

Clip? 

 

 

  



  143 

Fitro Nur Hakim 

BAB XIII 

MEDIA INTERAKTIF 
 

 

Media Interaktif salah satunya CD (Compact Disk) Interatif 

adalah salah satu media interaktif yang bisa terbilang baru. Media ini 

sebenarnya merupakan pengembangan dari teknologi internet yang 

akhir-akhir ini berkembang pesat. Sebagaimana dimaklumi bahwa 

teknologi internet saat ini menjadi salah satu tolok ukur majunya 

suatu perusahaan. Dari data disebutkan bahwa lebih dari 200 juta 

orang menggunakan media ini, termasuk di antaranya penduduk 

Indonesia. 

AC Nielsen menyatakan bahwa 3% dari penduduk Indonesia juga 

merupakan pengguna aktif internet (Istanto, 20001). Data ini juga 

memungkinkan perubahan yang semakin besar seiring semakin 

merakyatnya teknologi ini di masyarakat. Hal yang sebenarnya tidak 

mengherankan, mengingat internet memiliki keunggulan-keunggulan 

dibandingkan dengan media lain. Media ini demikian mudah 

digunakan, memiliki kecepatan tinggi, dan yang paling penting bahwa 

internet memiliki jaringan yang mendunia.  

Tujuan Instruksional: 
1. Menjelaskan Tentang Media Pembelajaran 
2. Menjelaskan Tentang Jenis Media 
3. Menjelaskan Tentang Desain Komunikasi 

4. Menjelaskan Tentang FS Command 
5. Menjelaskan Tentang Autorun 
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Bahkan, dengan kenyataan tersebut kini setiap perusahaan atau 

lembaga yang bergerak dalam bidang apapun merasa “berkewajiban” 

untuk memiliki situs sendiri yang berfungsi menyampaikan informasi 

seputar eksistensi keberadaan dirinya kepada masyarakat di seluruh 

dunia. 

Berkembangnya internet ini tidak lepas dari perkembangan 

teknologi PC (Personal Computer) dan software yang dari tahun ke 

tahun semakin canggih. Terlebih lagi setelah diperkenalkannya 

teknologi multimedia pada era tahun 80-an.  

Versi online (aktif di jaringan) internet ini kemudian diadopsi 

dalam versi offline (tanpa jaringan) dalam bentuk CD Interaktif dengan 

tampilan yang tetap menarik walau terbatas penggunaannya pada 

lokal satu unit PC (Personal Computer) saja. Hal ini yang menjadikan 

adanya korelasi antara internet dan CD Interaktif. 

a. Definisi Media Interaktif  

Compact Disk Interaktif merupakan sebuah media yang 

menegaskan sebuah format multimedia dapat dikemas dalam sebuah 

CD (Compact Disk) dengan tujuan aplikasi interaktif di dalamnya. CD 

ROM (Read Only Memory) merupakan satu-satunya dari beberapa 

kemungkinan yang dapat menyatukan suara, video, teks, dan program 

dalam CD (Tim Medikomp, 1994).  

Kemudian dalam program talk show e-Lifestyle yang ditayangkan 

Metro TV pada 9 Agustus 2003 pukul 09.00 WIB disebutkan bahwa CD 

Interaktif adalah sebuah CD yang berisi menu-menu yang dapat diklik 

untuk menampilkan sebuah informasi tertentu. 

Dari sini jelas bahwa sistem interaktif yang dipakai CD Interaktif 

sama persis dengan sistem navigasi pada internet, hanya yang berbeda 
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di sini adalah media yang dipakai keduanya. CD Interaktif memakai 

media off line berupa CD sementara Internet memakai media on line. 

b. Interaktif Media Pembelajaran  

Media pembelajaran saat ini sudah semakin beragam, mulai dari 

media konvensional seperti buku dan alat peraga tradisional sampai 

dengan media modern audio visual berupa kaset tape, VCD (Video 

Compact Disk), maupun alat paraga modern lainnya. Dengan beragam 

media tersebut, maka suatu sistem pembelajaran yang dapat 

menghadirkan suasana menyenangkan mutlak diperlukan. Oleh 

karena itu tidak salah jika CD Interaktif merupakan salah satu 

alternatif media yang dapat menjawab kebutuhan tersebut. 

Menurut praktisi media Augus Savara dalam program e-Lifestyle 

Metro TV, Sabtu 9 Agustus 2003, kelebihan CD Interaktif antara lain: 

 Penggunanya bisa berinteraksi dengan program komputer 

 Menambah pengetahuan. Pengetahuan yang dimaksud adalah 

materi pelajaran yang disajikan CD Interaktif 

 Tampilan audio visual yang menarik 

Kelebihan pertama yang menyebutkan bahwa penggunanya bisa 

berinteraksi dengan komputer adalah bahwa dalam CD Interaktif 

terdapat menu-menu khusus yang dapat diklik oleh user untuk 

memunculkan informasi berupa audio, visual maupun fitur lain yang 

diinginkan oleh pengguna. Kemudian yang kedua adalah menambah 

pengetahuan. Pengetahuan di sini adalah materi pembelajaran yang 

dirancang kemudahannya dalam CD Interaktif bagi pengguna. 

Kelebihan ketiga adalah tampilan audio visual yang menarik. Menarik 

di sini tentu saja jika dibandingkan dengan media konvensional seperti 

buku atau media dua dimensi lainnya. Kemenarikan di sini utamanya 
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karena sistem interaksi yang tidak dimiliki oleh media cetak (buku) 

maupun media elektronik lain (film TV, audio).  

Dari beberapa keunggulan CD Interaktif, dapat diketahui bahwa 

CD Interaktif dapat membantu mempertajam pesan yang disampaikan 

dengan kelebihannya menarik indera dan menarik minat, karena 

merupakan gabungan antara pandangan, suara, dan gerakan (Suyanto, 

2003: 18). 

c. Jenis Media Interaktif 

Saat ini di Indonesia banyak sekali dijual CD Interaktif. CD 

tersebut ada yang buatan asing dan ada pula yang buatan lokal (dalam 

negeri). Ada CD Interaktif untuk anak-anak balita, yang tujuannya 

merangsang aspek kognitif anak. Ada juga untuk pelajar SD, yang 

isinya antara lain mengenal huruf, belajar membaca dan berhitung, 

dan yang berisi aneka gambar. Sedangkan untuk sekolah menengah 

ada CD Interaktif berbagai mata pelajaran, seperti mengenal organ 

tubuh manusia (Tim Metro TV, 2004: 22). Kemudian dalam 

http://www.ialf.edu/kipbipa/papers/OudaTeda Ena.doc disebutkan 

bahwa Propinsi Bali telah menggunakan CD Interaktif dalam 

mempromosikan pariwisatanya. Perusahaan, baik pemerintah 

maupun swasta telah banyak memakai media ini untuk 

menginformasikan profilnya pada calon-calon investor. 

Jenis CD Interaktif dengan asumsi menurut tujuannya dapat 

dibagi menjadi: 

 Komersial, seperti CD Interaktif tutorial maupun pembelajaran 

untuk anak-anak. 

 Non-Komersial, seperti CD Interaktif profil pemerintahan, 

wisata, kota, maupun profil perusahaan. 
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d. Media dalam Desain Komunikasi Visual 

Tampilan halaman CD Interaktif merupakan sebuah proses 

komunikasi yang disampaikan secara visual. Kerja seorang perancang 

atau desainer komunikasi visual berkaitan dengan proses komunikasi 

sebuah materi untuk dikonsumsi oleh sekelompok target komunikan, 

yaitu user CD Interaktif adalah bagaimana materi tersebut dapat 

diterima oleh komunikan dengan efektif sesuai target yang 

diharapkan. Artinya reaksi yang diberikan oleh dari user CD Interaktif 

harus sesuai tujuan dibuatnya sistem informasi tersebut. 

Desainer bertanggung jawab atas pemecahan masalah 

komunikasi dalam menyampaikan informasi tersebut secara 

fungsional, elegan, sistematis, proporsional, sederhana, dan ekonomis. 

Demikian halnya pada perancangan sebuah CD Interaktif. 

Sebagai sebuah produk, CD Interaktif merupakan hasil 

pemecahan suatu masalah berdasarkan pendekatan komunikasi 

visual. Rancangan sebuah CD Interaktf adalah sebuah desain 

komunikasi visual yang ditayangkan melalui monitor yang dapat 

dihadirkan pada saat tertentu. Layar monitor berfungsi sebagai media 

komunikasi visual yang tampilannya tidak berbeda dengan desain 

sebuah majalah atau sebuah surat kabar (Istanto, 2001:55), sehingga 

kaidah-kaidah perancangan CD Interaktif adalah kaidah-kaidah yang 

berkaitan dengan desain komunikasi visual. 

e. Elemen Perancangan Media Interaktif 

Membuat halaman CD interaktif tak ubahnya membuat halaman 

web karena meman secara umum halaman web sama dengan halaman 

Media interaktif, hanya medianya saja yang berbeda. Dengan demikian 
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hanya kaidah-kaidah yang ada pada Media Interaktif dan web adalah 

sama. 

Seorang desainer menggunakan elemen-elemen pokok agar 

sebuah desain dapat secara efektif menyampaikan tujuannya. Elemen-

elemen yang digunakan tersebut antara lain adalah tipografi, 

simbolisme, ilustrasi dan fotografi (Istanto, 2001:57). Sedangkan 

menurut Budi Sutedjo Dharma Oetomo (Oetomo, 2001) menyatakan 

ada 10 unsur yang dapat digunakan untuk merancang sebuah halaman 

Media Interaktif yang cantik dan artistik, yaitu huruf, warna, gambar, 

model kartun, foto, animasi, tiga dimensi, bentuk-bentuk geometri, 

tekstur, dan manusia. 

Dari berbagai pendapat itu maka dapat disimpulkan ada 

beberapa elemen yang sangat vital dalam proses perancangan sebuah 

Media Interaktif yang artistik dan efektif, diantaranya adalah: 

tipografi, simbolisme, ilustrasi, warna, fotografi, animasi, nuansa, dan 

halaman depan. 

f. FS Command 

 Membuat Media Interaktif tidak dibatasi dengan ukuran file 

sehingga isinya dapat didesain dengan lebih kreatif, berbeda 

dengan membuat web yang apabila filenya terlalu besar akan 

lama untuk dibuka (loading). 

 Dengan fitur pembuat projector yang dimiliki Flash kita tetap 

akan memperoleh kompatibilitas yang terjaga, karena tidak 

tergantung pada plug-in atau software third party lainnya 

untuk menjalankan Media interaktif. Flash memungkinkan kita 

mengemas file pada format exe, sehingga pada komputer 

umum dapat dieksekusi. 
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Contoh perintah FS Command untuk CD Interaktif 

Fscommand(“fullscreen”, true); 

FSCommand tidak akan berjalan saat anda melakukan test 

movie, tetapi anda harus melakukan Publish atau menjalankan file 

swf-nya dari windows explorer. 

Fscommand(“quit”,true); 

Quit digunakan untuk membuat perintah keluar dari aplikasi 

flash movie. 

g. Membuat Media Autorun 

Seringkali desain CD Interaktif menerapkan autorun sehingga 

ketika CD dimasukkan kedalam CD Drive maka desain antarmuka akan 

langsung dijalankan dan langsung dapat diakses. 

Script autorun CD dapat Anda buat menggunakan program 

Notepad dan menyimpan filenya dengan nama “autorun.inf” 

[AutoRun] 
OPEN=main.exe 
ICON=main.ico 

File autorun ini harus berada pada root direktori CD dan file 

movie.swf terletak satu folder dengan autorun.inf. jika ingin 

meletakkan folder secara lebih spesifik maka anda harus memodifikasi 

scriptnya sbb: 

[AutoRun] 
OPEN=interaktif/movie.exe 
ICON=main.ico 



150 

Fitro Nur Hakim 

Supaya CD interaktif anda lebih menarik maka gunakan software 

Icon Maker untuk menciptakan ikon yang sesuai dengan konsep 

desain CD interaktif anda. Juga terdapat software Autorun Generator 

yang dapat digunakan untuk membuat file autorun daripada anda 

mengetik scriptnya secara manual. 

Jika memilih menggunakan Flashdis sebagai pengganti Compact 

Disk, maka untuk membuat Autorun tidaklah berbeda jauh. Buka 

Notepad atau software plain teks yang ada pada komputer,  kemudian 

ketikkan  

[AutoRun] 
shellexecute=example.exe 

Ganti example.exe dengan nama file yang ingin di runing 

otomatis, termasuk file extensionnya misal:  index.html, slideshow.ppt, 

portfolio.pdf dan lain-lain. Jika file eksekusi terdapat spasi maka 

gantilah spasi tersebut menggunakan _ (strip bawah). Letakkan file 

yang diperlukan berada pada satu folder, sebuah URL juga dapat 

dieksekusi dengan autorun, msial : 

[AutoRun] 
shellexecute=http://www.YourWebAddress.com 

Simpanlah nama file notepad tadi menjadi Autorun.inf. Letakkan 

file tersebut di root flashdisk, lengkap dengan file-file yang ingin 

dijalankan. 

 

Pertanyaan Dan Diskusi: 

1. Apakah yang disebut dengan Media Pembelajaran? 

2. Apakah yang disebut dengan Jenis Media? 
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3. Apakah yang disebut dengan Desain Komunikasi? 

4. Apakah yang disebut dengan FS Command? 

5. Apakah yang disebut dengan Autorun? 
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BAB XIV 

SISTEM INTERAKTIF 
 

 

Halaman Multimedia Interaktif yang Interaktif dibentuk oleh 

teknik penyajian halaman-halaman pada layar monitor yang akan 

diakses oleh oemakai. Untukmembuat halaman Multimedia interaktif 

yang interaktif, faktor-faktor berikut perlu mendapatkan perhatian, 

seperti yang dikemukaan I..T. Hawryszkiews dalam (Oetomo, 

2001:164). 

a. Workspace 

Tampilan pada layar monitor harus ditata dengan baik dan 

proporsional, dimana tidak seluruh ruang yang ada dipenuhi dengan 

tulisan, gambar atau fasilitas menu. Hal ini mempertimbangkan 

kemampuan dan kenyamanan mata dari si pengguna dalam 

melakukan scanning. Pembuat halaman Multimedia Interaktif juga 

harus mempertimbangkan sudut yang dibentuk ketika mata bergerak 

ke kiri terjauh dan kanan terjauh 

b. Mudah digunakan 

Pembangunan sistem muga harus memperhatikan derajat di 

mana pemakai dapat menggunakan sistem secara mudah karena 

Tujuan Instruksional: 
1. Menjelaskan Tentang Interaktifitas 
2. Menjelaskan Tentang Cognitive Phsycology 

3. Menjelaskan Tentang Sistem  
4. Menjelaskan Tentang Kemudahan Sistem 
5. Menjelaskan Tentang Sistem Ergonomik 
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sistem mudah dipelajari dan membangkitkan sikap positif setelah 

berinteraksi. 

c. Ergonomic 

Sistem yang baik juga harus mempertimbangkan faktor 

kenyamanan dan keamanan dalam penggunaan antar halaman 

Multimedia Interaktif. 

d. Cognitive Psychology 

Agar sistem dapat berinteraksi dengan user secara baik, maka 

perancang harus mempertimbangkan faktor psikologis, karena 

pemahaman seseorang terhadap sesuatu yang ditatapnya dipengaruhi 

oleh pengetahuan dan pemahaman yang telah dimiliki seseorang 

sebelumnya. Oleh karena itu penggunaan simbol, bentuk, ataupun 

gambar tertentu harus mempertimbangkan faktor cognitive 

psychology tersebut antara lain: 

 Jumlah warna. Jumlah warna yang berlebihan akan 

mengaburkan penekanan informasi-informsi tertentu. 

 Simbol standar. Gunakan simbol-simbol yang standar dan 

secara umum telah diterima oleh komunitas TI, seperti OK, exit, 

close, gambar printer, gambar disket, dan sebagainya. Simbol-

simbol itu akan mempermudah pengguna memahami halaman 

yang tersaji. 

a. Sistem yang Mudah Digunakan 

Agar sistem yang dibangun mudah digunakan, maka para analis 

dan pemrogram perlu memperhatikan beberapa teknik perancangan 

sistem sebagai berikut: 
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a. Perancangan berbasis pemakai. Rancangan sistem 

harus berdasarkan kebutuhan pemakai, bukan 

berdasarkan idealisme pembuat. 

b. Perancangan secara partisipatif. Untuk memastikan 

bahwa sistem yang dibangun seseuai dengan kebutuhan 

pemakai, maka pemakai perlu dilibatkan sebagai 

anggota tim perancang atau sebagai konsultan. 

c. Perancangan secara eksperimental. Perancangan model 

ini dilakukan dengan menyusun prototipe sistem. 

Setelah disusun, maka perlu dilakukan uji pemakai 

resmi untuk memperoleh kesan dan pendapat pemakai. 

Masukan dari hasil uji pemakai resmi ini digunakan 

untuk penyempurnaan sebelum sistem diterapkan. 

d. Proses perancangan, pengujian, pengukuran dilakukan 

dengan prosedur yang tetap sampai memenuhi 

spesifikasi yang diharapkan. 

b. Sistem yang Ergonomik 

Untuk menciptakan kenyamanan dan keamanan dalam 

penggunaan antar halaman sistem, maka beberapa faktor berikut 

perlu dipertimbangkan: 

a. Karakter tentu akan banyak mendominasi 

pembangunan antar halaman sistem. Oleh karena itu, 

penentuan jenis, ukuran, dan format karakter harus 

dirancang sedemikian rupa agar dapat memberi 

kenyamanan dan keamanan bagi pemakai. Nyaman 

karena mudah dan enak dibaca, sedangkan aman 

artinya menekan serendah mungkin resiko salah baca 
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dan kerusakan organ mata pemakai. Oleh karena itu 

perancang sistem perlu mewaspadai karakter-karakter 

yang membingungkan seperti angka 1 (satu) dengan 

huruf l (el), 2 dengan z, 8 dengan B, 0 dan O dan 

sebagainya. 

b. Pemilihan warna harus memperhatikan faktor radiasi 

sinar yang dapat melelahkan mata para pengguna, di 

mana warna merah, oranye, kuning, dan hijau serta 

warna-warna metalik perlu dihindari. Pilihan warna 

yang tepat diperlukan untuk menyajikan objek yang 

tipis atau kecil agar otot mata tidak tegang pada saat 

melihat dan mengamatinya. 

c. Perpaduan warna juga harus mendapat perhatian 

tersediri. Misalnya jika latar ditentukan warna yang 

terang, maka warna tulisan sebaiknya warna yang lebih 

gelap. 

d. Kompleksitas sajian pada sebuah halaman Multimedia 

Interaktif harus dikelola dengan baik agar tidak 

mengurangi kenyamanan pada saat melihatnya. 

Pengelolaan kompleksitas sajian antar halaman sangat 

diperlukan mengingat kemampuan scanning mata 

sangat terbatas. 

 

Pertanyaan Dan Diskusi: 

1. Apakah yang disebut dengan Sistem? 

2. Apakah yang disebut dengan Interaktifitas? 
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3. Apakah yang disebut dengan Kemudahan Sistem? 

4. Apakah yang disebut dengan Cognitive Phsycology? 

5. Apakah yang disebut dengan Sistem Ergonomik? 

 

 

  



  157 

Fitro Nur Hakim 

DAFTAR PUSTAKA 
 

1. Agnew, P.W., Kellerman, A.S & Meyer, M. J. (1996). Multimedia 
in the Classroom. Boston: Allyn and Bacon. 

2. Braunstein, Roger (2010). ActionScript 3.0 Bible Second 
Edition, Wiley Publishing, Inc., Indiana, Canada. 

3. Burdekin, Julee, (2005). Flash ActionScript 2Language 

Reference, Macromedia Inc, San Fransisco. 
4. Surasmi, Wuwuh Asrining, (2016). Pemanfaatan Multimedia 

Untuk Mendukung Kualitas Pembelajaran, Prosiding Ilmiah 
Nasional Guru (Ting) VIII 

5. Shupe, Reich, Zevan Rosser, (2008). Learning ActionScript 3.0 
A Begineer’s Guide, O’Reilly Media, Inc., Canada. 

 




