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KATA PENGANTAR 

Visual Basic .NET merupakan bahasa pemrograman komputer 
berorientasi objek yang diimplementasikan pada .NET Framework. Visual 
Basic .Net merupakan pengembangan dari bahasa pemrograman Visual 
Basic 6. Bahasa pemrograman Visual Basic .Net banyak digunakan untuk 
pembuatan aplikasi baik aplikasi single user maupun multi user. 

Buku ini di susun untuk dipersembahkan kepada mahasiswa 
Universitas STEKOM agar dapat membuat aplikasi dengan bahasa 
pemrograman Visual Basic .Net. Buku ini berisi contoh aplikasi Inventory 
Barang yang terdiri dari Form Barang untuk menyimpan data Barang, Form 
Suplier untuk menyimpan data Suplier, Form Pembelian untuk menyimpan 
transaksi Pembelian, Form Customer untuk menyimpan data Customer dan 
Form Pembelian untuk menyimpan data Pembelian. Pembuatan laporan 
tidak menggunakan program bantu tetapi menggunakan komponen Print 
Document yang sudah ada di Visual Basic .Net, laporan yang dibuat yaitu 
laporan data Barang, data Suplier, data Customer, data Pembelian 
PerFaktur, data Pembelian PerPeriode dan data Penjualan PerNota. Form 
Pemakai, form Login dan form Hak Akses digunakan untuk mengatur hak 
akses pemakai dalam mengakses form dan laporan yang ada di aplikasi 
Inventory. Untuk lebih memahami materi, pada buku ini terdapat link video 
pembelajaran untuk masing-masing materi. 

Harapan penyusun, buku ini bisa bermanfaat dan bisa digunakan 
oleh mahasiswa dan pembaca pada umumnya untuk pembuatan aplikasi 
menggunakan bahasa pemrograman Visual Basic .Net.  
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BAB I 
APLIKASI INVENTORY BARANG 

 
1.1 FORM BARANG 

 

 
 

Gambar 1.1 Form Data Barang 
 

Form Barang digunakan untuk menyimpan data master Barang, data 
yang diinput yaitu Kode Barang, Nama Barang, Harga Beli, Harga Jual 
dan Jumlah Awal. Data Jumlah Beli akan terisi otomatis dari data 
Transaksi Pembelian, data Jumlah Jual akan terisi otomatis dari data 
Transaksi Penjualan dan data Jumlah Stok terisi dari Jumlah Awal 
ditambah Jumlah Beli dikurangi Jumlah Jual. 
 

1.2 FORM SUPLIER 
 

 
 

Gambar 1.2 Form Data Suplier 
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Form Suplier digunakan untuk menyimpan data master Suplier yang 
terdiri dari Kode Suplier, Nama Suplier, Alamat Suplier dan Nomor 
Telpon Suplier.  
 

1.3 FORM PEMBELIAN 
 

 
 

Gambar 1.3 Form Transaksi Pembelian 
 

Form Pembelian digunakan untuk menyimpan data transaksi Pembelian 
dengan menginput data Nomor Faktur, Tanggal Pembelian dan Kode 
Suplier. Satu Faktur Pembelian bisa terdiri dari beberapa item barang. 
 

1.4 FORM CUSTOMER 
 

 
Gambar 1.4 Form Data Customer 
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Form Customer digunakan untuk menyimpan data master Customer yang 
terdiri dari Kode Customer, Nama Customer, Alamat Customer dan 
Nomor Telpon Customer.  
 

1.5 FORM PENJUALAN 
 

 
 

Gambar 1.5 Form Transaksi Penjualan 
 

Form Penjualan digunakan untuk menyimpan data transaksi Penjualan 
dengan menginput data Nomor Nota, Tanggal Penjualan dan Kode 
Customer. Satu Nota Penjualan bisa terdiri dari beberapa item barang. 
 

1.6 FORM MENU UTAMA 
 

 
 

Gambar 1.6 Form Menu Utama 
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Form Menu Utama untuk menjalankan Form Barang, Form Suplier, 
Form Pembelian, Form Customer dan Form Penjualan dari satu form. 
 

1.7 CETAK DATA BARANG 
 

 
Gambar 1.7 Laporan Data Barang 

 

Menampilkan data Barang di layar yang bisa pula dicetak ke printer. 
 

1.8 CETAK DATA SUPLIER 
 

 
Gambar 1.8 Laporan Data Suplier 

 

Menampilkan data Suplier di layar yang bisa pula dicetak ke printer. 
 

1.9 CETAK DATA PEMBELIAN PERFAKTUR  
 

 
Gambar 1.9 Laporan Pembelian PerFaktur 

 
Menampilkan data Pembelian PerFaktur  di layar yang bisa pula dicetak 
ke printer. 
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1.10 CETAK DATA PEMBELIAN PERPERIODE  
 

 
 

Gambar 1.10 Laporan Pembelian PerPeriode 
 

Menampilkan data Pembelian PerPeriode  di layar yang bisa pula 
dicetak ke printer. 

 
1.11 CETAK DATA CUSTOMER 

 

 
 

Gambar 1.11 Laporan Data Customer  
 

Menampilkan data Customer di layar yang bisa dicetak ke printer. 
 

1.12 CETAK DATA PENJUALAN PERNOTA 
 

 
 

Gambar 1.12 Laporan Penjualan PerNota 
 

Menampilkan data Penjualan PerNota  di layar yang bisa pula dicetak ke 
printer. 
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1.13 CETAK DATA PENJUALAN PERPERIODE 
 

 
 

Gambar 1.13 Laporan Penjualan PerPeriode 
 

Menampilkan data Penjualan PerPeriode di layar bisa dicetak ke printer. 
 

1.14 FORM PEMAKAI 
 

 
 

Gambar 1.14 Form Pemakai 
Form Pemakai menyimpan data pemakai program Inventory Barang. 
 

1.15 FORM LOGIN 
 

 
 

Gambar 1.15 Form Login 
Form Login untuk mengatur hak akses pemakai sesuai jabatan. 
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1.16 FORM HAK AKSES 
 

 
 

Gambar 1.16 Form Hak Akses 
 

Form Hak Akses untuk mengatur hak akses masing-masing pemakai 
sesuai dengan jabatannya tanpa merubah kode program. 
 

1.17 TUTORIAL APLIKASI INVENTORY BARANG 
 

 
 

https://youtu.be/AWjtwKle_Lc 
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BAB II 
FORM DATA BARANG 

 
2.1  CAPAIAN PEMBELAJARAN 

Capaian pembelajaran dari Form Data Barang yaitu mahasiswa 
memahami struktur tabel Barang, dapat mendesain Form Data Barang, 
memahami kode program yang digunakan dan cara mengoperasikan 
Form Data Barang yang meliputi manambah data baru, mengedit data 
dan menghapus data. 

 
2.2  FORM DATA BARANG 

A. MENDESAIN FORM DATA BARANG 
Langkah-langkah mendesain Form Data Barang sebagai berikut : 
1. Aktifkan Program Visual Basic .Net 
2. Klik menu File ⇒ New Project 
3. Ketik PRINV pada kotak Name,  Klik tombol OK 
4. Klik tempat kosong pada area Form 
5. Klik propertie Name, Ketik FORMBARANG 
6. Klik menu File ⇒ Save All, Klik tombol Browse 
7. Tentukan folder lokasi penyimpanan file proyek  
8. Klik tombol Select Folder, Klik tombol Save 
9. Buat desain Form Data Barang di bawah ini 

 

 
 

Gambar 2.1 Desain Form Data Barang 
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Daftar Objek pada Form Data Barang 
 

Komponen Properties Isi 

Label 

Text FORM DATA BARANG 
Text KODE BARANG 
Text NAMA BARANG 
Text HARGA BELI 
Text HARGA JUAL 
Text JUMLAH AWAL 

TextBox 

Name TXTKODEBRG 
Name TXTNAMABRG 
Name TXTHRGBELI 
Name TXTHRGJUAL 
Name TXTJMLAWAL 

Button 

Name BTSIMPAN 
Text SIMPAN 
Name BTHAPUS 
Text HAPUS 
Name BTBLANKFORM 
Text BLANKFORM 
Name BTCLOSE 
Text CLOSE 

DataGridView Name DGVBARANG 
 

10. Buat database MS Access DBINV.MDB pada folder 
PRINV\PRINV\BIN\DEBUG 

11. Buat struktur tabel berikut 
 

 
 

12. Simpan struktur tabel dengan nama BARANG 
13. Tutup program MS Access 
14. Kembali ke Form Barang 
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B. KODE PROGRAM FORM DATA BARANG 
Langkah berikutnya klik menu View => Code lalu ketik kode 
program berikut : 
 

 
Perintah Public untuk membuat variabel Publik supaya variabel 
tersebut dikenal oleh semua sub program. Variabel 
KONEKSISTRING berisi string untuk koneksi ke database, variabel 
KONEKSI untuk membuat koneksi ke database, variabel SQLSTR 
untuk perintah Query, variabel CMD untuk menjalankan perintah 
Query, variabel DABRG untuk penghubung data tabel, variabel 
DTBRG menyimpan data hasil perintah query. 
 

 
Saat form dijalankan akan dilakukan koneksi ke database 
DBINV.MDB dan membuka koneksi. 
 

 
Sub BLANKFORM untuk mengosongkan Textbox input data 
Barang, sub DGV untuk menampilkan data Barang ke DatagridView 
DGVBRG. Saat form aktif akan menjalankan sub BLANKFORM 
dan sub DGV. 
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Saat kursor meninggalkan Textbox TXTKODEBRG akan dideteksi 
apakah Kode Barang yang telah diketik sudah ada di tabel Barang, 
jika Kode Barang sudah ada maka datanya akan ditampilkan ke 
masing-masing Textbox. 
 

 
Saat diklik tombol SIMPAN akan dideteksi apakah Kode Barang 
yang disimpan sudah ada di tabel Barang, jika Kode Barang sudah 
ada maka data Barang akan diupdate sedangkan jika belum ada maka 
data Barang yang diinput akan ditambahkan sebagai data baru. 
 

 
Saat diklik tombol HAPUS akan ditampilkan konfirmasi apakah data 
Barang yang sedang tampil akan dihapus, jika diklik tombol Yes 
maka data Barang yang sedang tampil akan dihapus sedangkan jika 
diklik tombol No data Barang tidak akan dihapus. 
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Saat diklik tombol BLANKFORM akan menjalankan sub 
BLANKFORM untuk mengosongkan Textbox. 
 

 
Saat diklik tombol CLOSE akan menutup koneksi database dan 
menutup form. 
 

C. MENGOPERASIKAN FORM DATA BARANG 
1. Menambah data Barang 

Cara menambahkan data Barang : 
a. Klik menu Debug => Start Debugging 
b. Isikan data Kode Barang, Nama Barang, Harga Beli, Harga 

Jual dan Jumlah Awal 
c. Klik tombol SIMPAN untuk menyimpan data Barang 
Tekan tombol Tab untuk memindahkan kursor ke text box 
berikutnya. 
 

2. Mengedit data Barang 
Cara mengedit data Barang : 
a. Klik menu Debug => Start Debugging 
b. Isikan Kode Barang yang datanya mau diedit 
c. Tekan tombol Tab (data barang yang kodenya sesuai akan 

tampil) 
d. Lakukan pengeditan data 
e. Klik tombol SIMPAN untuk pengeditan data Barang 

 
3. Menghapus data Barang 

Cara menghapus data Barang : 
a. Klik menu Debug => Start Debugging 
b. Isikan Kode Barang yang datanya mau dihapus 
c. Tekan tombol Tab (data barang yang kodenya sesuai akan 

tampil) 
d. Klik tombol HAPUS 
e. Tampil konfirmasi data jadi dihapus atau tidak 
f. Klik tombol Yes jika data jadi dihapus atau klik tombol No 

jika data tidak jadi dihapus 
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2.3 TUTORIAL FORM BARANG 
 

 
 

https://youtu.be/8wFP13Ium84 
 

 
2.4 EVALUASI 

a. Atur supaya data Kode Barang hanya bisa diisi maksimal 6 karakter 
b. Atur supaya data Nama Barang hanya bisa diisi maksimal 25 karakter 
 

2.5 REFERENSI 

I Gusti Ngurah Suryantara, (2014), Merancang Aplikasi dengan VB .Net 
2013”, Jakarta : Elex Media Komputindo. 

Uus Rusmawan, (2013), Cara Cepat Belajar VB .Net, Jakarta : Elex 
Media Komputindo. 

Jubilee Enterprise, (2014), Visual Basic 2013 untuk Pemula, Jakarta : 
Elex Media Komputindo. 

WahanaKomputer, ST, (2013), Shortcourse Series : Visual Basic 2012, 
Yogyakarta : Andi Publisher. 
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BAB III 
FORM DATA SUPLIER 

 
3.1  CAPAIAN PEMBELAJARAN 

Capaian pembelajaran dari Form Data Suplier yaitu mahasiswa memahai 
struktur tabel Suplier, dapat mendesain Form Data Suplier, memahami 
kode program yang digunakan dan cara mengoperasikan Form Data 
Suplier yang meliputi manambah data baru, mengedit data dan 
menghapus data. 

 
3.2  FORM DATA SUPLIER 

A. MENDESAIN FORM DATA SUPLIER 
Langkah-langkah mendesain Form Data Suplier sebagai berikut : 
1. Buka database DBINV.MDB pada folder 

PRINV\PRINV\BIN\DEBUG 
2. Buat struktur tabel berikut : 

 
 
 
 

 

 
 

3. Simpan tabel dengan nama SUPLIER 
4. Tutup program MS Access 
5. Double klik file PRINV.SLN untuk membuka project Inventory 
6. Klik menu Project  ⇒ Add Windows Form  
7. Ketik nama form FORMSUPLIER 
8. Klik tombol Add, Buat desain Form Suplier berikut 

 

 
 

Gambar 2.2 Desain Form Data Suplier 
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Daftar Objek pada Form Data Suplier 

 

Komponen Properties Isi 

Label 

Text FORM DATA SUPLIER 
Text KODE SUPLIER 
Text NAMA SUPLIER 
Text ALAMAT 
Text NOMORTELPON 

TextBox 

Name TXTKODESP 
Name TXTNAMASP 
Name TXTALAMATSP 
Name TXTTELPONSP 

Button 

Name BTSIMPAN 
Text SIMPAN 
Name BTHAPUS 
Text HAPUS 
Name BTBLANKFORM 
Text BLANKFORM 
Name BTCLOSE 
Text CLOSE 

DataGridView Name DGVSP 
 
B. KODE PROGRAM FORM DATA SUPLIER 

Langkah berikutnya klik menu View => Code lalu ketik kode 
program berikut : 
 

 
Perintah Public untuk membuat variabel Publik supaya variabel 
tersebut dikenal oleh semua sub program. Variabel 
KONEKSISTRING berisi string untuk koneksi ke database, variabel 
KONEKSI untuk membuat koneksi ke database, variabel SQLSTR 
untuk perintah Query, variabel CMD untuk menjalankan perintah 
Query, variabel DASP untuk penghubung data tabel, variabel DTSP 
menyimpan data hasil perintah query. 
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Saat form dijalankan akan dilakukan koneksi ke database 
DBINV.MDB dan membuka koneksi. 
 

  
Sub BLANKFORM untuk mengosongkan Textbox input data 
Barang, sub DGV untuk menampilkan data Suplier ke DatagridView 
DGVSP. Saat form aktif akan menjalankan sub BLANKFORM dan 
sub DGV. 
 

 
Saat kursor meninggalkan Textbox TXTKODESP akan dideteksi 
apakah Kode Suplier yang telah diketik sudah ada di tabel Suplier, 
jika Kode Suplier sudah ada maka datanya akan ditampilkan ke 
masing-masing Textbox. 



17 

 

 

 
Saat diklik tombol SIMPAN akan dideteksi apakah Kode Suplier 
yang akan disimpan sudah ada di tabel Suplier, jika Kode Suplier 
sudah ada maka data Suplier akan diupdate sedangkan jika belum ada 
maka data Suplier yang diinput akan ditambahkan sebagai data baru. 
 

 
Saat diklik tombol HAPUS akan ditampilkan konfirmasi apakah data 
Suplier yang sedang tampil akan dihapus, jika diklik tombol Yes 
maka data Suplier yang sedang tampil akan dihapus sedangkan jika 
diklik tombol No data Suplier tidak akan dihapus. 
 

 
Saat diklik tombol BLANKFORM akan menjalankan sub 
BLANKFORM untuk mengosongkan Textbox. 
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Saat diklik tombol CLOSE akan menutup koneksi database dan 
menutup form. 
 

C. MENGOPERASIKAN FORM DATA SUPLIER 
1. Menambah data Suplier 

Cara menambahkan data Suplier : 
a. Klik menu Debug => Start Debugging 
b. Isikan data Kode Suplier, Nama Suplier, Alamat Suplier dan 

Nomor Telpon Suplier 
c. Klik tombol SIMPAN untuk menyimpan data Suplier 
Tekan tombol Tab untuk memindahkan kursor ke text box 
berikutnya. 
 

2. Mengedit data Suplier 
Cara mengedit data Suplier : 
a. Klik menu Debug => Start Debugging 
b. Isikan Kode Suplier yang datanya mau diedit 
c. Tekan tombol Tab (data Suplier yang kodenya sesuai akan 

tampil) 
d. Lakukan pengeditan data 
e. Klik tombol SIMPAN untuk pengeditan data Suplier 

 
3. Menghapus data Suplier 

Cara menghapus data Suplier : 
a. Klik menu Debug => Start Debugging 
b. Isikan Kode Suplier yang datanya mau dihapus 
c. Tekan tombol Tab (data Suplier yang kodenya sesuai akan 

tampil) 
d. Klik tombol HAPUS 
e. Tampil konfirmasi data jadi dihapus atau tidak 
f. Klik tombol Yes jika data jadi dihapus atau klik tombol No 

jika data tidak jadi dihapus 
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3.3 TUTORIAL FORM SUPLIER 
 

 
 

https://youtu.be/HNZ1MesVXFY 
 

3.4 EVALUASI 
1. Atur lebar kolom di DataGridView, KODESP selebar 75. NAMASP 

selebar 150, ALAMATSP selebar 150 dan TELPONSP selebar 100 
2. Tempatkan data Kode Suplier di tengah kolom 

 

 
 

3.5 REFERENSI 

I Gusti Ngurah Suryantara, (2014), Merancang Aplikasi dengan VB .Net 
2013”, Jakarta : Elex Media Komputindo. 

Uus Rusmawan, (2013), Cara Cepat Belajar VB .Net, Jakarta : Elex 
Media Komputindo. 

Jubilee Enterprise, (2014), Visual Basic 2013 untuk Pemula, Jakarta : 
Elex Media Komputindo. 

WahanaKomputer, ST, (2013), Shortcourse Series : Visual Basic 2012, 
Yogyakarta : Andi Publisher. 
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BAB IV 
FORM TRANSAKSI PEMBELIAN 

 
4.1  CAPAIAN PEMBELAJARAN 

Capaian pembelajaran dari Form Transaksi Pembelian yaitu mahasiswa 
memahami struktur tabel transaki Pembelian, dapat mendesain Form 
Transaksi Pembelian, memahami kode program yang digunakan dan 
cara mengoperasikan Form Transaksi Pembelian yang meliputi 
manambah item Barang pada Faktur Pembelian dan penyimpanan data 
transaksi Pembelian. 

 
4.2  FORM TRANSAKSI PEMBELIAN 

A. MENDESAIN FORM TRANSAKSI PEMBELIAN 
Langkah-langkah mendesain Form Data Barang sebagai berikut : 
1. Buka database DBINV.MDB pada folder 

PRINV\PRINV\BIN\DEBUG 
2. Buat struktur tabel berikut : 

 

 
 

3. Simpan tabel dengan nama BELI 
4. Buat struktur tabel berikut : 

 

 
 

5. Simpan tabel dengan nama DETAILBELI 
6. Buat struktur tabel berikut : 

 

 
 

7. Simpan tabel dengan nama DETAILBELISEMU 
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8. Buat Desain Query berikut 
 

 
 

9. Simpan Query dengan nama QUERYBELI 
10. Tutup program MS Access 
11. Double klik file PRINV.SLN untuk membuka project Inventory 
12. Klik menu Project  ⇒ Add Windows Form untuk menambahkan 

form baru 
13. Ketik nama form FORMBELI 
14. Klik tombol Add 
15. Buat desain Form Transaksi Pembelian berikut 

 

 
 

Gambar 4.1 Desain Form Transaksi Pembelian 
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Daftar Objek pada Form Transaksi Pembelian 

 

Komponen Properties Isi 

Label 

Text FORM TRANSAKSI PEMBELIAN 
Text NOMOR FAKTUR 
Text TANGGAL 
Text KODE SUPLIER 
Text NAMA SUPLIER 

TextBox 
Name TXTFAKTUR 
Name TXTNAMASP 

DateTimePicker Name TXTTANGGAL 
ComboBox Name TXTKODESP 

Button 

Name BTTAMBAH 
Text TAMBAH 
Name BTSIMPAN 
Text SIMPAN 
Name BTBLANKFORM 
Text BLANKFORM 
Name BTCLOSE 
Text CLOSE 

ComboBox Name TXTKODEBRG 

TextBox 

Name TXTNAMABRG 
Name TXTHRGBELI 
Name TXTJUMLAH 
Name TXTTOTAL 

DataGridView 
Name DGVDETAILBELI 
Name DGVBELI 

 
B. KODE PROGRAM FORM TRANSAKSI PEMBELIAN 

Klik menu View => Code lalu ketik kode program berikut : 
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Perintah Public untuk membuat variabel Publik supaya variabel 
tersebut dikenal oleh semua sub program. Variabel 
KONEKSISTRING berisi string untuk koneksi ke database, variabel 
KONEKSI untuk membuat koneksi ke database, variabel SQLSTR 
untuk perintah Query, variabel CMD untuk menjalankan perintah 
Query, variabel DADETAILBELI dan DTDETAILBELI untuk   
menampilkan data detail Pembelian perfaktur, variabel 
DAQUERYBELI dan DTQUERYBELI untuk menampilkan seluruh 
data transaksi Pembelian. Variabel DR untuk membaca data tabel. 
 

 
Saat form dijalankan akan dilakukan koneksi ke database 
DBINV.MDB dan membuka koneksi. Combobox TXTKODESP diisi 
dengan data Kode Suplier dan Nama Suplier dari tabel tabel Suplier, 
combobox TXTKODEBRG diisi dengan data Kode Barang dan 
Nama Barang dari tabel Barang. 
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Sub KOSONG untuk mengosongkan Textbox input data Nomor 
Faktur, Kode Suplier, Nama Suplier, Kode Barang, Nama Barang, 
Harga Beli, Jumlah, Total dan mengosongkan data pada tabel 
DETAILBELISEMU yang digunakan untuk menyimpan sementara 
data Pembelian perFaktur. 
 

 
Sub DGV untuk menampilkan data pada tabel DetailBeliSemu ke 
Datagridview DgvDetailBeli, Sub DGVBL untuk menampilkan data 
pada query QueryBeli ke Datagridview DgvBeli. Saat forn aktif akan 
menjalankan sub Kosong, Dgv dan DgvBeli. 
 

 
Cari Kode Suplier yang diklik pada tabel Suplier dan tampilkan data 
Nama Suplier yang sesuai pada TextBox TXTNAMASP. 
 

 
Cari Kode Barang yang diklik pada tabel Barang dan tampilkan data 
Nama Barang pada TextBox TXTNAMABRG dan Harga Beli pada 
TextBox TXTHRGBELI. 
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Saat diisikan data Jumlah Beli maka pada TextBox TXTTOTAL 
otomatis akan terisi data Harga Beli dikalikan Jumlah. 
 

 
Setelah diklik tombol Tambah maka data Kode Barang, Nama 
Barang, Harga Beli, Jumlah dan Total akan ditambahkan ke tabel 
DetailBeliSemu dan TextBox input data akan dikosongkan untuk 
item barang berikutnya. 
 

 
Setelah diklik tombol Simpan, tambahkan data Nomor Faktur, 
Tanggal Pembelian dan Kode Suplier ke tabel Beli. Tambahkan data 
Kode Barang, Harga Beli dan Jumlah pada tabel DetailBeliSemu ke 
tabel DetailBeli. Update data Faktur yang masih kosong pada tabel 
DetailBeli dengan data Faktur pada TextBox TXTFAKTUR. 
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Saat diklik tombol CLOSE akan menutup koneksi database dan 
menutup form. 
 

C. MENGOPERASIKAN FORM PEMBELIAN 
Cara mengisi data transaksi Pembelian : 
a. Isikan data Nomor Faktur 
b. Isikan data Tanggal Pembelian 
c. Klik droplist pada Kode Suplier 
d. Klik salah satu Kode Suplier, Nama Suplier otomatis akan tampil 
e. Klik droplist pada Kode Barang 
f. Klik salah satu Kode Barang, Nama Barang dan Harga Barang 

otomatis akan tampil 
g. Isikan data Jumlah, data Total otomatis tampil 
h. Klik tombol Tambah untuk menambahkan item data Barang ke 

DetailBeliSemu 
i. Ulangi langkah e s/ h untuk menambah item Barang, satu Nomor 

Faktur bisa berisi beberapa item Barang 
j. Klik tombol Simpan untuk menyimpan Faktur Pembelian ke 

tabel Beli 
 

4.3 TUTORIAL FORM PEMBELIAN 
 

 
 

https://youtu.be/9toA49qxp5Q 
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4.4 EVALUASI 

Tambahkan tombol HAPUS untuk menghapus item Barang yang telah 
ditambahkan di DataGridView DetailBeliSemu 

 

 
4.5 REFERENSI 

I Gusti Ngurah Suryantara, (2014), Merancang Aplikasi dengan VB .Net 
2013”, Jakarta : Elex Media Komputindo. 

Uus Rusmawan, (2013), Cara Cepat Belajar VB .Net, Jakarta : Elex 
Media Komputindo. 

Jubilee Enterprise, (2014), Visual Basic 2013 untuk Pemula, Jakarta : 
Elex Media Komputindo. 

WahanaKomputer, ST, (2013), Shortcourse Series : Visual Basic 2012, 
Yogyakarta : Andi Publisher. 
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BAB V 
FORM DATA CUSTOMER 

 
5.1  CAPAIAN PEMBELAJARAN 

Capaian pembelajaran dari Form Data Customer yaitu mahasiswa 
memahai struktur tabel Customer, dapat mendesain Form Data 
Customer, memahami kode program yang digunakan dan cara 
mengoperasikan Form Data Customer yang meliputi manambah data 
baru, mengedit data dan menghapus data. 

 
5.2  FORM DATA CUSTOMER 

A. MENDESAIN FORM DATA CUSTOMER 
Langkah-langkah mendesain Form Data Customer sebagai berikut : 
1. Buka database DBINV.MDB pada folder 

PRINV\PRINV\BIN\DEBUG 
2. Buat struktur tabel berikut : 

 

 
 

3. Simpan tabel dengan nama CUSTOMER 
4. Tutup program MS Access 
5. Double klik file PRINV.SLN untuk membuka project Inventory 
6. Klik menu Project  ⇒ Add Windows Form  
7. Ketik nama form FORMCUSTOMER 
8. Klik tombol Add, Buat desain Form Customer berikut 

 

 
 

Gambar 5.1 Desain Form Data Customer 
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Daftar Objek pada Form Data Customer 

 

Komponen Properties Isi 

Label 

Text FORM DATA CUSTOMER 
Text KODE CUSTOMER 
Text NAMA CUSTOMER 
Text ALAMAT 
Text NOMORTELPON 

TextBox 

Name TXTKODECS 
Name TXTNAMACS 
Name TXTALAMATCS 
Name TXTTELPONCS 

Button 

Name BTSIMPAN 
Text SIMPAN 
Name BTHAPUS 
Text HAPUS 
Name BTBLANKFORM 
Text BLANKFORM 
Name BTCLOSE 
Text CLOSE 

DataGridView Name DGVCS 
 
B. KODE PROGRAM FORM DATA CUSTOMER 

Langkah berikutnya klik menu View => Code lalu ketik kode 
program berikut : 
 

 
Perintah Public untuk membuat variabel Publik supaya variabel 
tersebut dikenal oleh semua sub program. Variabel 
KONEKSISTRING berisi string untuk koneksi ke database, variabel 
KONEKSI untuk membuat koneksi ke database, variabel SQLSTR 
untuk perintah Query, variabel CMD untuk menjalankan perintah 
Query, variabel DACS untuk penghubung data tabel, variabel DTCS 
menyimpan data hasil perintah query. 
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Saat form dijalankan akan dilakukan koneksi ke database 
DBINV.MDB dan membuka koneksi. 
 

 
Sub KOSONG untuk mengosongkan Textbox input data Customer, 
sub DGV untuk menampilkan data Customer ke DatagridView 
DGVCS. Saat form aktif akan menjalankan sub KOSONG dan sub 
DGV. 
 

 
Saat kursor meninggalkan Textbox TXTKODECS akan dideteksi 
apakah Kode Customer yang telah diketik sudah ada di tabel 
Customer, jika Kode Customer sudah ada maka datanya akan 
ditampilkan ke masing-masing Textbox. 
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Saat diklik tombol SIMPAN akan dideteksi apakah Kode Customer 
yang akan disimpan sudah ada di tabel Customer, jika Kode 
Customer sudah ada maka data Customer akan diupdate sedangkan 
jika belum ada maka data Customer yang diinput akan ditambahkan 
sebagai data baru. 
 

 
Saat diklik tombol HAPUS akan ditampilkan konfirmasi apakah data 
Customer yang sedang tampil akan dihapus, jika diklik tombol Yes 
maka data Customer yang sedang tampil akan dihapus sedangkan jika 
diklik tombol No data Customer tidak akan dihapus. 
 

 
Saat diklik tombol BLANKFORM akan menjalankan sub KOSONG 
untuk mengosongkan Textbox. 
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Saat diklik tombol CLOSE akan menutup koneksi database dan 
menutup form. 
 

C. MENGOPERASIKAN FORM DATA CUSTOMER 
1. Menambah data Customer 

Cara menambahkan data Suplier : 
a. Klik menu Debug => Start Debugging 
b. Isikan data Kode Customer, Nama Customer, Alamat 

Customer dan Nomor Telpon Customer 
c. Klik tombol SIMPAN untuk menyimpan data Customer 
Tekan tombol Tab untuk memindahkan kursor ke text box 
berikutnya. 
 

2. Mengedit data Customer 
Cara mengedit data Customer : 
a. Klik menu Debug => Start Debugging 
b. Isikan Kode Customer yang datanya mau diedit 
c. Tekan tombol Tab (data Customer yang kodenya sesuai akan 

tampil) 
d. Lakukan pengeditan data 
e. Klik tombol SIMPAN untuk pengeditan data Customer 

 
3. Menghapus data Customer 

Cara menghapus data Customer : 
a. Klik menu Debug => Start Debugging 
b. Isikan Kode Customer yang datanya mau dihapus 
c. Tekan tombol Tab (data Suplier yang kodenya sesuai akan 

tampil) 
d. Klik tombol HAPUS 
e. Tampil konfirmasi data jadi dihapus atau tidak 
f. Klik tombol Yes jika data jadi dihapus atau klik tombol No 

jika data tidak jadi dihapus 
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5.3 TUTORIAL FORM CUSTOMER 
 

 
 

https://youtu.be/YXmm-MZC0u8 
 

 
5.4 EVALUASI 

Buat kode program untuk mendeteksi saat input data Nomor Telpon jika 
diinput data selain angka tampilkan pesan “DATA NOMOR TELPON 
HANYA BISA DIISI ANGKA” 

 
5.5 REFERENSI 

I Gusti Ngurah Suryantara, (2014), Merancang Aplikasi dengan VB .Net 
2013”, Jakarta : Elex Media Komputindo. 

Uus Rusmawan, (2013), Cara Cepat Belajar VB .Net, Jakarta : Elex 
Media Komputindo. 

Jubilee Enterprise, (2014), Visual Basic 2013 untuk Pemula, Jakarta : 
Elex Media Komputindo. 

WahanaKomputer, ST, (2013), Shortcourse Series : Visual Basic 2012, 
Yogyakarta : Andi Publisher. 
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BAB VI 
FORM TRANSAKSI PENJUALAN 

 
6.1  CAPAIAN PEMBELAJARAN 

Capaian pembelajaran dari Form Transaksi Penjualan yaitu mahasiswa 
memahami struktur tabel transaki Penjualan, dapat mendesain Form 
Transaksi Penjualan, memahami kode program yang digunakan dan cara 
mengoperasikan Form Transaksi Penjualan yang meliputi manambah 
item Barang pada Nota Penjualan dan penyimpanan data Penjualan. 

 
6.2  FORM TRANSAKSI PENJUALAN 

A. MENDESAIN FORM TRANSAKSI PENJUALAN 
Langkah-langkah mendesain Form Penjualan sebagai berikut : 
1. Buka database DBINV.MDB pada folder 

PRINV\PRINV\BIN\DEBUG 
2. Buat struktur tabel berikut : 

 

 
 

3. Simpan tabel dengan nama JUAL 
4. Buat struktur tabel berikut : 

 

 
 

5. Simpan tabel dengan nama DETAILJUAL 
6. Buat struktur tabel berikut : 

 

 
 

7. Simpan tabel dengan nama DETAILJUALSEMU 
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8. Buat Desain Query berikut 
 

 
 

9. Simpan Query dengan nama QUERYJUAL 
10. Tutup program MS Access 
11. Double klik file PRINV.SLN untuk membuka project Inventory 
12. Klik menu Project  ⇒ Add Windows Form untuk menambahkan 

form baru 
13. Ketik nama form FORMJUAL 
14. Klik tombol Add 
15. Buat desain Form Transaksi Penjualan berikut 

 

 
 

Gambar 6.1 Desain Form Transaksi Penjualan 
 

Daftar Objek pada Form Transaksi Penjualan 
 

Komponen Properties Isi 

Label 
Text FORM TRANSAKSI 

PENJUALAN 
Text NOMOR NOTA 
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Text TANGGAL 
Text KODE CUSTOMER 
Text NAMA CUSTOMER 

TextBox 
Name TXTNOTA 
Name TXTNAMACS 

DateTimePicker Name TXTTANGGAL 
ComboBox Name TXTKODECS 

Button 

Name BTTAMBAH 
Text TAMBAH 
Name BTSIMPAN 
Text SIMPAN 
Name BTBLANKFORM 
Text BLANKFORM 
Name BTCLOSE 
Text CLOSE 

ComboBox Name TXTKODEBRG 

TextBox 

Name TXTNAMABRG 
Name TXTHRGBELI 
Name TXTJUMLAH 
Name TXTTOTAL 

DataGridView 
Name DGVDETAILJUAL 
Name DGVJUAL 

 
B. KODE PROGRAM FORM TRANSAKSI PENJUALAN 

Langkah berikutnya klik menu View => Code lalu ketik kode 
program berikut : 
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Perintah Public untuk membuat variabel Publik supaya variabel 
tersebut dikenal oleh semua sub program. Variabel KONEKSI berisi 
string untuk koneksi ke database, variabel CONN untuk membuat 
koneksi ke database, variabel SQLSTR untuk perintah Query, 
variabel CMD untuk menjalankan perintah Query, variabel 
DADETAILJUAL dan DTDETAILJUAL untuk   menampilkan data 
detail Penjualan pernota, variabel DAQUERYJUAL dan 
DTQUERYJUAL untuk menampilkan seluruh data transaksi 
Penjualan. Variabel DR untuk membaca data dari suatu tabel. 
 

 
Saat form dijalankan akan dilakukan koneksi ke database 
DBINV.MDB dan membuka koneksi. Combobox TXTKODECS 
diisi dengan data Kode Customer dan Nama Customer dari tabel 
Customer, combobox TXTKODEBRG diisi dengan data Kode 
Barang dan Nama Barang dari tabel Barang. 
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Sub KOSONG untuk mengosongkan Textbox input data Nomor 
Nota, Kode Customer, Nama Customer, Kode Barang, Nama Barang, 
Harga Jual, Jumlah, Total dan mengosongkan data pada tabel 
DETAILJUALSEMU yang digunakan untuk menyimpan sementara 
data Penjualan perNota. 
 

 
Sub DGV untuk menampilkan data pada tabel DetailJualSemu ke 
Datagridview DgvDetailJual, Sub DGVJL untuk menampilkan data 
pada query QueryJual ke Datagridview DgvJual. Saat forn aktif akan 
menjalankan sub Kosong, Dgv dan DgvBeli. 
 

 
Cari Kode Customer yang diklik pada tabel Customer dan tampilkan 
data Nama Customer yang sesuai pada TextBox TXTNAMACS. 
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Cari Kode Barang yang diklik pada tabel Barang dan tampilkan data 
Nama Barang pada TextBox TXTNAMABRG dan Harga Jual pada 
TextBox TXTHRGJUAL. 
 

 
Saat diisikan data Jumlah Jual maka pada TextBox TXTTOTAL 
otomatis akan terisi data Harga Jual dikalikan Jumlah. 
 

 
Setelah diklik tombol Tambah maka data Kode Barang, Nama 
Barang, Harga Jual, Jumlah dan Total akan ditambahkan ke tabel 
DetailJualSemu dan TextBox input data akan dikosongkan untuk 
item barang berikutnya. 
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Setelah diklik tombol Simpan, tambahkan data Nomor Nota, Tanggal 
Penjualan dan Kode Customer ke tabel Jual. Tambahkan data Kode 
Barang, Harga Jual dan Jumlah pada tabel DetailJualSemu ke tabel 
DetailJual. Update data Nota yang masih kosong pada tabel 
DetailJual dengan data Nota pada TextBox TXTNOTA. 
 

 
Saat diklik tombol CLOSE akan menutup koneksi database dan 
menutup form. 
 

C. MENGOPERASIKAN FORM PENJUALAN 
Cara mengisi data transaksi Penjualan : 
a. Isikan data Nomor Nota 
b. Isikan data Tanggal Penjualan 
c. Klik droplist pada Kode Customer 
d. Klik salah satu Kode Customer, Nama Customer otomatis akan 

tampil 
e. Klik droplist pada Kode Barang 
f. Klik salah satu Kode Barang, Nama Barang dan Harga Barang 

otomatis akan tampil 
g. Isikan data Jumlah, data Total otomatis tampil 
h. Klik tombol Tambah untuk menambahkan item data Barang  
i. Ulangi langkah e s/d h untuk menambah item Barang 
j. Klik tombol Simpan untuk menyimpan data Nota Penjualan ke 

tabel Jual 



41 

 

6.5 TUTORIAL FORM PENJUALAN 
 

 
https://youtu.be/szwC0-Lsw6s 

 
6.6 EVALUASI 

Buat kode program untuk menghitung Total Penjualan PerNota. 

 

 
6.7 REFERENSI 

I Gusti Ngurah Suryantara, (2014), Merancang Aplikasi dengan VB .Net 
2013”, Jakarta : Elex Media Komputindo. 

Uus Rusmawan, (2013), Cara Cepat Belajar VB .Net, Jakarta : Elex 
Media Komputindo. 

Jubilee Enterprise, (2014), Visual Basic 2013 untuk Pemula, Jakarta : 
Elex Media Komputindo. 

WahanaKomputer, ST, (2013), Shortcourse Series : Visual Basic 2012, 
Yogyakarta : Andi Publisher. 
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BAB VII 
FORM MENU UTAMA 

 
7.1  CAPAIAN PEMBELAJARAN 

Capaian pembelajaran dari Form Menu Utama yaitu mahasiswa bisa 
membuat Form Menu untuk menjalankan Form Barang, Form  Suplier, 
Form Pembelian, Form Customer dan Form Penjualan dari satu form 
yaitu Form Menu Utama. 
 

7.2  FORM MENU UTAMA 
A. MENDESAIN FORM MENU UTAMA 

Langkah-langkah mendesain Form Penjualan sebagai berikut : 
1. Double klik file PRINV.SLN untuk membuka project Inventory 
2. Klik menu Project  ⇒ Add Windows Form untuk menambahkan 

form baru 
3. Ketik nama form MENUUTAMA 
4. Klik tombol Add 
5. Klik komponen MenuStrip pada ToolBox 
6. Klik area kosong pada form 
7. Buat desain Form Menu berikut 

 

 
 

Gambar 7.1 Desain Form Menu Utama 
 

B. KODE PROGRAM FORM MENU 
Langkah berikutnya klik menu View => Code lalu ketik kode 
program berikut : 
 



43 

 

 
Perintah FORMBARANG.ShowDialog() untuk menampilkan Form 
Barang saat diklik menu Master => Data Barang, 
FORMSUPLIER.ShowDialog() untuk menampilkan Form Suplier 
saat diklik menu Master => Data Suplier, FORMBELI.ShowDialog() 
untuk menampilkan Form Beli saat diklik menu Transaksi => 
Transaksi Pembelian, FORMCUSTOMER.ShowDialog() untuk 
menampilkan Form Customer saat diklik menu Master => Data 
Customer, FORMJUAL.ShowDialog() untuk menampilkan Form 
Jual saat diklik menu Transaksi => Transaksi Penjualan, Close() 
untuk menutup Form saat diklik menu Selesai => Keluar Dari 
Program. 
 

C. MENGOPERASIKAN FORM MENU 
Cara mengoperasikan Form Menu : 
a. Klik menu Project => PRINV Properties 
b. Klik Droplist pada Startup Form 
c. Klik MENUUTAMA 
d. Klik menu Debug => Start Debugging 
e. Klik menu Master => Data Barang akan tampil Form Barang 
f. Pada Form Barang klik tombol Close untuk kembali ke Form 

Menu 
g. Klik menu Master => Data Suplier akan tampil Form Suplier 
h. Pada Form Suplier klik tombol Close untuk kembali ke Form 

Menu 
i. Klik menu Master => Data Customer akan tampil Form 

Customer 
j. Pada Form Customer klik tombol Close untuk ke Form Menu 
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k. Klik menu Transaksi => Transaksi Pembelian untuk 
menampilkan Form Beli 

l. Pada Form Beli klik tombol Close untuk kembali ke Form Menu 
m. Klik menu Transaksi => Transaksi Penjualan untuk 

menampilkan Form Jual 
n. Pada Form Jual klik tombol Close untuk kembali ke Form Menu 
o. Klik menu Selesai => Keluar Dari Program untuk keluar 

 
7.3 TUTORIAL FORM MENU UTAMA 

 

 
 

https://youtu.be/ZBfzEXIA-eo 
 

7.4 EVALUASI 
Buat kode program pada Form Barang untuk menghitung Jumlah Beli 
sesuai dengan total jumlah masing-masing Barang dari transaksi 
Pembelian, Jumlah Jual sesuai dengan total jumlah masing-masing 
Barang dari transaksi Penjualan dan Jumlah Stok dengan Jumlah Awal 
ditambah Jumlah Beli dikurangi Jumlah Jual.  

 
7.5 REFERENSI 

I Gusti Ngurah Suryantara, (2014), Merancang Aplikasi dengan VB .Net 
2013”, Jakarta : Elex Media Komputindo. 

Uus Rusmawan, (2013), Cara Cepat Belajar VB .Net, Jakarta : Elex 
Media Komputindo. 

Jubilee Enterprise, (2014), Visual Basic 2013 untuk Pemula, Jakarta : 
Elex Media Komputindo. 

WahanaKomputer, ST, (2013), Shortcourse Series : Visual Basic 2012, 
Yogyakarta : Andi Publisher. 
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BAB VIII 
MENCETAK DATA MASTER 

 
8.1  CAPAIAN PEMBELAJARAN 

Capaian pembelajaran dari Mencetak Data Master yaitu mahasiswa bisa 
memahami kode program untuk mendesain dan mencetak data Barang, 
data Suplier dan data Customer menggunakan komponen 
PrintDocument. 
 

8.2  MENCETAK DATA BARANG 
Langkah-langkah mencetak data Barang sebagai berikut : 
a. Double klik file PRINV.SLN untuk membuka project Inventory 
b. Double klik form MENUUTAMA 
c. Klik komponen PrintDocument pada ToolBox 
d. Klik area kosong pada form 
e. Klik propertie Name 
f. Ketik PDBARANG 
g. Ulangi langkah c s/d f untuk menambahkan objek PrintDocument 

dengan nama PDSUPLIER dan PDCUSTOMER 
h. Klik menu View => Code 
i. Ketik kode program berikut 

 

 
Variabel BARIS untuk menentukan nilai baris data, variabel 
NOMOR untuk Nomor Urut data, variabel FONTJUDUL untuk 
menentukan ukuran font judul lapotan, variabel FONTDATA untuk 
menentukan ukuran font data, variabel KIRI untuk perataan kiri, 
variabel TENGAH untuk perataan tengah dan variabel KANAN 
untuk perataan kanan. 
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Saat form dijalankan akan dilakukan koneksi ke database 
DBINV.MDB dan membuka koneksi 
 

 



47 

 

Perintah e.Graphics.DrawString("LAPORAN DATA BARANG", 
FONTJUDUL, Brushes.Blue, 450, 25, TENGAH) untuk mencetak 
string LAPORAN DATA BARANG menggunakan jenis FontJudul, 
warna Biru, kolom 450, baris 25, perataan Tengah. Perintah 
e.Graphics.DrawLine(Pens.Black, 30, 70, 805, 70) untuk mencetak 
garis mendatar warna Hitam, mulai Kolom 30 Baris 70 sampai 
Kolom 805 Baris 70. Variabel BARIS untuk menentukan awal Baris 
data pertama, variabel NOMOR untuk awal Nomor data pertama. 
Sebelum mencetak data berikutnya, nilai variabel BARIS akan 
bertambah 20 dan nilai variabel NOMOR bertambah 1. 
 

 
Perintah PDBARANG.Print untuk mencetak data yang telah didesain 
pada Private Sub PDBARANG_PrintPage. 
 

j. Klik menu Debug => Start Debugging 
k. Klik menu Cetak => Cetak Barang 

 

 

 
8.3  MENCETAK DATA SUPLIER 

Langkah-langkah mencetak data Suplier sebagai berikut : 
a. Double klik form MENUUTAMA 
b. Klik menu View => Code, ketik kode program berikut 
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Perintah e.Graphics.DrawString("LAPORAN DATA SUPLIER", 
FONTJUDUL, Brushes.Blue, 400, 25, TENGAH) untuk mencetak 
string LAPORAN DATA SUPLIER menggunakan jenis FontJudul, 
warna Biru, kolom 400, baris 25, perataan Tengah. Perintah 
e.Graphics.DrawLine(Pens.Black, 30, 70, 805, 70) untuk mencetak 
garis mendatar warna Hitam, mulai Kolom 30 Baris 70 sampai 
Kolom 805 Baris 70. Variabel BARIS untuk menentukan awal Baris 
data pertama, variabel NOMOR untuk awal Nomor data pertama. 
Sebelum mencetak data berikutnya, nilai variabel BARIS akan 
bertambah 20 dan nilai variabel NOMOR bertambah 1. 
 

 
Perintah PDSUPLIER.Print untuk mencetak data yang telah didesain 
pada Private Sub PDSUPLIER_PrintPage. 
 

c. Klik menu Debug => Start Debugging 
d. Klik menu Cetak => Cetak Suplier 
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8.4  MENCETAK DATA CUSTOMER 
Langkah-langkah mencetak data Suplier sebagai berikut : 
a. Double klik form MENUUTAMA 
b. Klik menu View => Code 
c. Ketik kode program berikut 

 

 
Perintah e.Graphics.DrawString("LAPORAN DATA CUSTOMER", 
FONTJUDUL, Brushes.Blue, 400, 25, TENGAH) untuk mencetak 
string LAPORAN DATA CUSTOMER menggunakan jenis 
FontJudul, warna Biru, kolom 400, baris 25, perataan Tengah. 
Perintah e.Graphics.DrawLine(Pens.Black, 30, 70, 805, 70) untuk 
mencetak garis mendatar warna Hitam, mulai Kolom 30 Baris 70 
sampai Kolom 805 Baris 70. Variabel BARIS untuk menentukan 
awal Baris data pertama, variabel NOMOR untuk awal Nomor data 
pertama. Sebelum mencetak data berikutnya, nilai variabel BARIS 
akan bertambah 20 dan nilai variabel NOMOR bertambah 1. 
 

 
Perintah PDCUSTOMER.Print untuk mencetak data yang telah 
didesain di Private Sub PDCUSTOMER_PrintPage. 
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d. Klik menu Debug => Start Debugging 
e. Klik menu Cetak => Cetak Customer 

 

 

 
8.5  TUTORIAL MENCETAK DATA MASTER 
 

 
 

https://youtu.be/sOObSQnq1lo 
 

8.6  EVALUASI 
Buat Kode program untuk menccetak Total Jumlah Awal, Jumlah Beli, 
Jumlah Jual dan Jumlah Stok pada Laporan Data Barang. 
 

8.7 REFERENSI 
I Gusti Ngurah Suryantara, (2014), Merancang Aplikasi dengan VB .Net 

2013”, Jakarta : Elex Media Komputindo. 
Uus Rusmawan, (2013), Cara Cepat Belajar VB .Net, Jakarta : Elex 

Media Komputindo. 
Jubilee Enterprise, (2014), Visual Basic 2013 untuk Pemula, Jakarta : 

Elex Media Komputindo. 
WahanaKomputer, ST, (2013), Shortcourse Series : Visual Basic 2012, 

Yogyakarta : Andi Publisher. 
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BAB IX 
MENCETAK PEMBELIAN PERFAKTUR 

 
9.1  CAPAIAN PEMBELAJARAN 

Capaian pembelajaran Mencetak Pembelian PerFaktur yaitu 
mahasiswa dapat mendesain form untuk memfilter data Pembelian 
PerFaktur dan memahami kode program untuk mencetak data 
Pembelian PerFaktur. 

 
9.2  FORM PEMBELIAN PERFAKTUR 

  A. MENDESAIN FORM PEMBELIAN PERFAKTUR 
Langkah-langkah mendesain Form Pembelian PerFaktur sebagai 
berikut : 
1. Double klik file PRINV.SLN untuk membuka project Inventory 
2. Klik menu Project  ⇒ Add Windows Form  
3. Ketik nama form FORMCETAKBELIPERFAKTUR 
4. Klik tombol Add 
5. Buat desain Form Pembelian PerFaktur berikut 

 
 

 
 

Gambar 9.1 Desain Form Pembelian PerFaktur 
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Daftar Objek pada Form Pembelian PerFaktur 
 

Komponen Properties Isi 

Label 

Text FORM CETAK 
PEMBELIAN PERFAKTUR 

Text NO. FAKTUR 
Text TANGGAL 
Text KODE SUPLIER 
Text NAMA SUPLIER 

ComboBox Name TXTFAKTUR 

TextBox 
Name TXTTANGGAL 
Name TXTKODESP 
Name TXTNAMASP 

Button 

Name BTPREVIEW 
Text PREVIEW 
Name BTCLOSE 
Text CLOSE 

DataGridView Name DGVBELI 
PrintDocument Name PDBELI 

 
B. KODE PROGRAM FORM PEMBELIAN PERFAKTUR 

Langkah berikutnya klik menu View => Code lalu ketik kode 
program berikut : 
 

 
Perintah Public untuk membuat variabel Publik supaya variabel 
tersebut dikenal oleh semua sub program. Variabel 
KONEKSISTRING berisi string untuk koneksi ke database, variabel 
KONEKSI untuk membuat koneksi ke database, variabel SQLSTR 
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untuk perintah Query, variabel CMD untuk menjalankan perintah 
Query, variabel DA untuk   menampilkan data Pembelian PerFaktur, 
Variabel DR untuk membaca data dari suatu tabel. Variabel BARIS 
untuk menentukan nilai baris data, variabel NOMOR untuk Nomor 
Urut data, variabel FONTJUDUL untuk menentukan ukuran font 
judul lapotan, variabel FONTDATA untuk menentukan ukuran font 
data, variabel KIRI untuk perataan kiri, variabel TENGAH untuk 
perataan tengah dan variabel KANAN untuk perataan kanan. 
 

 
Membuat koneksi ke database DBINV,MDB dan membuka koneksi 
database. Mengisi data pada ComboBox TXTFAKTUR dengan data 
Nomor Faktur dari tabel BELI 
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Sub KOSONG untuk mengosongkan ComboBox, TextBox dan 
menghapus semua data pada tabel DETAILBELISEMU. Sub DGV 
untuk menampilkan data pada tabel DETAILBELISEMU ke 
DataGridView DGVBELI. Saat form aktif akan menjalankan Sub 
KOSONG dan Sub DGV. 
 

 
Saat diklik Nomor Faktur akan dicari Nomor Faktur yang diklik pada 
query QUERYBELI lalu ditampilkan data Tanggal Pembelian, Kode 
Suplier dan Nama Suplier. Berikutnya akan dihapus semua data pada 
tabel DETAILBELISEMU dan data pada QUERYBELI yang Nomor 
Fakturnya sesuai akan ditambahkan ke tabel DETAILBELISEMU. 
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Mendesain judul laporan yang terdiri dari Nomor Faktur, Tanggal, 
Kode Suplier dan Nama Suplier. Perintah 
e.Graphics.DrawLine(Pens.Black, 30, 110, 600, 110) untuk mencetak 
garis mendatar, berikutnya mencetak judul kolom yang terdiri dari 
Nomor, Kodebrg, Nama Barang, Harga Beli, Jumlah dan Total. 
 

 
Mencetak data pada tabel DETAILBELISEMU yang terdiri dari 
Nomor, Kode Barang, Nama Barang, Harga Beli, Jumlah dan Total. 
Variabel TOTAL untuk menghitung Total Pembelian PerFaktur. 
 

 
Saat diklik tombol PREVIEW akan mencetak data Pembelian 
PerFaktur yang sudah didesain. 
 

 
Saat diklik tombol CLOSE akan menutup koneksi database dan 
menutup form. 
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C. MENCETAK PEMBELIAN PERFAKTUR 
Cara mencetak data Pembelian PerFaktur : 
a. Klik droplist pada Nomor Faktur 
b. Klik Nomor Faktur yang datanya mau dicetak, data item barang 

akan tampil di DataGridView 
c. Klik tombol PREVIEW 
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9.3 TUTORIAL PEMBELIAN PERFAKTUR 
 

 
 

https://youtu.be/6-cYdgj8l30 
 

9.4 EVALUASI 

Tambahkan garis pembatas data pada laporan Pembelian PerFaktur. 
 

 
 
9.5 REFERENSI 

I Gusti Ngurah Suryantara, (2014), Merancang Aplikasi dengan VB .Net 
2013”, Jakarta : Elex Media Komputindo. 

Uus Rusmawan, (2013), Cara Cepat Belajar VB .Net, Jakarta : Elex 
Media Komputindo. 

Jubilee Enterprise, (2014), Visual Basic 2013 untuk Pemula, Jakarta : 
Elex Media Komputindo. 

WahanaKomputer, ST, (2013), Shortcourse Series : Visual Basic 2012, 
Yogyakarta : Andi Publisher. 
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BAB X 
MENCETAK PEMBELIAN PERPERIODE 

 
10.1  CAPAIAN PEMBELAJARAN 

Capaian pembelajaran Mencetak Pembelian PerPeriode yaitu 
mahasiswa dapat mendesain form untuk memfilter data Pembelian 
PerPeriode dan memahami kode program untuk mencetak data 
Pembelian PePeriode. 

 
10.2  FORM PEMBELIAN PERPERIODE 

  A. DESAIN FORM PEMBELIAN PERPERIODE 
Langkah-langkah mendesain Form Pembelian PerPeriode sebagai 
berikut : 
1. Double klik file PRINV.SLN untuk membuka project Inventory 
2. Klik menu Project  ⇒ Add Windows Form  
3. Ketik nama form FORMCETAKBELIPERPERIODE 
4. Klik tombol Add 
5. Buat desain Form Pembelian PerPeriode berikut 

 

 
 

Gambar 10.1 Desain Form Pembelian PerPeriode 
 

Daftar Objek pada Form Pembelian PerPeriode 
 

Komponen Properties Isi 

Label 

Text FORM CETAK PEMBELIAN 
PERPERIODE 

Text MULAI TANGGAL 
Text SAMPAI TANGGAL 
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ComboBox 
Name TXTMULAI 
Name TXTSAMPAI 

Button 

Name BTPREVIEW 
Text PREVIEW 
Name BTCLOSE 
Text CLOSE 

DataGridView Name DGVBELI 
PrintDocument Name PDBELI 

 
B. KODE PROGRAM FORM PEMBELIAN PERPERIODE 

Klik menu View => Code lalu ketik kode program berikut : 
 

 
Perintah Public untuk membuat variabel Publik supaya variabel 
tersebut dikenal oleh semua sub program. Variabel 
KONEKSISTRING berisi string untuk koneksi ke database, variabel 
KONEKSI untuk membuat koneksi ke database, variabel SQLSTR 
untuk perintah Query, variabel CMD untuk menjalankan perintah 
Query, variabel DA untuk   menampilkan data Pembelian PerFaktur, 
Variabel DR untuk membaca data dari suatu tabel. Variabel BARIS 
untuk menentukan nilai baris data, variabel NOMOR untuk Nomor 
Urut data, variabel FONTJUDUL untuk menentukan ukuran font 
judul lapotan, variabel FONTDATA untuk menentukan ukuran font 
data, variabel KIRI untuk perataan kiri, variabel TENGAH untuk 
perataan tengah dan variabel KANAN untuk perataan kanan, variabel 
XMULAI untuk tanggal awal periode, variabel XSAMPAI untuk 
tanggal akhir periode. 
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Membuat koneksi ke database DBINV,MDB dan membuka koneksi 
database. Mengisi data pada ComboBox TXTMULAI dan 
TXTSAMPAI dengan data Tanggal Pembelian dari tabel BELI 
 

 
Sub KOSONG untuk mengosongkan ComboBox TXTMULAI dan 
TXTSAMPAI. Sub DGV untuk menampilkan data pada query 
QUERYBELI ke DataGridView DGVBELI. Saat form aktif akan 
menjalankan Sub KOSONG dan Sub DGV. 
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Saat diklik Tanggal Mulai, jika data pada ComboBox TXTSAMPAI 
tidak kosong maka data Pembelian sesuai dengan periode yang telah 
ditentukan akan tampil di DataGridView DGVBELI.  
 

 
Saat diklik Tanggal Sampai, jika data pada ComboBox TXTMULAI 
tidak kosong maka data Pembelian sesuai dengan periode yang telah 
ditentukan akan tampil di DataGridView DGVBELI. 
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Mendesain judul laporan Tanggal Periode data Pembelian dan judul 
kolom yang terdiri dari Nomor, Nomor Faktur, Tanggal, Nama 
Suplier, Kode Barang, Nama Barang, Harga Beli, Jumlah dan Total. 
 

 
Mencetak data Pembelian sesuai dengan Periode yang ditentukan 
terdiri dari Nomor, Nomor Faktur, Tanggal, Nama Suplier, Kode 
Barang, Nama Barang, Harga Beli, Jumlah dan Total. Variabel 
TOTAL untuk menghitung Total Pembelian PerPeriode. 
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Saat diklik tombol PREVIEW akan mencetak data Pembelian 
PerPeriode yang sudah didesain. 
 

 
Saat diklik tombol CLOSE akan menutup koneksi database dan 
menutup form. 
 

C. MENCETAK PEMBELIAN PERPERIODE 
Cara mencetak data Pembelian PerPeriode : 
a. Klik droplist pada Mulai Tanggal, klik Tanggal Mulai Periode 
b. Klik droplist pada Sampai Tanggal, klik Tanggal Akhir Periode, 

data item barang akan tampil di DataGridView 
c. Klik tombol PREVIEW 
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10.3 TUTORIAL PEMBELIAN PERPERIODE 
 

 
 

https://youtu.be/iMW0AhYLWpg 
 

 
10.4 EVALUASI 

Tambahkan Logo (gambar bebas) pada laporan Pembelian PerPeriode. 
 

 
 

10.5 REFERENSI 
I Gusti Ngurah Suryantara, (2014), Merancang Aplikasi dengan VB .Net 

2013”, Jakarta : Elex Media Komputindo. 
Uus Rusmawan, (2013), Cara Cepat Belajar VB .Net, Jakarta : Elex 

Media Komputindo. 
Jubilee Enterprise, (2014), Visual Basic 2013 untuk Pemula, Jakarta : 

Elex Media Komputindo. 
WahanaKomputer, ST, (2013), Shortcourse Series : Visual Basic 2012, 

Yogyakarta : Andi Publisher. 
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BAB XI 
MENCETAK PENJUALAN PERNOTA 

 
11.1  CAPAIAN PEMBELAJARAN 

Capaian pembelajaran Mencetak Penjualan PerNota yaitu mahasiswa 
dapat mendesain form untuk memfilter data Penjualan PerNota dan 
memahami kode program untuk mencetak data Penjualan PerNota. 

 
11.2  FORM PENJUALAN PERNOTA 

  A. MENDESAIN FORM PENJUALAN PERNOTA 
Langkah-langkah mendesain Form Penjualan PerNota sebagai 
berikut : 
1. Double klik file PRINV.SLN untuk membuka project Inventory 
2. Klik menu Project  ⇒ Add Windows Form  
3. Ketik nama form FORMCETAKJUALPERNOTA 
4. Klik tombol Add 
5. Buat desain Form Penjualan PerNota berikut 

 

 
 

Gambar 11.1 Desain Form Penjualan PerNota 
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Daftar Objek pada Form Penjualan PerNota 
 

Komponen Properties Isi 

Label 

Text FORM CETAK 
PEMNJUALAN PERNOTA 

Text NO. NOTA 
Text TANGGAL 
Text KODE CUSTOMER 
Text NAMA CUSTOMER 

ComboBox Name TXTNOTA 

TextBox 
Name TXTTANGGAL 
Name TXTKODECS 
Name TXTNAMACS 

Button 

Name BTPREVIEW 
Text PREVIEW 
Name BTCLOSE 
Text CLOSE 

DataGridView Name DGVJUAL 
PrintDocument Name PDJUAL 

 
B. KODE PROGRAM FORM PENJUALAN PERNOTA 

Langkah berikutnya klik menu View => Code lalu ketik kode 
program berikut : 
 

 
Perintah Public untuk membuat variabel Publik supaya variabel 
tersebut dikenal oleh semua sub program. Variabel 
KONEKSISTRING berisi string untuk koneksi ke database, variabel 
KONEKSI untuk membuat koneksi ke database, variabel SQLSTR 
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untuk perintah Query, variabel CMD untuk menjalankan perintah 
Query, variabel DA untuk   menampilkan data Pembelian PerFaktur, 
Variabel DR untuk membaca data dari suatu tabel. Variabel BARIS 
untuk menentukan nilai baris data, variabel NOMOR untuk Nomor 
Urut data, variabel FONTJUDUL untuk menentukan ukuran font 
judul lapotan, variabel FONTDATA untuk menentukan ukuran font 
data, variabel KIRI untuk perataan kiri, variabel TENGAH untuk 
perataan tengah dan variabel KANAN untuk perataan kanan. 
 

 
Membuat koneksi ke database DBINV,MDB dan membuka koneksi 
database. Mengisi data pada ComboBox TXTNOTA dengan data 
Nomor Nota dari tabel JUAL 
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Sub KOSONG untuk mengosongkan ComboBox, TextBox dan 
menghapus semua data pada tabel DETAILJUALSEMU. Sub DGV 
untuk menampilkan data pada tabel DETAILJUALSEMU ke 
DataGridView DGVJUAL. Saat form aktif akan menjalankan Sub 
KOSONG dan Sub DGV. 
 

 
Saat diklik Nomor Nota akan dicari Nomor Nota yang diklik pada 
query QUERYJUAL lalu ditampilkan data Tanggal Penjualan, Kode 
Customer dan Nama Customer. Berikutnya akan dihapus semua data 
pada tabel DETAILJUALSEMU dan data pada QUERYJUAL yang 
Nomor Notanya sesuai akan ditambahkan ke tabel 
DETAILJUALSEMU. 
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Mendesain judul laporan yang terdiri dari Nomor Nota, Tanggal, 
Kode Customer dan Nama Customer. Perintah 
e.Graphics.DrawLine(Pens.Black, 30, 110, 600, 110) untuk mencetak 
garis mendatar, berikutnya mencetak judul kolom yang terdiri dari 
Nomor, Kode Barang, Nama Barang, Harga Jual, Jumlah dan Total. 
 

 
Mencetak data pada tabel DETAILJUALSEMU yang terdiri dari 
Nomor, Kode Barang, Nama Barang, Harga Jual, Jumlah dan Total. 
Variabel TOTAL untuk menghitung Total Penjualan PerFaktur. 
 

 
Saat diklik tombol PREVIEW akan mencetak data Penjualan PerNota 
yang sudah didesain. 
 

 
Saat diklik tombol CLOSE akan menutup koneksi database dan 
menutup form. 
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C. MENCETAK PENJUALAN PERNOTA 
Cara mencetak data Penjualan PerNota : 
a. Klik droplist pada Nomor Nota 
b. Klik Nomor Nota yang datanya mau dicetak, data item barang 

akan tampil di DataGridView 
c. Klik tombol PREVIEW 
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11.3 TUTORIAL MENCETAK PENJUALAN PERNOTA 
 

 
 

https://youtu.be/C_-ClDEyBx4 
 
11.4 EVALUASI 

Cetak Tebal data Total Penjualan pada laporan Penjualan PerNota. 
 

 
 

11.5 REFERENSI 
I Gusti Ngurah Suryantara, (2014), Merancang Aplikasi dengan VB .Net 

2013”, Jakarta : Elex Media Komputindo. 
Uus Rusmawan, (2013), Cara Cepat Belajar VB .Net, Jakarta : Elex 

Media Komputindo. 
Jubilee Enterprise, (2014), Visual Basic 2013 untuk Pemula, Jakarta : 

Elex Media Komputindo. 
WahanaKomputer, ST, (2013), Shortcourse Series : Visual Basic 2012, 

Yogyakarta : Andi Publisher. 
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BAB XII 
MENCETAK PENJUALAN PERPERIODE 

 
12.1  CAPAIAN PEMBELAJARAN 

Capaian pembelajaran Mencetak Penjualan PerPeriode yaitu 
mahasiswa dapat mendesain form untuk memfilter data Penjualan 
PerPeriode dan memahami kode program untuk mencetak data 
Penjualan PePeriode. 

 
12.2  FORM PENJUAIAN PERPERIODE 

  A. DESAIN FORM PENJUALAN PERPERIODE 
Langkah-langkah mendesain Form Penjualan PerPeriode sebagai 
berikut : 
1. Double klik file PRINV.SLN untuk membuka project Inventory 
2. Klik menu Project  ⇒ Add Windows Form  
3. Ketik nama form FORMCETAKJUALPERPERIODE 
4. Klik tombol Add, Buat desain Form Penjualan PerPeriode  

 

 
 

Gambar 12.1 Desain Form Penjualan PerPeriode 
 

Daftar Objek pada Form Penjualan PerPeriode 
 

Komponen Properties Isi 

Label 

Text FORM CETAK PENJUALAN 
PERPERIODE 

Text MULAI TANGGAL 
Text SAMPAI TANGGAL 

ComboBox 
Name TXTMULAI 
Name TXTSAMPAI 
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Button 

Name BTPREVIEW 
Text PREVIEW 
Name BTCLOSE 
Text CLOSE 

DataGridView Name DGVBELI 
PrintDocument Name PDBELI 

 
B. KODE PROGRAM FORM PENJUALAN PERPERIODE 

Klik menu View => Code lalu ketik kode program berikut : 
 

 
Perintah Public untuk membuat variabel Publik supaya variabel 
tersebut dikenal oleh semua sub program. Variabel 
KONEKSISTRING berisi string untuk koneksi ke database, variabel 
KONEKSI untuk membuat koneksi ke database, variabel SQLSTR 
untuk perintah Query, variabel CMD untuk menjalankan perintah 
Query, variabel DA untuk   menampilkan data Pembelian PerFaktur, 
Variabel DR untuk membaca data dari suatu tabel. Variabel BARIS 
untuk menentukan nilai baris data, variabel NOMOR untuk Nomor 
Urut data, variabel FONTJUDUL untuk menentukan ukuran font 
judul lapotan, variabel FONTDATA untuk menentukan ukuran font 
data, variabel KIRI untuk perataan kiri, variabel TENGAH untuk 
perataan tengah dan variabel KANAN untuk perataan kanan, variabel 
XMULAI untuk tanggal awal periode, variabel XSAMPAI untuk 
tanggal akhir periode. 
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Membuat koneksi ke database DBINV,MDB dan membuka koneksi 
database. Mengisi data pada ComboBox TXTMULAI dan 
TXTSAMPAI dengan data Tanggal Pembelian dari tabel JUAL 
 

 
Sub KOSONG untuk mengosongkan ComboBox TXTMULAI dan 
TXTSAMPAI. Sub DGV untuk menampilkan data pada query 
QUERYJUAL ke DataGridView DGVJUAL. Saat form aktif akan 
menjalankan Sub KOSONG dan Sub DGV. 
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Saat diklik Tanggal Mulai, jika data pada ComboBox TXTSAMPAI 
tidak kosong maka data Penjualan sesuai dengan periode yang telah 
ditentukan akan tampil di DataGridView DGVJUAL.  
 

 
Saat diklik Tanggal Sampai, jika data pada ComboBox TXTMULAI 
tidak kosong maka data Penjualan sesuai dengan periode yang telah 
ditentukan akan tampil di DataGridView DGVJUAL. 
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Mendesain judul laporan Tanggal Periode data Penjualan dan judul 
kolom yang terdiri dari Nomor, Nomor Nota, Tanggal, Nama 
Customer, Kode Barang, Nama Barang, Harga Jual, Jumlah dan 
Total. 
 

 
Mencetak data Penjualan sesuai dengan Periode yang ditentukan 
terdiri dari Nomor, Nomor Nota, Tanggal, Nama Customer, Kode 
Barang, Nama Barang, Harga Jual, Jumlah dan Total. Variabel 
TOTAL untuk menghitung Total Penjualan PerPeriode. 
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Saat diklik tombol PREVIEW akan mencetak data Pembelian 
PerPeriode yang sudah didesain. 
 

 
Saat diklik tombol CLOSE akan menutup koneksi database dan 
menutup form. 
 

C. MENCETAK PENJUALAN PERPERIODE 
Cara mencetak data Penjualan PerPeriode : 
a. Klik droplist pada Mulai Tanggal, klik Tanggal Mulai Periode 
b. Klik droplist pada Sampai Tanggal, klik Tanggal Akhir Periode, 

data item barang akan tampil di DataGridView 
c. Klik tombol PREVIEW 

 

 



78 

 

12.3 TUTORIAL MENCETAK PENJUALAN PERPERIODE 
 

 
 

https://youtu.be/iMW0AhYLWpg 
 

12.4 EVALUASI 
Tampilkan data Tanggal pada judul laporan seperti berikut 
 

 
 

12.5 REFERENSI 
I Gusti Ngurah Suryantara, (2014), Merancang Aplikasi dengan VB .Net 

2013”, Jakarta : Elex Media Komputindo. 
Uus Rusmawan, (2013), Cara Cepat Belajar VB .Net, Jakarta : Elex 

Media Komputindo. 
Jubilee Enterprise, (2014), Visual Basic 2013 untuk Pemula, Jakarta : 

Elex Media Komputindo. 
WahanaKomputer, ST, (2013), Shortcourse Series : Visual Basic 2012, 

Yogyakarta : Andi Publisher. 
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BAB XIII 
FORM DATA PEMAKAI 

 
13.1  CAPAIAN PEMBELAJARAN 

Capaian pembelajaran dari Form Data Pemakai yaitu mahasiswa 
memahami struktur tabel Pemakai, dapat mendesain Form Data 
Pemakai, memahami kode program yang digunakan dan cara 
mengoperasikan Form Data Pemakai yang meliputi manambah data 
baru, mengedit data dan menghapus data. 

 
13.2  FORM DATA PEMAKAI 

A. MENDESAIN FORM DATA PEMAKAI 
Langkah-langkah mendesain Form Data Pemakai sebagai berikut : 
1. Buka file database DBINV.MDB 
2. Buat struktur tabel berikut 

 
3. Simpan struktuktur tabel dengan nama PEMAKAI 
4. Tutup program MS Access 
5. Double klik file PRINV.SLN untuk membuka project Inventory 
6. Klik menu Project  ⇒ Add Windows Form  
7. Ketik nama form FORMPEMAKAI 
8. Klik tombol Add, buat Desain Form Pemakai berikut 

 

 
Gambar 13.1 Desain Form Data Pemakai 
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Daftar Objek pada Form Data Pemakai 

 

Komponen Properties Isi 

Label 

Text FORM DATA 
PEMAKAI 

Text KODE PEMAKAI 
Text NAMA PEMAKAI 
Text JABATAN 
Text PASSWORD 

TextBox 

Name TXTKODEPK 
Name TXTNAMAPK 
Name 
PasswordChar 

TXTPASSWORD 
* 

ComboBox 

Name CBJABATAN 

Items 
MANAGER 
ADMINISTRASI 
KEUANGAN 

PictureBox 
Name PBFOTO 
SizeMode StretchImage 

Button 

Name BTSIMPAN 
Text SIMPAN 
Name BTHAPUS 
Text HAPUS 
Name BTBLANKFORM 
Text BLANKFORM 
Name BTCLOSE 
Text CLOSE 

DataGridView Name DGVPEMAKAI 
OpenFileDialog Name OFD 

 
B. KODE PROGRAM FORM DATA PEMAKAI 

Klik menu View => Code lalu ketik kode program berikut : 
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Perintah Public untuk membuat variabel Publik supaya variabel 
tersebut dikenal oleh semua sub program. Variabel 
KONEKSISTRING berisi string untuk koneksi ke database, variabel 
KONEKSI untuk membuat koneksi ke database, variabel SQLSTR 
untuk perintah Query, variabel CMD untuk menjalankan perintah 
Query, variabel DA untuk penghubung data tabel, variabel DT 
menyimpan data hasil perintah query, variabel XFOTO untuk 
menyimpan nama file foto. 
 

 
Saat form dijalankan akan dilakukan koneksi ke database 
DBINV.MDB dan membuka koneksi. 
 

 
Sub KOSONG untuk mengosongkan Textbox input data dan foto 
Pemakai, sub DGV untuk menampilkan data Pemakai ke 
DataGridView DGVPEMAKAI. Saat form aktif akan menjalankan 
sub KOSONG dan sub DGV. 
 

 
Saat PictureBox PBFOTO diklik akan menampilkan window Open 
untuk memilih file gambar yang akan ditampilkan di PictureBox, 
nama file foto disimpan ke variabel XFOTO. 
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Saat kursor meninggalkan Textbox TXTKODEPK akan dideteksi 
apakah Kode Pemakai yang telah diketik sudah ada di tabel Pemakai, 
jika Kode Pemakai sudah ada maka datanya akan ditampilkan ke 
masing-masing Textbox. 
 

 
Saat diklik tombol SIMPAN akan dideteksi apakah Kode Pemakai 
yang akan disimpan sudah ada di tabel Pemakai, jika Kode Pemakai 
sudah ada maka data Pemakai akan diupdate sedangkan jika belum 
ada maka data Pemakai yang diinput akan ditambahkan sebagai data 
baru. 
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Saat diklik tombol HAPUS akan ditampilkan konfirmasi apakah data 
Pemakai yang sedang tampil akan dihapus, jika diklik tombol Yes 
maka data Pemakai yang sedang tampil akan dihapus sedangkan jika 
diklik tombol No data Pemakai tidak akan dihapus. 
 

 
Saat diklik tombol BLANKFORM maka akan menjalankan sub 
BLANKFORM untuk mengosongkan Textbox. 
 

 
Saat diklik tombol CLOSE akan menutup koneksi database dan 
menutup form. 
 

C. MENGOPERASIKAN FORM DATA PEMAKAI 
1. Menambah data Pemakai 

Cara menambahkan data Pemakai : 
a. Klik menu Debug => Start Debugging 
b. Isikan data Kode Pemakai, Nama Pemakai, Jabatan, Foto dan 

Password Pemakai 
c. Klik tombol SIMPAN untuk menyimpan data Pemakai 
 

2. Mengedit data Pemakai 
Cara mengedit data Pemakai : 
a. Klik menu Debug => Start Debugging 
b. Isikan Kode Pemakai yang datanya mau diedit 
c. Tekan tombol Tab (data Pemakai yang kodenya sesuai akan 

tampil) 
d. Lakukan pengeditan data 
e. Klik tombol SIMPAN untuk pengeditan data Pemakai 

 
3. Menghapus data Pemakai 

Cara menghapus data Pemakai : 
a. Klik menu Debug => Start Debugging 
b. Isikan Kode Pemakai yang datanya mau dihapus 
c. Tekan tombol Tab (data Pemakai yang sesuai akan tampil) 
d. Klik tombol HAPUS 
e. Tampil konfirmasi data jadi dihapus atau tidak 
f. Klik tombol Yes jika data jadi dihapus atau klik tombol No 

jika data tidak jadi dihapus 
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13.3 TOTURIAL FORM PEMAKAI 
 

 
 

https://youtu.be/Zf5VeJZxci0 
 

13.4 EVALUASI 
Tampilkan Data Password pada DataGridView dengan karakter * 
supaya tidak diketahui Passwordnya. 

 
 

13.5 REFERENSI 
I Gusti Ngurah Suryantara, (2014), Merancang Aplikasi dengan VB .Net 

2013”, Jakarta : Elex Media Komputindo. 
Uus Rusmawan, (2013), Cara Cepat Belajar VB .Net, Jakarta : Elex 

Media Komputindo. 
Jubilee Enterprise, (2014), Visual Basic 2013 untuk Pemula, Jakarta : 

Elex Media Komputindo. 
WahanaKomputer, ST, (2013), Shortcourse Series : Visual Basic 2012, 

Yogyakarta : Andi Publisher. 
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BAB XIV 
FORM LOGIN PEMAKAI 

 
14.1  CAPAIAN PEMBELAJARAN 

Capaian pembelajaran dari Form Login Pemakai yaitu mahasiswa 
dapat mendesain Form Login Pemakai untuk mengatur hak akses 
Pemakai sesuai jabatannya, memahami kode program yang digunakan 
dan cara mengoperasikan Form Login Pemakai. 

 
14.2  FORM LOGIN PEMAKAI 

A. MENDESAIN FORM LOGIN PEMAKAI 
Langkah-langkah mendesain Form Login Pemakai sebagai berikut : 
1. Double klik file PRINV.SLN untuk membuka project Inventory 
2. Klik menu Project  ⇒ Add Windows Form untuk menambahkan 

form baru 
3. Ketik nama form FORMLOGIN 
4. Klik tombol Add 
5. Buat Desain Form Login Pemakai berikut 

 

 
 

Gambar 14.1 Desain Form Login Pemakai 
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Daftar Objek pada Form Login Pemakai 
 

Komponen Properties Isi 

Label 

Text FORM LOGIN PEMAKAI 
Text KODE PEMAKAI 
Text NAMA PEMAKAI 
Text JABATAN 
Text PASSWORD 

ComboBox Name CBKODEPK 

TextBox 

Name TXTNAMAPK 
Name TXTJABATAN 
Name 
PasswordChar 

TXTPASSWORD 
* 

PictureBox 
Name PBFOTO 
SizeMode StretchImage 

Button 

Name BTLOGIN 
Text LOGIN 
Name BTCLOSE 
Text CLOSE 

 
B. KODE PROGRAM FORM LOGIN PEMAKAI 

Langkah berikutnya klik menu View => Code lalu ketik kode 
program berikut : 
 

 
Perintah Public untuk membuat variabel Publik supaya variabel 
tersebut dikenal oleh semua sub program. Variabel 
KONEKSISTRING berisi string untuk koneksi ke database, variabel 
KONEKSI untuk membuat koneksi ke database, variabel SQLSTR 
untuk perintah Query, variabel CMD untuk menjalankan perintah 
Query, variabel DA untuk penghubung data tabel, variabel DT 
menyimpan data hasil perintah query, variabel XKODEPK untuk 
menyimpan Kode Pemakai yang diklik, variabel XPASSWORD 
untuk menyimpan teks Password yang diinput. 
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Saat form dijalankan akan dilakukan koneksi ke database 
DBINV.MDB dan membuka koneksi. ComboBox CBKODEPK akan 
diisi dengan data Kode Pemakai dan Nama Pemakai dari tabel 
Pemakai. 
 

 
Sub KOSONG untuk mengosongkan ComboBox, Textbox dan foto 
Pemakai. Saat form aktif akan menjalankan sub KOSONG. 
 

 
Saat diklik salah satu Kode Pemakai maka akan dicari Kode Pemakai 
yang diklik pada tabel Pemakai lalu ditampilkan data Nama Pemakai, 
Jabatan dan Foto Pemakai. Password Pemakai disimpan ke variabel 
XPASSWORD dan kursor ditempatkan ke TextBox 
TXTPASSWORD untuk mengisi Password Pemakai. 
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Saat diklik tombol LOGIN akan dideteksi apakah Password yang 
diinput sama dengan Password Pemakai yang disimpan di variabel 
XPASSWORD, jika Password sama maka akan diatur Menu yang 
diaktifkan sesuai dengan Jabatan Pemakai lalu ditampilkan Form 
Menu Utama, jika Password salah tampilkan pesan Password Salah 
dan diberikan kesempatan untuk input Password kembali. 
 

 
Saat diklik tombol CLOSE akan menutup koneksi database dan 
menutup form. 
 

C. MENGOPERASIKAN FORM LOGIN PEMAKAI 
Cara menambahkan data Pemakai : 
a. Klik droplist pada ComboBox Kode Pemakai 
b. Klik salah satu Kode Pemakai, data Nama Pemakai, Jabatan dan 

Foto Pemakai otomatis tampil 



89 

 

c. Isikan Password Pemakai 
d. Klik tombol LOGIN, jika Password yang diisikan benar akan 

tampil form Menu Utama sedangkan jika Password salah akan 
tampil pesan Password Salah dan diberi kesempatan mengisi 
Password kembali. 
 

14.3 TUTORIAL LOGIN PEMAKAI 
 

 
 

https://youtu.be/E6kkgZ1QxLo 
 

 
14.4 EVALUASI 

Tambahkan kode program untuk mendeteksi jika input Password salah 
3 kali tampilkan pesan Password sudah 3 Kali Salah dan form Login 
Pemakai ditutup. 

 
14.5 REFERENSI 

I Gusti Ngurah Suryantara, (2014), Merancang Aplikasi dengan VB .Net 
2013”, Jakarta : Elex Media Komputindo. 

Uus Rusmawan, (2013), Cara Cepat Belajar VB .Net, Jakarta : Elex 
Media Komputindo. 

Jubilee Enterprise, (2014), Visual Basic 2013 untuk Pemula, Jakarta : 
Elex Media Komputindo. 

WahanaKomputer, ST, (2013), Shortcourse Series : Visual Basic 2012, 
Yogyakarta : Andi Publisher. 
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BAB XV 
FORM HAK AKSES 

 
15.1  CAPAIAN PEMBELAJARAN 

Capaian pembelajaran dari Form Hak Akses yaitu mahasiswa 
memahami struktur tabel Hak Akses, dapat mendesain Form Hak 
Akses, memahami kode program yang digunakan dan cara mengatur 
Hak Akses Pemakai menggunakan Form Hak Akses. 

 
15.2  FORM HAK AKSES 

A. MENDESAIN FORM HAK AKSES 
Langkah-langkah mendesain Form Hak Akses sebagai berikut : 

1. Buka file database DBINV.MDB 
2. Buat struktur tabel berikut 

 

 
 

3. Simpan struktuktur tabel dengan nama HAKAKSES 
4. Klik ikon View, isikan data Hak Akses berikut 

 

 
 

5. Tutup program MS Access 
6. Double klik file PRINV.SLN untuk membuka project Inventory 
7. Klik menu Project  ⇒ Add Windows Form untuk menambahkan 

form baru 
8. Ketik nama form FORMHAKAKSES 
9. Klik tombol Add 
10. Buat Desain Form Hak Akses berikut 
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Gambar 15.1 Desain Form Hak Akses 
 

Daftar Objek pada Form Hak Akses 
 

Komponen Properties Isi 

Label 
Text  FORM HAK AKSES 

PEMAKAI 
DataGridView Name DGVAKSES 

Button 
Name BTCLOSE 
Text CLOSE 

 
B. KODE PROGRAM FORM HAK AKSES 

Langkah berikutnya klik menu View => Code lalu ketik kode 
program berikut : 
 

 
Perintah Public untuk membuat variabel Publik supaya variabel 
tersebut dikenal oleh semua sub program. Variabel 
KONEKSISTRING berisi string untuk koneksi ke database, variabel 
KONEKSI untuk membuat koneksi ke database, variabel SQLSTR 
untuk perintah Query, variabel CMD untuk menjalankan perintah 
Query, variabel DA untuk penghubung data tabel, variabel DT 
menyimpan data hasil perintah query.. 
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Saat form dijalankan akan dilakukan koneksi ke database 
DBINV.MDB dan membuka koneksi. 
 

 
Saat form aktif, tampilkan data Hak Akses ke DataGridView 
DGVAKSES. 
 

 
Saat diklik tombol CLOSE akan mengupdate data pada tabel 
HakAkses lalu menutup koneksi database dan menutup form. 
 
Double klik FORMLOGIN, tambahkan kode program berikut : 
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C. MENGOPERASIKAN FORM HAK AKSES 
Cara menambahkan data Pemakai : 
a. Klik menu Debug => Start Debugging 
b. Login dengan jabatan MANAGER 
c. Klik menu Hak Akses => Hak Akses 
d. Lakukan perubahan Hak Akses 
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e. Klik tombol CLOSE 
f. Klik menu Selesai => Keluar Dari Program 
g. Login dengan jabatan selain MANAGER, perhatikan perubahan 

Hak Akses 
 

15.3 TUTORIAL HAK AKSES 
 

 
 

https://youtu.be/Ug173J1cpj4 
 
15.4 EVALUASI 

Buat kode program pada Form Pemakai, jika ada Jabatan baru maka 
akan otomatis menambah data Jabatan pada tabel Hak Akses 

 
15.5 REFERENSI 

I Gusti Ngurah Suryantara, (2014), Merancang Aplikasi dengan VB .Net 
2013”, Jakarta : Elex Media Komputindo. 

Uus Rusmawan, (2013), Cara Cepat Belajar VB .Net, Jakarta : Elex 
Media Komputindo. 

Jubilee Enterprise, (2014), Visual Basic 2013 untuk Pemula, Jakarta : 
Elex Media Komputindo. 

WahanaKomputer, ST, (2013), Shortcourse Series : Visual Basic 2012, 
Yogyakarta : Andi Publisher. 

 
 
 
 



 

Visual Basic .NET merupakan bahasa pemrograman komputer 
berorientasi objek yang diimplementasikan pada .NET 
Framework. Visual Basic .Net merupakan pengembangan dari 
bahasa pemrograman Visual Basic 6.
Buku ini berisi contoh aplikasi Inventory Barang yang terdiri dari 
Form Barang untuk menyimpan data Barang, Form Suplier untuk 
menyimpan data Suplier, Form Pembelian untuk menyimpan 
transaksi Pembelian, Form Customer untuk menyimpan
Customer dan Form Pembelian untuk menyimpan data 
Pembelian. Pembuatan laporan tidak menggunakan program 
bantu tetapi menggunakan komponen 
ada di Visual Basic .Net, laporan yang dibuat yaitu laporan data 
Barang, data Suplier, data Customer, data Pembelian PerFaktur, 
data Pembelian PerPeriode dan data Penjualan PerNota. Form 
Pemakai, form Login dan form Hak Akses digunakan untuk 
mengatur hak akses pemakai dalam mengakses form dan laporan 
yang ada di aplikasi Inventory. Untuk le
pada buku ini terdapat link video pembelajaran untuk masing
masing materi. 
 

Aplikasi Inventory Barang

Dengan Visual Basic .Net
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Visual Basic .NET merupakan bahasa pemrograman komputer 
berorientasi objek yang diimplementasikan pada .NET 
Framework. Visual Basic .Net merupakan pengembangan dari 

ograman Visual Basic 6. 
Buku ini berisi contoh aplikasi Inventory Barang yang terdiri dari 
Form Barang untuk menyimpan data Barang, Form Suplier untuk 
menyimpan data Suplier, Form Pembelian untuk menyimpan 
transaksi Pembelian, Form Customer untuk menyimpan data 
Customer dan Form Pembelian untuk menyimpan data 
Pembelian. Pembuatan laporan tidak menggunakan program 
bantu tetapi menggunakan komponen Print Document yang sudah 
ada di Visual Basic .Net, laporan yang dibuat yaitu laporan data 

data Customer, data Pembelian PerFaktur, 
data Pembelian PerPeriode dan data Penjualan PerNota. Form 
Pemakai, form Login dan form Hak Akses digunakan untuk 
mengatur hak akses pemakai dalam mengakses form dan laporan 
yang ada di aplikasi Inventory. Untuk lebih memahami materi, 

video pembelajaran untuk masing-

Aplikasi Inventory Barang 

Dengan Visual Basic .Net 


